Bug Hunting Session
Bug 100513 - [FILEOPEN] Text after Word Continuous section break pushed to next page on import of DOCX file
Summary: [FILEOPEN] Text after Word Continuous section break pushed to next page on im...
Status: RESOLVED DUPLICATE of bug 90697
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-21 12:25 UTC by Cor Nouws
Modified: 2016-07-04 10:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
orig test file (104.99 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-06-21 12:25 UTC, Cor Nouws
Details
pdf from Word of orig test file (129.19 KB, application/unknown)
2016-06-21 12:26 UTC, Cor Nouws
Details
Screen shot showing Section Break (Continuous) in Word (54.54 KB, image/png)
2016-06-21 12:26 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2016-06-21 12:25:12 UTC
Created attachment 125792 [details]
orig test file

Open attached docx file
Paragraph starting with "Aanleiding" is pushed to page 2
 > Should be on page one, below document header/information

In Word there is a Section Break (Continuous) just above the paragraph that erroneously flows to next page in Writer.

Save as docx, reopen
 > Text is correct on page 1
 
 Save as odt, reopen
 > Text still starts on page 2
Comment 1 Cor Nouws 2016-06-21 12:26:15 UTC
Created attachment 125793 [details]
pdf from Word of orig test file
Comment 2 Cor Nouws 2016-06-21 12:26:57 UTC
Created attachment 125794 [details]
Screen shot showing Section Break (Continuous) in Word
Comment 3 Cor Nouws 2016-06-21 17:12:14 UTC
Mind that the current situation with this document is better than in earlier versions:

3661
"Page 1 broken
headers missing
Content missing?"

4062
Page 1 broken

4153
Page 1 broken

4272
Page 1 broken
Text content pushed to pg 2
Page numbering
Text parts in text box right not bold

4372
Page 1 bit better
content missing

4442
Page 1 OK
"Content missing from half
way page 2"

"formatting in text boxes
right nearly OK"

5.0/5.1
"does not open:
SAXParseException …
Line 2 Column 30391"
"see bug 92157 :
Backportrequest 20160620"

daily20160616
Page 1 OK
Text content pushed to pg 2
Page numbering
"formatting in text boxes
right nearly OK"
"Save & Open > 
Image in headers.."


I've created bug 100514, bug 100515, bug 100516, bug 100524, bug 100525, bug 100526 for the other problems.
Comment 4 Buovjaga 2016-06-26 11:36:47 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: ff25ea3d5ccf3a990767cbb1ef99037d3f84b072
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on June 26th 2016
Comment 5 Cor Nouws 2016-07-04 10:11:01 UTC

*** This bug has been marked as a duplicate of bug 90697 ***
Comment 6 Cor Nouws 2016-07-04 10:11:16 UTC
fixed in 90697 !