Bug 100550 - Adding standard colours to “Font Colour” and “Background Colour” menus
Summary: Adding standard colours to “Font Colour” and “Background Colour” menus
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2016-06-22 14:52 UTC by hakan
Modified: 2016-06-23 15:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Colour Palette (77.76 KB, image/png)
2016-06-22 14:52 UTC, hakan
Details
MS Office - Colour Palette (65.54 KB, image/png)
2016-06-23 08:15 UTC, hakan
Details
Google Docs - Colour Palette (43.50 KB, image/png)
2016-06-23 08:35 UTC, hakan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hakan 2016-06-22 14:52:41 UTC
Created attachment 125838 [details]
Colour Palette

P.S. My English is not excellent, sorry for that. Attached picture can explain my suggestion better.

When I working on LibreOffice, I have difficulties in determining standard colours while changing font colour or background colour. I want to make a text red but which red? Wanna make yellow but which yellow? That’s why  I need a standard colour palette. So, I think that it is going to be so helpful doing an arrangement such as attached picture. My proposal does not have different dimensions from current state for menus. Current menu is large enough, already. So, I just shifted location of “Custom Colour” button.
Comment 1 V Stuart Foote 2016-06-22 19:05:25 UTC
Not sure this makes any sense. What "standard" colors would be used on this persistent swatch list--you'll get just 12 swatches that folks then won't be able to change.

Also, the there are already multiple .soc files, in addition to the default.soc (including the standard.soc), each provides a different approach to layout of color pallet layout, and each provides tool-tip names or color values as appropriate to the pallet.

Just don't see this improving the UX.
Comment 2 Heiko Tietze 2016-06-22 19:29:28 UTC
Agree to disagree. Guess Hakan has "pure" colors in mind like red, blue, green. Right? Nothing to say against such a _palette_, however.
Comment 3 hakan 2016-06-23 08:15:08 UTC
Created attachment 125852 [details]
MS Office - Colour Palette

MS Office has said exactly what I mean. See the attached picture.
Comment 4 hakan 2016-06-23 08:35:36 UTC
Created attachment 125854 [details]
Google Docs - Colour Palette

Google Docs are the same color bar also there. See image 3
Comment 5 Heiko Tietze 2016-06-23 13:53:46 UTC
What are "standard colors" for web design? Background to this question: There is a palette called html.soc with less vibrant colors (just an example to illustrate that there is no standard).
Comment 6 V Stuart Foote 2016-06-23 14:47:49 UTC
Well question is if the GUI needs a bar of swatches--in addition to the currently selected palette, and the swatch bar to hold recently selected colors.

Especially as most of the .soc palettes--including default.soc and standard.soc have the "pure" colors as the first or second row of swatches.

And why a row of "standard" basic colors? Why not a row of blank "favorites", that we drag a swatch onto and it becomes profile persistent?

If we are going to tweak the GUI, at least make it functional.

@hakan, thanks for the clips from Word and Google Docs, but not sure their handling of palettes is any better or worse than LibreOffice's new (at 4.4) color picker.
Comment 7 Heiko Tietze 2016-06-23 15:19:56 UTC
Let me close this ticket as WFM (actually WONTFIX because LibO handles palettes and 'standard colors' differently to Microsoft or Google). In bug 94551 we discuss a new approach to user colors being implemented right now. Feel free to join, Hakan.