Bug 37480 - Changing font colour to custom RGB value is hard
Summary: Changing font colour to custom RGB value is hard
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other All
: high enhancement
Assignee: Krisztian Pinter
URL:
Whiteboard: color_handling target:4.4.0
Keywords:
: 38214 42474 55873 (view as bug list)
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2011-05-22 15:30 UTC by Dave Neary
Modified: 2017-01-12 10:06 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Neary 2011-05-22 15:30:19 UTC
After many years using LibreOffice/OOo I found out today for the first time how to set font colour to a custom RGB colour.

To do this, you need to add a new colour to the palette, via Tools->Options, Colour.

Then in that dialog, the workflow is kind of unintuitive. I clicked on the "Add" button to add a new colour, which was the wrong thing to do - apparently I needed to change the name of the active colour first - then when I clicked "Modify", and set the new RGB colour, then clicked "OK", the colour wasn't saved - I had to click "Modify" first.

I was expecting to see this in the toolbar in the colour drop-down - perhaps a "Custom" button at the bottom of drop-down? Or right-click->Modify in the palette colours? Or even in "Format->Character". But this definitely seems like a context change, rather than a global setting/option.

Dave.
Comment 1 Yifan Jiang 2011-05-22 23:55:55 UTC
In my opinion, good point, but not sure which is the preferred way to do that. 

As a summary:

1. a "Custom" button at the bottom of color drop-down?

2. right-click->Modify in the palette colours? 

3. context based change in "Format->Character"?

4. Redesign current dialog box? 

Anyway it is an Enhancement request.
Comment 2 Yifan Jiang 2011-05-22 23:57:08 UTC
cc Christoph for reviewing, Thanks!
Comment 3 Christoph 2011-05-25 09:12:43 UTC
Hi Dave, thanks for the feedback. Yifan, thanks for the CC!
True, color handling is hard - we are collecting color handling issues at the moment. I'll kindly ask for two weeks patience for some more info how we'll address those issues.

Setting tag "color_handling" to "Whiteboard".
Comment 4 Dave Neary 2011-05-30 10:54:51 UTC
(In reply to comment #0)
> Then in that dialog, the workflow is kind of unintuitive. I clicked on the
> "Add" button to add a new colour, which was the wrong thing to do - apparently
> I needed to change the name of the active colour first - then when I clicked
> "Modify", and set the new RGB colour, then clicked "OK", the colour wasn't
> saved - I had to click "Modify" first.

I realise this is poorly explained... let me try again.

When I get to the colours dialog in the options, my instinct was to hit the "Add" button to add a new colour. But this creates a new colour from the active colours (which is, by default, Blue 8 with RGB (153,204,255) for me) and fails with a "Duplicate entry" error. There's then a pop-up which prompts me for a new colour name.

I put in "Scarlet". I wanted to set it to (61,6,7). So I hit "Modify" to modify the colour, then set the RGB to (61,6,7), the colour looks OK, and I hit "OK" to save is. The problem is that this saves "Scarlet" as (153,204,255), because to save my updated colour, I was supposed to hit "Modify". This also applies if I change the colour with the "Edit" button. I would expect "OK" to save the colour as it is, and "Cancel" to revert to the previously saved colour.

Hope that's clearer. In any case, happy to see the bug report get attention :)

Dave.
Comment 5 Gaetano Giunta 2011-06-13 08:40:46 UTC Comment hidden (me-too)
Comment 6 vitriol 2011-11-01 06:06:38 UTC
*** Bug 42474 has been marked as a duplicate of this bug. ***
Comment 7 Michal Suchanek 2011-11-01 06:47:06 UTC
There are two issues here:

1) adding colors to the palette is separate from using colors to the palette.

This is clearly wrong UI.

2) adding colors to the palette is awkward

I guess this could be solved by 

a) adding/ re-using from toolkit a simple color picker. The current picker is weird and there are existing better pickers in Gtk/Windows/Gimp/.. which could be reused from the underlying platform or ported.

b) add a "Custom ..." option in the color dropdowns which calls this picker.

The picker should have OK or Apply to use the color and "Add to palette" to save the color.

c) if the colors in preferences are to be preserved then there should be an "Add ..." button that invokes the same picker with "Apply" disabled (not visible).
Comment 8 Björn Michaelsen 2013-02-23 19:43:07 UTC
> c) if the colors in preferences are to be preserved then there should be an
> "Add ..." button that invokes the same picker with "Apply" disabled (not
> visible).

This is done by mmeeks work in current releases, for the rest: The description of this bug is still very vague => NEEDINFO
Comment 9 Dave Neary 2013-02-25 17:41:27 UTC
(In reply to comment #8)
> This is done by mmeeks work in current releases, for the rest: The
> description of this bug is still very vague => NEEDINFO

Hi Bjorn,

Can you explain to me how the report is vague, please? It is difficult to change text to a custom colour which is not already in the LO palette. Also background colours, and everywhere else that colours appear in the user interface.

The natural place for a preference like this seems to me to be as a text property in Format->Character (but you are the experts).

Thanks,
Dave.
Comment 10 Kumāra 2013-03-27 07:12:44 UTC
*** Bug 55873 has been marked as a duplicate of this bug. ***
Comment 11 Kumāra 2013-03-27 07:36:02 UTC
I think this deserves to be marked as "high importance".

Björn, the easiest way to understand this is just to have a look at what's available in most word processors, e.g. WordPad.
Comment 12 ign_christian 2013-07-26 14:39:07 UTC
*** Bug 38214 has been marked as a duplicate of this bug. ***
Comment 13 Danixu 2014-06-12 06:59:17 UTC
Is there any plan to add this feature in futures LO? because we're on 4.2.4 and still without them...
Comment 14 Fabian Alexander Wilms 2014-08-21 19:53:16 UTC
This has been added during the GSOC: http://cgit.freedesktop.org/libreoffice/core/log/?h=feature/gsoc14-colors
Comment 15 Samuel Mehrbrodt (CIB) 2014-09-21 16:24:08 UTC
Fixed in http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff17738a4a84ca53782d87da5f63d87a165d19d1

Will be available in LibreOffice 4.4
Comment 16 Samuel Mehrbrodt (CIB) 2014-09-21 16:25:22 UTC
There is a small bounty for this issue, Krisztian, feel free to claim it: https://freedomsponsors.org/issue/257/changing-font-colour-to-custom-rgb-value-is-hard#description
Comment 17 Yousuf Philips (jay) (retired) 2014-09-21 21:03:00 UTC
Thanks Krisztian Pinter for working on this and it seems to be moving in the right direction, though i noticed a few issues i wanted to bring to your attention, encase you weren't aware of it.

1) major: the popup element only appears downwards, so if you are in a toolbar that appears at the bottom of the screen (eg. table toolbar), then you wont be able to do anything with the popup other than clicking the 'no fill' button.

2) medium: with the palette drop down open, the up and down keys dont work and instead move the cursor in the document.

3) medium: when the popup appears, the color palette color area expands, which causes the recent colors area to be shrunk, which causes the recent colors scrollbar buttons to overlap and the recent colors list to be less visible and less easy to click, as they are about ~10px in height.

4) low: in the color picker, if the color is set to ffffff or 000000 and you click on the vertical color spectrum more than once, it wont refresh the color gradient area.

5) low: i think a scrollbar for the palette color list would be suitable, as presently there isnt any indication that their are more colors in the list than what is currently being seen. And if i select a color at the bottom of the scrolled list, when i reopen the popup, it wont show it selected.

6) lowest: the palette drop down is filled with .soc filenames rather than title case palette names.

4) enhancement: i like the color picker, as it resembles the color picker found in photoshop and it would be great if it would also allowed to grab colors from the document, as a user might want a color found in an inserted image.

6) enhancement: i think it would visually easier to understand if both automatic/no fill and color picker were shown as buttons, rather than appearing as buttons when you mouse over them. i also think that placing the color picker next to automatic/no fill is a good idea as there is alot of empty/wasted space having those buttons take up the full width of the popup, and it also brings more attention to the color picker tool, as i missed it the first time i opened up the drop down.

7) enhancement: with the color picker button moved from its location, that location can be taken up by a text label of the currently selected color, along with its hex equivalent, similar to the old color drop down.

Keep up the great work and if you need any more testing/feedback, dont hesitate to contact me.
Comment 18 Yousuf Philips (jay) (retired) 2014-10-19 08:02:59 UTC
Created a meta bug (bug 85184) to deal with bugs related to the new color picker.