Download it now!
Bug 100572 (Sunuosh) - Formula editor (Math) crash when I export from odf to PDF or directly to pdf from interface
Summary: Formula editor (Math) crash when I export from odf to PDF or directly to pdf ...
Status: RESOLVED WORKSFORME
Alias: Sunuosh
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2016-06-23 20:50 UTC by Sunuosh Ibarie
Modified: 2017-02-28 01:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample Math formula document recreated (7.01 KB, application/vnd.oasis.opendocument.formula)
2016-06-24 17:45 UTC, V Stuart Foote
Details
sample Math formula document printed (ghostscrip) to PDF (18.39 KB, application/force-download)
2016-06-24 17:46 UTC, V Stuart Foote
Details
sample Math formula document exported to PDF (43.88 KB, application/force-download)
2016-06-24 17:49 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sunuosh Ibarie 2016-06-23 20:50:21 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36
Build Identifier: LibreOffice 5.1.x and 4.x

When I write in Formula editor (Math) and I want to export the file to a pdf the interface of Math (LibreOffice or Math) crash.

Furthermore, if I export from a interface of Math, and later when LibreOffice crashed, the "LibreOffice Document Recovery" is correctly displayed; but when I click on "OK" sometimes is a new Formula editor file recovered not the original.

And, this I tried only in Windows 8 and 8.1.

Reproducible: Always

Steps to Reproduce:
1. Download the instalator from https://es.libreoffice.org/
2. Install the sofware with personal options
3. Select some dictionaries more and interface languages too
4. finish the instalation
5. Open LibreOffice at Windows 8 or 8.1
6. Open the Formula Editor (Math)
7. Write something at Math (Formula Editor)
8. Export the file (File -> Export...)
9. Math (Formula Editor) is crashed
Actual Results:  
Libre Offices crash, open the recovery wondow and later works normaly again.

Some time open in this point a new odf file not the original.

Expected Results:  
Formula editor (Math) has to export to a PDF

[Information automatically included from LibreOffice]
Locale: es
Module: StartModule
[Information guessed from browser]
OS: Windows (8 and 8.1)
OS is 64bit: yes


Reset User Profile?No
Comment 1 V Stuart Foote 2016-06-23 22:08:54 UTC
Can not confirm with Windows 8.1 Ent 64-bit en-US with
Version: 5.1.4.2 (x64)
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
CPU Threads: 8; OS Version: Windows 6.29; UI Render: GL; 
Locale: en-US (en_US)

Export to PDF via Dialog (File -> Export: PDF) , Export via Toolbar (Export as PDF button), and Print to PDF (Ghostscript 9.18 & CutePDF Writer) all function as expected.

On the PDF export dialog I adjust default and check Range All, Images Lossless Compression--all other options unchecked.

Please clear you user profile and retest with defaults, or as configured above.
Comment 2 Sunuosh Ibarie 2016-06-24 17:29:05 UTC
Please, watch this pics.

This is the odf file
https://sunuosh.files.wordpress.com/2016/06/1-math1.jpg

Iopen the file. Write and do something
https://sunuosh.files.wordpress.com/2016/06/2-math1.jpg

Click on "File"
https://sunuosh.files.wordpress.com/2016/06/3-math1.jpg

Click on "Export..."
https://sunuosh.files.wordpress.com/2016/06/4-math1.jpg

The window to save and click "Save"
https://sunuosh.files.wordpress.com/2016/06/5-math1.jpg

PDF options, and later click on "Export" but...
https://sunuosh.files.wordpress.com/2016/06/6-math1.jpg

... happen this:
https://sunuosh.files.wordpress.com/2016/06/7-math1.jpg

Nornal Recovery
https://sunuosh.files.wordpress.com/2016/06/8-math1.jpg
https://sunuosh.files.wordpress.com/2016/06/9-math1.jpg

Now use the icon:
https://sunuosh.files.wordpress.com/2016/06/10-math.jpg

Click on "Save" and...
https://sunuosh.files.wordpress.com/2016/06/11-math.jpg

... this happen again:
https://sunuosh.files.wordpress.com/2016/06/12-math.jpg

That's happen each time since my first time with LibreOffice (Windows 8). With Fedora 20 I never try it. Later, with windows 8.1 happen again, but I return to Windows 8 and happens yet.
Comment 3 V Stuart Foote 2016-06-24 17:45:37 UTC
Created attachment 125888 [details]
sample Math formula document recreated
Comment 4 V Stuart Foote 2016-06-24 17:46:11 UTC
Created attachment 125889 [details]
sample Math formula document printed (ghostscrip) to PDF
Comment 5 V Stuart Foote 2016-06-24 17:49:10 UTC
Created attachment 125890 [details]
sample Math formula document exported to PDF

On Windows 10 Pro 64-bit en-US with
Version: 5.2.0.1 (x64)
Build ID: fcbcb4963bda8633ba72bd2108ca1e802aad557d
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US)

Can not reproduce. Get clean export to PDF, as well as print to PDF with ghostscript filtering.

Attached the sample document recreated from the linked screenclips.

Please clear user profile and retest.

Also, any change if you disable OpenGL rendering?
Comment 6 MM 2016-06-24 22:47:03 UTC
Unconfirmed with v5.1.4.2 (64bit) under windows 10 x64.
Confirmed with v5.1.4.2 (32 bit) under windows 7 x64.

GL is off, crashes even with new profile.
Comment 7 Xisco Faulí 2017-02-28 01:50:13 UTC
I can no longer reproduce the crash in

Versión: 5.3.0.3
Id. de compilación: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
Subpr. de CPU: 1; Versión de SO: Windows 6.1; Repr. de IU: predet.; Motor de
trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group

Closing as RESOLVED WORKSFORME

Feel free to move it back to NEW if you can still reproduce the issue on your
side.