Download it now!
Bug 100625 - Auto-save scrolls to the cursor, annoying the user
Summary: Auto-save scrolls to the cursor, annoying the user
Status: RESOLVED DUPLICATE of bug 95797
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-26 20:00 UTC by ken
Modified: 2016-06-26 20:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ken 2016-06-26 20:00:19 UTC
This is a major UI breakage/annoyance.

Steps

1. Configure auto-save to the lowest value (1 minute, I believe).
2. Open or author a document that is larger than the viewable window.
3. Put the cursor at the beginning of the document, and press the space bar (so there's an edit it will auto-save).
4. Scroll to the end of the document using the mouse and the scroll bar.
5. Wait until the auto-save interval.


Expected Results

The document should auto-save and whatever was on screen remains as-is.


Actual Results

The document auto-saves, AND ALSO scrolls to where the cursor is.  This is almost NEVER desired behavior.  In fact, I can't think of any time I would want it to do that.
Comment 1 V Stuart Foote 2016-06-26 20:07:27 UTC
Duplicate of bug 95797 which has been fixed--available with 5.2.0

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4fabfb654bc65a564da1162f10f441efce167706&h=libreoffice-5-2

tdf#95797: Don't jump to the cursor position after auto-save.

*** This bug has been marked as a duplicate of bug 95797 ***