Bug 100627 - Create a table, and the cursor disappears
Summary: Create a table, and the cursor disappears
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Tables Text-Cursor
  Show dependency treegraph
 
Reported: 2016-06-26 20:05 UTC by ken
Modified: 2018-12-28 16:48 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ken 2016-06-26 20:05:21 UTC
Whether I create the table with the keyboard (my preference) or the mouse (to provide a more comprehensive bug report), the cursor disappears until I switch away and then back.
Comment 1 Buovjaga 2016-07-02 19:24:11 UTC
Has it always behaved like this or did it start with an update to some version?
Could you copy & paste here the information in your Help - About LibreOffice?
Comment 2 Aron Budea 2016-07-07 13:39:58 UTC
Reproduced with LibreOffice 5.0.5.2, 5.1.4.2, master build (id: 9fee132c18b658c9ea9fb1114c1fefa56b57532a) in Windows 7, with default and GL rendering alike.
Not reproduced with 5.0.0.5. => regression
Comment 3 raal 2016-09-25 20:16:01 UTC
This seems to have begun at the below commit.
Adding Cc: to lgodard.libre@laposte.net; Could you possibly take a look at this one? Thanks

author	Laurent Godard <lgodard.libre@laposte.net>	2015-06-08 08:24:42 (GMT)
committer	Tomaž Vajngerl <quikee@gmail.com>	2015-06-23 06:38:56 (GMT)
commit	187445b2d2885ced92be37ffb11cd2a9bb11f8d6 (patch)
tree	1aef8d03508376156d4f987083a9f148da4602f5
parent	77cc71476bae2b3655102e2c29d36af40a393201 (diff)

e9f64da6cf2df55f4dfa08ab3d999a6f930d2b24 is the first bad commit
commit e9f64da6cf2df55f4dfa08ab3d999a6f930d2b24
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sun Jul 19 17:43:27 2015 -0700

    source sha:187445b2d2885ced92be37ffb11cd2a9bb11f8d6

 git bisect log
# bad: [05d11632892a322664fb52bac90b2598b7fb7544] source sha:5616d22b57a9a5e57d545e912e029162a230829b
# good: [c1efd324c6ad448ac9edb030dc9738b9e6899e4d] source sha:ab465b90f6c6da5595393a0ba73f33a1e71a2b65
git bisect start 'origin/master' 'oldest'
# bad: [97526ab777da7e58ce283c05498262ecdd4d6f7f] source sha:4ea70f87f7a2b61eda6e5ab1f48debf6fcfadc1f
git bisect bad 97526ab777da7e58ce283c05498262ecdd4d6f7f
# bad: [2202cdaa0eae3f646f1285a0ea45934edeb26e8a] source sha:a88bf8fd10c42a15e5d6e66da656889c82b4933a
git bisect bad 2202cdaa0eae3f646f1285a0ea45934edeb26e8a
# good: [1d0a95445c203c11beb1aa5eae844cf178ea0984] source sha:8f324aebfb94c4b2023894121b954ad4f35eb395
git bisect good 1d0a95445c203c11beb1aa5eae844cf178ea0984
# bad: [2ab10dd694f52d975b104db63c74d74affc857cf] source sha:c92853c93e537b75444ea2852777d73390de1b1a
git bisect bad 2ab10dd694f52d975b104db63c74d74affc857cf
# good: [131890245b4ecbfbc397a21035817baf2bbe1f6b] source sha:cd3881d7171b828872db2ed0b3d49b580c3b17d1
git bisect good 131890245b4ecbfbc397a21035817baf2bbe1f6b
# bad: [3926b127c7054a7fe24b0888481bb44f7f880b41] source sha:6a6d7766f49cc283be174aead9785f5a95287be4
git bisect bad 3926b127c7054a7fe24b0888481bb44f7f880b41
# good: [54e97a4be8f62c012717edb3065de98abb6ec65e] source sha:04834f4ad1682e7853536ffcdd9b19a9848c4c70
git bisect good 54e97a4be8f62c012717edb3065de98abb6ec65e
# bad: [4c95545fc6a23b8eec032f2f7de688d1eb749d59] source sha:2a65bf32ec270484dcea4d22d3c93552dc0c24dd
git bisect bad 4c95545fc6a23b8eec032f2f7de688d1eb749d59
# bad: [ba3573b3de0254e4a672db89a8ee11d6a7cff7ee] source sha:cbe3b2fe0b9d745e22a2bf436ce55141b15f9502
git bisect bad ba3573b3de0254e4a672db89a8ee11d6a7cff7ee
# bad: [e9f64da6cf2df55f4dfa08ab3d999a6f930d2b24] source sha:187445b2d2885ced92be37ffb11cd2a9bb11f8d6
git bisect bad e9f64da6cf2df55f4dfa08ab3d999a6f930d2b24
# good: [4b962b6a67aedf70302ea934350b2937a7a8f85b] source sha:70cba374f6862bb6b3568927267fc9e1fe3c0922
git bisect good 4b962b6a67aedf70302ea934350b2937a7a8f85b
# good: [0cb70180b038b9d93d14c0a8c17b26ceddd99161] source sha:a51ac4d2bb8c4f1ea1d4ea7569863e2fb6535b02
git bisect good 0cb70180b038b9d93d14c0a8c17b26ceddd99161
# good: [e222cec2f1d99cdab08c44e0f85d11b75efffbfd] source sha:77cc71476bae2b3655102e2c29d36af40a393201
git bisect good e222cec2f1d99cdab08c44e0f85d11b75efffbfd
# first bad commit: [e9f64da6cf2df55f4dfa08ab3d999a6f930d2b24] source sha:187445b2d2885ced92be37ffb11cd2a9bb11f8d6
Comment 4 Telesto 2018-01-26 17:20:11 UTC
Repro with
Version: 6.1.0.0.alpha0+
Build ID: 80fb8d406ced47e6a2089f0c8ba5c103d2fec91f
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-01-15_05:18:42
Locale: nl-NL (nl_NL); Calc: CL

Pre-requirements:
1. Only happening using the table dialog (CTRL+F12)
2. The sidebar should be enabled
Comment 5 Jim Raykowski 2018-10-01 00:31:28 UTC
Could not reproduce with

Version: 6.2.0.0.alpha0+
Build ID: ae0d1f3af9ae129c3a7d98a544e0c9b0c30659c7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: threaded
Comment 6 Aron Budea 2018-10-01 02:56:40 UTC
Me neither, let's close as WFM.