Download it now!
Bug 100765 - Accelerator menu option "x" used twice in Data Menu
Summary: Accelerator menu option "x" used twice in Data Menu
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2016-07-04 22:22 UTC by Mark Stewart
Modified: 2017-09-01 13:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Stewart 2016-07-04 22:22:31 UTC
In Calc, "Data" menu: "_X_ML Source ..." and "Te_x_t to Columns" both use "x" as the accelerator key.
Comment 1 V Stuart Foote 2016-07-05 19:19:19 UTC
Confirmed on Windows 10 Pro 64-bit en-US with
Version: 5.2.0.1 (x64)
Build ID: fcbcb4963bda8633ba72bd2108ca1e802aad557d
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US)

However there is no functional issue:

<Alt>+D opens Data menu, X passes to XML Source, and second X passes to Text to Columns--when the selected range of cells contains CSV values.

In other words the accelerators work as intended--otherwise believe there is no issue with duplicate accelerators so long as they continue to function, i.e. they do not block each other on a given menu.
Comment 2 QA Administrators 2017-09-01 11:20:32 UTC Comment hidden (obsolete, spam)
Comment 3 V Stuart Foote 2017-09-01 13:50:56 UTC
NAB, duplicated accelerators on a menu are acceptable and behavior of the accelerators on use is correct.