Bug 100849 - Currency icon is hardcoded to “$”, which is inappropriate to locales not using dollars
Summary: Currency icon is hardcoded to “$”, which is inappropriate to locales not usin...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.2.1
Keywords:
Depends on:
Blocks: Icon-Themes
  Show dependency treegraph
 
Reported: 2016-07-11 11:16 UTC by Neil Nation
Modified: 2018-09-26 13:54 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sterling Currency Symbol NOT Dollar (57.62 KB, image/png)
2016-07-11 11:20 UTC, Neil Nation
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neil Nation 2016-07-11 11:16:47 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build Identifier: LibreOffice 5.1.3.2

 The currency icon [$]  ought to use the locale currency symbol e.g. In the UK use [£]

Reproducible: Always




[Information automatically included from LibreOffice]
Locale: en-GB
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Neil Nation 2016-07-11 11:20:20 UTC
Created attachment 126163 [details]
Sterling Currency Symbol NOT Dollar
Comment 2 Adolfo Jayme 2016-07-12 19:52:34 UTC
It’s meant to be a generic icon, but the generic currency symbol, ¤, is not as recognizable. Perhaps one can try to draw some nice coins for this icon instead…
Comment 3 Gülşah Köse 2016-07-15 08:51:21 UTC
High contrast and Oxygen themes uses coins as currency icon. That report is valid for Tango, Tango Testing, Breeze, Sifr and Galaxy theme.
Comment 4 Commit Notification 2016-07-24 08:11:56 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3c4aec158a595826e37652a82c5782433022a7b

tdf#100849 Restore Tango currency-neutral icon

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2016-07-24 14:21:30 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=578fa3dab0db98f0a07cef00b81d4fd3f56d8794&h=libreoffice-5-2

tdf#100849 Restore Tango currency-neutral icon

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2016-09-15 21:01:34 UTC
Hi,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Regards
Comment 7 Adolfo Jayme 2016-09-16 20:44:38 UTC
Hi, Xisco: the above patches only dealt with the Tango theme, but we sill need updated artwork for the Sifr and Breeze themes. That’s why this bug hasn’t been closed.
Comment 8 Yousuf Philips (jay) (retired) 2017-05-26 19:53:38 UTC
Yes i had changed this to a dollar in 5.1 as the old tango icon of coins arent understandable and a dollar symbol is universally understood for currency. Ideally this wouldnt change between locales, but if a locale specific icons is wanted, they should be added into /icon-themes/tango/cmd/[locale folder]/.

@Adolfo: Would have been nice if you had CCed me on this, before reverting part of my patch so it could have been discussed. Will you be reverting your patch or should I?
Comment 9 Adolfo Jayme 2017-05-26 21:03:41 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> Yes i had changed this to a dollar in 5.1 as the old tango icon of coins
> arent understandable and a dollar symbol is universally understood for
> currency.

I can’t agree that *coins* aren’t understood as money. MS Office also uses coins for this action, so the point is moot even if it weren’t about such an obvious, straightforward metaphor.
Comment 10 V Stuart Foote 2017-05-26 21:16:35 UTC
@Jay, Eike, Adolfo *

Maybe rather than static list of icons for world currencies, do something clever and make the button decoration dynamic.

Couldn't we use ICU to assign the ISO 4217 compliant currency for the locale (document or system) such that its Unicode glyph would become basis of SVG button decoration?
Comment 11 Adolfo Jayme 2017-05-26 21:31:57 UTC
To be honest, that seems overkill to me. Nobody other than Jay has complained about the default icons after all the time that OOo and LO has been out. Nobody else seems to find *coins* (let me stress that again) a difficult methaphor to represent *money*.
Comment 12 Yousuf Philips (jay) (retired) 2017-05-27 14:21:43 UTC
(In reply to Adolfo Jayme from comment #9)
> I can’t agree that *coins* aren’t understood as money.

If the coins were clearly seen as coins, like how they look in Galaxy, maybe people would understand it as money, but unfortunately they arent. And that is the in case of the large icons (24x24), while the small icons (16x16) are even more difficult to understand.

> MS Office also uses
> coins for this action, so the point is moot even if it weren’t about such an
> obvious, straightforward metaphor.

No MS Office uses the dollar sign in all Excel versions I have installed (2003, 2007, 2010, 2013).

2003 - http://www.free-downloads.us/wp-content/uploads/2012/06/Microsoft-Excel-2003-Free.gif

2010 - http://weborb.gcflearnfree.org/weborbassets/uploads/ID_82/workbook_2.png

2013 - http://blog.directionstraining.com/wp-content/uploads/2013/03/Excel2013-3.png

I've see a few screenshots online of Excel using a paper bill with coins, though not sure when this would appear.

http://www.asap-utilities.com/screenshots/excel-application/excel-country31-version11.png

http://www.excel2013.info/wp-content/uploads/2012/10/Excel_2013_Interface_Modern_UI.png

Google Docs uses a dollar sign[1] and Gnumeric uses paper bill with coins[2].

[1] http://www.techf5.com/pic/ms-excel-online-2.png
[2] http://cdn.ilovefreesoftware.com/wp-content/uploads/2010/08/Gnumeric.png

(In reply to Adolfo Jayme from comment #11)
> Nobody other than Jay has
> complained about the default icons after all the time that OOo and LO has
> been out.

People do complain about the default icons, but they dont come to bugzilla to complain about it, as can be seen with our old chart icon in bugs 82272 comment 1. I've heard complaints about the default icons from QA members on IRC as well, which is why I bothered to improve our default icons[3]. Many users choose to use another icon theme as they prefer the metaphors used there. Also the 'Classic' icon theme, which was round in the OOo days, had a dollar sign next to the coins for easier clarity.

[3] https://redmine.documentfoundation.org/boards/1/topics/333

> Nobody else seems to find *coins* (let me stress that again) a
> difficult methaphor to represent *money*.

If it were a single coin icon like this[4] or two coins like this[5], it would be easier to understand both as a small and large icon, but a stack of coins is not understandable with our icon sizes and wont be easy to design in other icon themes like breeze and sifr.

[4] http://icons.iconarchive.com/icons/custom-icon-design/pretty-office-11/512/coin-us-dollar-icon.png
[5] http://ku703611.bplaced.net/Ranchet_Dev/FEAUTRE_REQUEST_HP_FOCUS_MOUSE/gold/Gold-coins-icon.jpg
Comment 13 Heiko Tietze 2017-05-27 20:09:40 UTC
I'm primed to euro, the dollar symbol looks very similar to paragraph to me. People from the U.K. may prefer a pound sign, the yen is something completely different, etc. Let's understand currency as a symbol that we have to identify independent from the locale setting, similar to languages and flags. That means we require _one_ symbol that stands for money - Donald Duck maybe?
Here are some better ideas https://thenounproject.com/search/?q=money
Comment 14 Yousuf Philips (jay) (retired) 2017-05-27 21:04:42 UTC
(In reply to Heiko Tietze from comment #13)
> I'm primed to euro, the dollar symbol looks very similar to paragraph to me.

Not sure how $ looks similar to ¶ though.

> People from the U.K. may prefer a pound sign, the yen is something
> completely different, etc.

Yes many users would prefer to see their local currency symbol used on the 'Format as Currency' button, but i doubt that people are going to spend time creating icons for each locale and in all icon themes.

> Let's understand currency as a symbol that we
> have to identify independent from the locale setting, similar to languages
> and flags.

The dollar sign is quite universal when it comes to money/currency[1] and is visible in most keyboard layouts with Shift+4. Many currencies use the dollar sign as or within their currency symbol[2] and the sign is used by 4 out of the top 10 traded currencies[3].

[1] https://en.wikipedia.org/wiki/Dollar_sign
[2] https://en.wikipedia.org/wiki/Dollar
[3] https://en.wikipedia.org/wiki/Template:Most_traded_currencies

> That means we require _one_ symbol that stands for money - Donald Duck maybe?

I think you mean Scrooge McDuck. :D
https://en.wikipedia.org/wiki/Scrooge_McDuck

> Here are some better ideas https://thenounproject.com/search/?q=money

Most of the icons either contain a bill or a dollar sign, but lets not forget that we need something that looks good at large (24x24) and small (16x16) icon sizes.
Comment 15 Heiko Tietze 2017-05-28 09:17:47 UTC
(In reply to Yousuf Philips (jay) from comment #14)
> Not sure how $ looks similar to ¶ though.

Typical false friend. I meant the section sign ("paragraph" in German) § which is also close to $ on the keyboard.

> I think you mean Scrooge McDuck. :D
> https://en.wikipedia.org/wiki/Scrooge_McDuck

Him, and I'd have another real person in mind too.
 
> > Here are some better ideas https://thenounproject.com/search/?q=money
> 
> Most of the icons either contain a bill or a dollar sign, but lets not
> forget that we need something that looks good at large (24x24) and small
> (16x16) icon sizes.

What we need are ideas for money without localized signs, bills, and coins. And if we don't find a better icon we should keep the dollar symbol.
Comment 16 andreas_k 2017-05-28 15:05:58 UTC
Would it be a problem to localize the icon?
Comment 17 V Stuart Foote 2017-05-28 17:16:58 UTC
(In reply to andreas_k from comment #16)
> Would it be a problem to localize the icon?

+1 -- as in comment 10, seems to me Unicode already provides the glyphs needed in a consistent format by font as appropriate per locale to decorate the button widget with the currency symbol as SVG.  Aren't we already doing similar to provide the Emoji as thunmbnail views for the Emoji toolbar widget?

The SVG could be styled with stroke & fill color and a line weight appropriate to blend with the active icon theme.
Comment 18 Heiko Tietze 2017-05-28 17:45:33 UTC
(In reply to V Stuart Foote from comment #17)
> (In reply to andreas_k from comment #16)
> > Would it be a problem to localize the icon?
> 
> +1 -- as in comment 10, seems to me Unicode already provides the glyphs...

That would add some overhead http://www.xe.com/symbols.php
Comment 19 Heiko Tietze 2017-05-28 17:47:32 UTC
Here is a better link https://stackoverflow.com/questions/15000102/is-there-an-iso-standard-for-currency-symbols, 2nd answer.
Comment 20 V Stuart Foote 2017-05-28 18:58:41 UTC
(In reply to Heiko Tietze from comment #19)
> Here is a better link
> https://stackoverflow.com/questions/15000102/is-there-an-iso-standard-for-
> currency-symbols, 2nd answer.

Think we'd be looking at what ICU provides to parse the font symbols against the ISO 4217:2015 currency codes and currency number--either getName() or getSymbol() by locale

http://userguide.icu-project.org/formatparse/numbers
http://www.icu-project.org/apiref/icu4j/index.html?com/ibm/icu/util/Currency.html

While for Android, Google provides their own getSymbol()
https://developer.android.com/reference/java/util/Currency.html

@Eike?
Comment 21 andreas_k 2017-05-28 19:16:54 UTC
I'm against render the currency by a font, cause the font didn't follow the guideline of the icon themes. Breeze offer an icon that can be used for currency and is usable for all contries https://github.com/KDE/breeze-icons/blob/master/icons/actions/24/taxes-finances.svg
Comment 22 V Stuart Foote 2017-05-28 22:15:09 UTC
(In reply to andreas_k from comment #21)
> I'm against render the currency by a font, cause the font didn't follow the
> guideline of the icon themes. Breeze offer an icon that can be used for
> currency and is usable for all contries
> https://github.com/KDE/breeze-icons/blob/master/icons/actions/24/taxes-
> finances.svg

Understand the reluctance, but frankly the generic "bank note" taxes-finances.svg is even less readable than the old "piles of coins". 

Guess we could define an icon for "every" ISO 4217:2015 locale/currency--but doing it once per build at compile time with the ICU libraries, if possible, seems more maintainable.

Maybe adding a full set of appropriate glyphs (to match the ICU mappings to Currency code/number) for the currency symbols to OpenSymbol would provide a common graphic to style against--and would allow us to localize the button. Also for locales without single graphical currency symbol, to pre-compose the preferred currency symbol and use as PUA addressed Unicode.
Comment 23 Eike Rathke 2017-05-29 07:46:58 UTC
(In reply to V Stuart Foote from comment #20)
> Think we'd be looking at what ICU provides to parse the font symbols against
> the ISO 4217:2015 currency codes and currency number--either getName() or
> getSymbol() by locale

It wouldn't even need ICU for that because for all locales we support we already have each ISO currency code or rather the currency symbol in our locale data which matches the currency format that is applied when clicking the button. See the <Currency> elements in i18npool/source/localedata/data/*.xml which can be obtained through UNO API or the LocaleDataWrapper class.

However, pre-generating 250 currency icons or generating an icon on the fly whenever you change the office locale I'd also name a bit overkill.. anyway, if someone wants to work on it and can solve the problem how to generate a proper icon suiting the theme and somehow store it in the user configuration so that it gets used by the UI, or load a pre-generated icon matching the current work locale, then why not..

I'm not sure if "localizing" the button for the UI locale helps anything, because what you get when clicking the button is not the currency format of the UI locale but the work locale instead. But matching the UI locale might be better than nothing for people who complain about this as they likely work in the same locale as their UI locale.
Comment 24 Yousuf Philips (jay) (retired) 2017-05-30 00:15:36 UTC
This issue is getting really complicated when the simple solution is to find an icon metaphor that works.

The current 'pile of coins' icon doesnt work and i vote for the return of the dollar sign icon I created because of all the points i've already mentioned and its also available in sifr and breeze. As i created it in gimp, the icon is to be created in inkscape by a designer whenever they show up.

The other option is the bank note and we can add the dollar sign in the middle to give it more readability and we'd have to get someone to design it for tango, as it wont work for breeze or sifr.
Comment 25 Eike Rathke 2017-05-30 07:12:03 UTC
What about a bank note *AND* a coin?
Comment 26 Heiko Tietze 2017-05-30 07:33:35 UTC
If we go we the symbol solution independent from the locale it's up to the icon designer how the currency is represented. Breeze has an icon, and this icon likely not changes because of LibreOffice. Sifr may use coins and bills, and Tango the dollar sign. In the end the icon set has to have a harmonic appearance and the user decides what she wants to use.
If we go with a locale dependent solution we are in charge of making it nice. That could be bold font for Sifr, Serif/Sans etc. Doubt that works ultimately. We can also request a number of localized icons from the designers - again it's up to them how they look.
So the discussion is not bill, coin, or another more creative solution.
Comment 27 andreas_k 2017-05-31 22:54:04 UTC
I think with 5 symbols (Dollar, Euro, Pound, Rubel, Japan Yen and China Yuan (same)) you can fit 90% of the world and if someone else want to have another symbol, why not.

So I would add to breeze dollar as default and euro, pound, rubel, yen for different countries.
Comment 28 Heiko Tietze 2017-06-01 09:33:46 UTC
(In reply to andreas_k from comment #27)
> I think with ... you can fit 90% of the world...

This approach is doomed to failure. You totally neglect south america, for instance, or force them to use dollar. And even with peso, real, and bolivar there are many more currencies and peoples who don't want to be forgotten.
Comment 29 andreas_k 2017-06-01 09:42:56 UTC
according to your link to http://www.xe.com/symbols.php brazil, chille, argentinia has use the dollar SYMBOL. But it's right, with 5 icons you can't fit the world.
Comment 30 jonathon 2017-06-01 10:19:54 UTC
I'd suggest adding the glyph for the Rupee ₹, and the Rand R, to the list of Dollar $, Euro €, Pound £, Ruble ₽, and Yen/Yuan ¥. 

There is no Unicode glyph for the Argentinian Peso --- the glyph for it has two vertical bars.
Comment 31 Heiko Tietze 2017-06-01 12:21:35 UTC
We talked in the design meeting about this and came to the conclusion of one icon for currency, in general. It's up to the icon designer to find a creative solution with a bill, coins, or whatever that doesn't use a particular currency sign.

So if Tango uses $ instead of £ it's NOTOURBUG.
Comment 32 Yousuf Philips (jay) (retired) 2017-06-01 18:29:47 UTC
(In reply to Heiko Tietze from comment #31)
> We talked in the design meeting about this and came to the conclusion of one
> icon for currency, in general. It's up to the icon designer to find a
> creative solution with a bill, coins, or whatever that doesn't use a
> particular currency sign.

I think there is some confusion as if a designer wants to include a currency sign on a bill or coin, that is fine.

> So if Tango uses $ instead of £ it's NOTOURBUG.

Yes we need to close this bug, but Adolfo reverted the dollar sign tango icon back to the old coins icon, so this needs to be reverted.
Comment 33 Heiko Tietze 2018-02-20 16:19:01 UTC
(In reply to Yousuf Philips (jay) (retired) from comment #32)
> Yes we need to close this bug, but Adolfo reverted the dollar sign tango
> icon back to the old coins icon, so this needs to be reverted.

Don't see need for this when it's a NOB. Up to Adolfo how the icon is designed, and actually the issue with dollar sign is not existent anymore.