Download it now!
Bug 100859 - Windows close window shortcut overridden (Alt-F4)
Summary: Windows close window shortcut overridden (Alt-F4)
Status: RESOLVED DUPLICATE of bug 97908
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2016-07-11 23:24 UTC by Zane
Modified: 2017-04-17 16:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zane 2016-07-11 23:24:27 UTC
When using the standard Windows keyboard shortcut to close a window/application (Alt-F4), Libre Office Calc and Writer do not close. This may also happen with the other Libre Office apps, but I do not use them. When hitting the Alt-F4 combo, Calc and Writer just do what they are configured to do when someone hits F4 (i.e. for calc, alternates between relative and absolute references, and for writer, shows the data sources pane). Some Linux distros use Alt-F4 as a close window shortcut as well, but I haven't tried the 5.1+ on them to see if it suffers from the same problem.

This shortcut is used by people who do not use the mouse as much (such as visually impaired users) and should be available.

Thank you!
Comment 1 V Stuart Foote 2016-07-12 14:14:01 UTC
Can not confirm. The Alt+F4 performs the .uno:Quit as expected.

On Windows 10 Pro 64-bit en-US with
Version: 5.2.0.1 (x64)
Build ID: fcbcb4963bda8633ba72bd2108ca1e802aad557d
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US)

The .uno:Quit (F4_MOD2)|(Q_MOD1), .uno:CloseDoc (F4_MOD1), and .uno:CloseWin (W_MOD1) function as intended and the short-cut assignments are intact in source.

And for specific locations where document control might take precedent over the frame (I could not find a specific case), entering an F10 key would move focus to where Alt+F4, Ctrl+F4, Ctrl+W, or Ctrl+Q function as desired.

=-ref-=
Shortcuts - Accelerators

http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/Accelerators.xcu#7178

http://opengrok.libreoffice.org/xref/core/vcl/source/window/keycod.cxx#37
Comment 2 dan 2017-04-05 00:56:20 UTC
I've had this issue for a while as well. I only use Calc and Writer and it's only an issue with Calc for me. Also, most importantly, this issue only applies to the right alt key. Left Alt+F4 works as expected for me.
Comment 3 Buovjaga 2017-04-17 16:24:36 UTC

*** This bug has been marked as a duplicate of bug 97908 ***