Bug 100988 - Loss of color selections in cells after saving to Excel XLSX format
Summary: Loss of color selections in cells after saving to Excel XLSX format
Status: RESOLVED DUPLICATE of bug 95231
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-18 15:51 UTC by Alexander Lukashev
Modified: 2016-07-21 07:16 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (Before LibreOffice saving). (12.00 KB, application/vnd.ms-excel)
2016-07-18 15:51 UTC, Alexander Lukashev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Lukashev 2016-07-18 15:51:19 UTC
Created attachment 126284 [details]
Sample file (Before LibreOffice saving).

Hello,

I have tried to fill a table with a script which allow a possibility of colour highlighting depending of filled values. The page is looking good before LibreOffice saving: http://screencast.com/t/bsmAlLl49u But it looks wrong after LibreOffice saving: http://screencast.com/t/wPw41X4TkhB -- no colour highlight.

Please try to save and reopen file from attachment. Would you please tell me what's the problem?

LibreOffice info.

Version: 5.1.4.2
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
CPU Threads: 2; OS Version: Mac OS X 10.11; UI Render: default; 
Locale: en-US (en.UTF-8)

With Best Regards,
Alexander.
Comment 1 Alex Thurgood 2016-07-19 10:41:30 UTC
@Alexander : please provide precise steps for reproducing the problem.

The attached file you provided is an Excel file. Does the conditional formatting work if you save as ODS (Calc) ?

Setting needinfo.
Comment 2 Alexander Lukashev 2016-07-19 11:03:52 UTC
Hello Alex,

Thank you for the reply.

> The attached file you provided is an Excel file. Does the conditional formatting work if you save as ODS (Calc) ?
Yes, it is. The problem has reproduced when I try to save the file as Excel.

Steps for reproducing:
1) Please, open the sample file.
2) Please, save file as MS Excel 97-2003.
3) Please, close the current file.
4) Please, open new file -- no colour highlighting.

If you have any questions, please feel free to ask.

With Best Regards,
Alexander.
Comment 3 Alex Thurgood 2016-07-21 07:14:37 UTC
Pretty certain this is a DUP, but will check.
Comment 4 Alex Thurgood 2016-07-21 07:16:15 UTC

*** This bug has been marked as a duplicate of bug 95231 ***