Download it now!
Bug 101109 - FILESAVE Exporting a Sheet containing a scrollbar control to XLS will result in dysfunctional slider having 0 max value.
Summary: FILESAVE Exporting a Sheet containing a scrollbar control to XLS will result ...
Status: RESOLVED DUPLICATE of bug 48183
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xls
Depends on:
Blocks: Scrollbars
  Show dependency treegraph
 
Reported: 2016-07-25 12:43 UTC by Christian Fries
Modified: 2019-10-22 14:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Original file (pre export) (7.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-07-25 12:43 UTC, Christian Fries
Details
Result file (after exporting) (5.50 KB, application/vnd.ms-excel)
2016-07-25 12:44 UTC, Christian Fries
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Fries 2016-07-25 12:43:28 UTC
Created attachment 126397 [details]
Original file (pre export)

Exporting a Sheet containing a slider (form) to XLS will result in dysfunctional slider having 0 max value.

To reproduce the error:
- Create a LibreOffice Spreadsheet.
- Create a scrollbar (control/form) and link it to a cell (say A1). By default the scrollbar will have min = 0, max = 100, step = 1.
- Export the sheet to XLS
- Opening the sheet in Excel, the scrollbar will have min = 0, max = 0, step = 1.
Comment 1 Christian Fries 2016-07-25 12:44:37 UTC
Created attachment 126398 [details]
Result file (after exporting)
Comment 2 Buovjaga 2016-08-03 19:38:51 UTC
Reproduced with attachment 126397 [details]

Win 8.1 32-bit
MSO 2013
LibO Version: 5.3.0.0.alpha0+
Build ID: 9f8f6e032a61beaddeaa3bf3bb0ed08581c15b17
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-08-03_08:09:13
Locale: fi-FI (fi_FI); Calc: group
Comment 3 QA Administrators 2018-02-13 03:33:54 UTC Comment hidden (obsolete)
Comment 4 stragu 2018-02-13 11:36:57 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2018-02-19 15:20:44 UTC
I found a dupe (where I had even commented myself...)

*** This bug has been marked as a duplicate of bug 48183 ***
Comment 6 stragu 2018-02-20 04:09:23 UTC
Sorry about that comment, I forgot I had to activate the design mode... Please disregard, the behaviour has not changed.
Comment 7 stragu 2019-10-22 14:09:57 UTC Comment hidden (obsolete)