Download it now!
Bug 101111 - Additional points in custom shape, if anti-aliasing is off
Summary: Additional points in custom shape, if anti-aliasing is off
Status: RESOLVED DUPLICATE of bug 37559
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2016-07-25 14:29 UTC by Regina Henschel
Modified: 2016-09-22 11:34 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Shape, which shows the additional dots (32.54 KB, application/vnd.oasis.opendocument.graphics-flat-xml)
2016-07-25 14:29 UTC, Regina Henschel
Details
Screenshot showing the problem (68.11 KB, image/png)
2016-07-25 14:30 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2016-07-25 14:29:10 UTC
Created attachment 126399 [details]
Shape, which shows the additional dots

Open attached document in current master. Make sure, that in your settings neither OpenGL nor Anti-aliasing is enabled. Notice, that the custom shape has additional dots left-top and right-buttom.

It has been OK in
Version: 5.3.0.0.alpha0+
Build ID: fc95bc132db20e7701088c76da6ec039031feadf
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-07-06_12:20:17
Locale: de-DE (de_DE); Calc: group

and fails in
Version: 5.3.0.0.alpha0+
Build ID: 4da8378302093dd3e3dc3e201ac5e188c55f8009
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-07-22_13:59:23
Locale: de-DE (de_DE); Calc: group

Because it had been OK three weeks ago, I do not think, that it is a direct duplicate to bug #37559. But it might be related.
Comment 1 Regina Henschel 2016-07-25 14:30:03 UTC
Created attachment 126400 [details]
Screenshot showing the problem
Comment 2 Regina Henschel 2016-07-25 14:42:50 UTC
I get these points too in
Version: 5.3.0.0.alpha0+
Build ID: b0d96a82a4f6a0832d03d185f4a53db669adcc99
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-07-12_09:25:31
Locale: de-DE (de_DE); Calc: group
Comment 3 Heiko Tietze 2016-07-26 09:41:10 UTC
I get the artifacts at the pages pane but never on the view. So half-confirmed. It depends on anti-aliasing, when this feature is checked (which is on by default) the will-o'-the-wisps are gone.

Similar issues have been reported in bug 101032 for 5.2. Duplicate?
Comment 4 Regina Henschel 2016-07-26 09:53:48 UTC
There are problems with additional points, which are drawn on the page pane and in pdf export. And these additional points should be removed. But this issue is about the problem, that I see the points in the normal working area, if I use a _current_ 5.3 build. Which version do you have used? Perhaps the problem is specific for Windows?
Comment 5 Heiko Tietze 2016-07-26 09:55:41 UTC
(In reply to Regina Henschel from comment #4)
> Which version do you have used?

Oops, forgot to mention:

Version: 5.3.0.0.alpha0+ (x64)
Build ID: f536a83d51443d19dba58157cea28fb67a090e02
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-06-13_01:19:21
Locale: de-DE (de_DE)

(Could retry with Linux versions this evening)
Comment 6 Buovjaga 2016-08-05 15:16:21 UTC
Confirmed, even with antialiasing enabled. It is ok in 5.2.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.4
Build ID: 5.2.0-1
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: f3d26af51588af441f62fb69bb7a5432845226ac
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on August 5th 2016
Comment 7 Xisco Faulí 2016-09-13 16:53:36 UTC
Regression introduced in range 7289a140fc68dc898ba2b2357cc960968195f236..766524b13b3e69cc16cf19b826f62222d7f15ea5
Comment 8 Aron Budea 2016-09-17 00:30:42 UTC
Xisco, that range points to somewhere around 5.1 branch point.

I bibisected with Nortbert's recent 5.3 repo, with antialiasing turned off.
With antialiasing on, I get the extra points even from the first commit in the repo (5b168b3fa568e48e795234dc5fa454bf24c9805e).

Results:

6c2d8e28a0e17636079b0587bfeffe3461434a40 is the first bad commit
commit 6c2d8e28a0e17636079b0587bfeffe3461434a40
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Sat Sep 10 19:47:01 2016 +0200

    source sha:4609380bb0bde0d4437b72b752c1c24ee2950361


# bad: [4407a23f278bbf4c8031f85563844430c43dfd7e] source sha:e5981249db34db2367bae2a2f3e7e8d9f8bd09a0
# good: [09613c3ea582c72cd064e1627766e3e96c196ebf] source sha:5b168b3fa568e48e795234dc5fa454bf24c9805e
git bisect start '4407a23f278bbf4c8031f85563844430c43dfd7e' '09613c3ea582c72cd064e1627766e3e96c196ebf'
# bad: [7c0cd7c913557bac842bf0fa03ae9d84e8c9e605] source sha:c4cb83504faa1d241a116001fd27f7148de300ba
git bisect bad 7c0cd7c913557bac842bf0fa03ae9d84e8c9e605
# good: [7d5da20c2a49e40cb3a001657aaf95272952533c] source sha:511f6f85d90884f864b5bf42eedb758841f72957
git bisect good 7d5da20c2a49e40cb3a001657aaf95272952533c
# good: [8d6f0849b9dd159efd5ce1ae14f350edfec30e34] source sha:9742ee52a842653f7118c4ad8e38c02a6e43e97a
git bisect good 8d6f0849b9dd159efd5ce1ae14f350edfec30e34
# good: [a92e02282cbe008367b87daec7f5209fe1f9237c] source sha:646aabc06c4bd10b2dbf9ac83ccb5c7ea1cc7283
git bisect good a92e02282cbe008367b87daec7f5209fe1f9237c
# bad: [a0f2f5d2f0ba57425b0e3589c6c31b16d2adef0e] source sha:30f81c01d247cdffa0de86367d5f2be80887a251
git bisect bad a0f2f5d2f0ba57425b0e3589c6c31b16d2adef0e
# bad: [d92200a1f335834338bef9d7c52a561c827a6782] source sha:84059c853f15e0e3b1433193e8136350869c23d7
git bisect bad d92200a1f335834338bef9d7c52a561c827a6782
# good: [b0f513536bd6441d433edc53a472673953860b99] source sha:9f0766917a4fb1bc8fe1786c3b46132dd63c1c66
git bisect good b0f513536bd6441d433edc53a472673953860b99
# bad: [6b0465ba3caed81ff3e6bec2c8e21b35c48a1df4] source sha:9d1f51307d61d0b9a8a8e4847b9e7e5c0177322e
git bisect bad 6b0465ba3caed81ff3e6bec2c8e21b35c48a1df4
# bad: [692dd9c0cefd174122f489120dae725a7a11f3de] source sha:00a9f80948d27bcc031969902aedd5fbfa08eaca
git bisect bad 692dd9c0cefd174122f489120dae725a7a11f3de
# bad: [6c2d8e28a0e17636079b0587bfeffe3461434a40] source sha:4609380bb0bde0d4437b72b752c1c24ee2950361
git bisect bad 6c2d8e28a0e17636079b0587bfeffe3461434a40
# good: [6dddab66e418d6c1f08b430a8931cb04b1837070] source sha:3dc8ee7d8eec40093af5df3113ef226bc59220ff
git bisect good 6dddab66e418d6c1f08b430a8931cb04b1837070
# good: [908339fdf0b5331aa426f4cef3d532b1b9ed7aff] source sha:c1f476d91805e6a9573bba3ea8f5f980e0ea7b54
git bisect good 908339fdf0b5331aa426f4cef3d532b1b9ed7aff
# first bad commit: [6c2d8e28a0e17636079b0587bfeffe3461434a40] source sha:4609380bb0bde0d4437b72b752c1c24ee2950361
Comment 9 Aron Budea 2016-09-17 00:32:12 UTC
Armin, bibisecting points to your commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=4609380bb0bde0d4437b72b752c1c24ee2950361

Can you please take a look? Thanks!
Comment 10 Armin Le Grand 2016-09-22 08:02:59 UTC
This is an old error which comes from a BugFix originally from Thorsten, problems with the BoundRect of rotated objects in slideshow. It's in EnhancedCustomShape2d.cxx, commit f64ef72743e55389e446e0d4bc6febd475011023. It exists since 2010 and I was always unhappy with that 'hack' (as named in the comment in the cxx file). It does not only show, but is in the way for numerous things - geometric changes, 3D conversion, ...
Thus I have this on the radar but did not manage to recreate the original error yet.
Comment 11 Armin Le Grand 2016-09-22 08:11:16 UTC
Going back to the description and screenshot from comment 1 I would say it's the mentioned #37559. I checked the bibisected change, that is for pattern fill and should not add points to CustomShapes (which have no pattern fill)
Comment 12 Thorsten Behrens (CIB) 2016-09-22 11:34:57 UTC

*** This bug has been marked as a duplicate of bug 37559 ***