Bug Hunting Session
Bug 101129 - Message [placeholder for message] at end of find bar
Summary: Message [placeholder for message] at end of find bar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.3 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2016-07-26 11:08 UTC by B.J. Herbison
Modified: 2019-11-07 10:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Displaying [placeholder for message] (53.92 KB, image/png)
2016-07-26 11:08 UTC, B.J. Herbison
Details
After search key not found (54.55 KB, image/png)
2016-07-26 11:09 UTC, B.J. Herbison
Details

Note You need to log in before you can comment on or make changes to this bug.
Description B.J. Herbison 2016-07-26 11:08:53 UTC
Created attachment 126413 [details]
Displaying [placeholder for message]

Actual result:

At the end of the search bar is two right angle brackets (when the window is narrow enough). Clicking that symbol displays the message "[placeholder for message]".

After a search finds no results the two right angle brackets are still displayed but clicking has no effect.

See the attached screen shots.

Expected result:

* The text [placeholder for message] is never displayed.
* The two right angle brackets are never displayed unless clicking them will display useful information.

Observed on 5.1.4.2 on Ubuntu and 5.2.0.3 on Windows 7.
Comment 1 B.J. Herbison 2016-07-26 11:09:24 UTC
Created attachment 126414 [details]
After search key not found
Comment 2 Julien Nabet 2016-07-26 15:35:09 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

ux-team: what is expected here?
Comment 3 Samuel Mehrbrodt (CIB) 2016-07-26 16:02:34 UTC
It should show something like "search key not found".
Bibisect appreciated.
Comment 4 Julien Nabet 2016-07-26 16:29:31 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #3)
> It should show something like "search key not found".
> Bibisect appreciated.

Even, if there was no search made?
Indeed, i can see the "placeholder" message without having done any search.
Comment 5 Samuel Mehrbrodt (CIB) 2016-07-28 10:41:23 UTC
(In reply to Julien Nabet from comment #4)
> Even, if there was no search made?
> Indeed, i can see the "placeholder" message without having done any search.

No, nothing should appear then. Does the real message appear after searching?
Comment 6 Julien Nabet 2016-07-28 14:54:06 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #5)
> (In reply to Julien Nabet from comment #4)
> > Even, if there was no search made?
> > Indeed, i can see the "placeholder" message without having done any search.
> 
> No, nothing should appear then. Does the real message appear after searching?

On pc Debian x86-64 with master sources updated today (+rendering gtk3 and enable-dbgutil and English/US UI), when searching a non existing string, it indeed displays "Search key not found".
If there's not enough space to display the whole message, I got only a part, eg: "Search key not" with ">>" overlapping "not".
Remark: in this case clicking on ">>" gives nothing (no popup, no placeholder message, etc.)
Comment 7 Samuel Mehrbrodt (CIB) 2016-07-28 21:14:14 UTC
Hm so it looks this was added intentionally: bug 81925
Not sure what to do about it.
Comment 8 Heiko Tietze 2016-07-28 22:41:14 UTC
In my self-compiled v5.3 the space remains empty for a search with success and says 'key not found' otherwise. However, it's badly top aligned and far from being a good notification.

We could always show the number of results there, which makes this area clear. Or use some highlighting (e.g. Firefox makes the search field red), fading out message panels, a baloon notification...

Version: 5.3.0.0.alpha0+
Build ID: d4cb9c3a8851cb874fd8b6c77d4d7521da7579b7
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 9 Samuel Mehrbrodt (CIB) 2016-07-29 05:59:00 UTC
(In reply to Heiko Tietze from comment #8)

To see the hidden message, hover over the empty space; or resize the toolbar and click the arrow to show the hidden widgets.
That message is there, even before doing any search.
Comment 10 Heiko Tietze 2016-07-29 09:11:35 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #9)
> That message is there, even before doing any search.

I get a tooltip with this text, but the label is not shown. Maybe it's white on white (KDE/Qt toolbar issue).
Comment 11 Robinson Tryon (qubit) 2016-08-25 05:49:24 UTC Comment hidden (obsolete)
Comment 12 Luke Picciau 2016-09-24 01:43:55 UTC
I can reproduce this on calc and I can also get it to show up as a tooltip when libreoffice is full screen by hovering over the "Search key not found" message.


OS: xUbuntu 16.04
Version: 5.1.4.2
Build ID: 1:5.1.4-0ubuntu1
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: en-AU (en_AU.UTF-8)
Comment 13 Heiko Tietze 2016-09-24 07:30:58 UTC
Putting all together:

"[placeholder for message]" is shown on some systems
The label is replaced by "Search key not found"
The label is vertically misaligned
"[placeholder for message]" is always shown as tooltip

Solution 1: Remove the label as users are not aware of it and change the frame color of the input to red when nothing is found
Solution 2: Have always some information there like "Number of results: 0" (which makes the techtalk 'search key not found' obsolete)

And please take care of the alignment as well the tooltip.

(Removing UX to bring this up to the development.)
Comment 14 Cor Nouws 2016-09-26 10:09:17 UTC
(In reply to Heiko Tietze from comment #13)

> Solution 1: Remove the label as users are not aware of it and change the
> frame color of the input to red when nothing is found
> Solution 2: Have always some information there like "Number of results: 0"
> (which makes the techtalk 'search key not found' obsolete)

What about showing the message - if there is anything to show - in bold?
Comment 15 Heiko Tietze 2016-09-26 10:58:39 UTC
(In reply to Cor Nouws from comment #14)
> What about showing the message - if there is anything to show - in bold?

Whether bold or not (the is no need to draw special attention), there would be no information unless a search "fails". When we show the number of results we get a consistent interface that keeps the user in loop.
Comment 16 QA Administrators 2017-10-23 14:06:39 UTC Comment hidden (obsolete)
Comment 17 Luke Picciau 2017-10-24 12:37:35 UTC
This is still present in LO version 5.3.6.1 on Fedora 26.
Comment 18 B.J. Herbison 2017-10-25 10:20:23 UTC
The situation is improved, but not fully resolved, with Calc Version 5.4.1.2 on Ubuntu.

Better:
* The message "[placeholder..." is gone.

Still broken:
* The >> symbol is still shown.
* When >> is clicked a box is still displayed. But now the box is empty.
* The message "Search key not found" is still displayed above and behind the left side of the search bar.

If the "Search key not found" message appears on the right side of the Find bar, start over again with a narrower window. Or at least close and reopen the Find bar.

Note: If you change the size of the window the problem goes away and "Search key not found" is displayed on the right. I have only reproduced the problem with starting from a fresh Find bar and a Calc window of the appropriate width. (For me a window width of around 960 pixels causes the problem. I often used two side-by-side Calc windows on a 1920x1080 screen.)
Comment 19 QA Administrators 2018-10-26 02:58:11 UTC Comment hidden (obsolete)
Comment 20 B.J. Herbison 2018-10-31 21:34:31 UTC
The situation isn't correctly resolved in version 6.0.6.2.

1) When I first open the find bar the >> is present at the end (depending on the width of the window). Clicking on the >> displays an empty pop-up.

In other words, there is no information to show but Calc wants you to check and see if there is information.

2) After a search failure in a wide window the "Search key not found" message is displayed in the correct location. But if you narrow the window the "Search key not found" message goes away and is replaced by ">>". Clicking the >> displays an empty box.

I can find no way to display the Search key not found message in this case.
Comment 21 Jim Raykowski 2018-11-01 08:46:31 UTC
Hi B.J.

This is fixed in version 6.1.0. See bug 81925.
Comment 22 QA Administrators 2019-11-02 03:45:31 UTC Comment hidden (obsolete)
Comment 23 B.J. Herbison 2019-11-02 11:00:51 UTC
The [placeholder for message] problem was fixed a while ago.

Of the two problems I mentioned in comment 20 one has been fixed, but the other still remains.

When I first open the find bar the >> is present at the end (depending on the width of the window). Clicking on the >> displays an empty pop-up.

Should this bug be reopened or should another bug be created?
Comment 24 Julien Nabet 2019-11-07 10:59:42 UTC
(In reply to B.J. Herbison from comment #23)
> ...
> Should this bug be reopened or should another bug be created?

Since it's an old bug which has been partly fixed, it'd be more practical you submit a brand new one with just the remnant problem.