Bug Hunting Session
Bug 95665 - Text "Search key not found" vertically misaligned within Find toolbar
Summary: Text "Search key not found" vertically misaligned within Find toolbar
Status: RESOLVED DUPLICATE of bug 81925
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, implementationError, needsDevEval
Depends on:
Blocks: Find-Search Toolbars
  Show dependency treegraph
 
Reported: 2015-11-07 22:59 UTC by Thorsten Wagner
Modified: 2017-01-25 13:44 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (14.64 KB, image/tiff)
2015-11-07 22:59 UTC, Thorsten Wagner
Details
Misaligned text (13.74 KB, image/png)
2016-09-25 05:56 UTC, mahfiaz
Details
bibisect output, using Calc (6.63 KB, text/plain)
2017-01-24 17:51 UTC, Terrence Enger
Details
bibisect output, using Calc (3.38 KB, text/plain)
2017-01-24 17:54 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Wagner 2015-11-07 22:59:41 UTC
Created attachment 120373 [details]
Screenshot

If search strings are not found, the message "Search key not found" is vertically misaligned (not centered, see screenshot). The baseline of the message should be the same as the baseline of "Find All" and "Match Case".
Comment 1 A (Andy) 2015-11-08 07:33:54 UTC
This specific isssue is for me not reproducible with LO 5.0.3.2, Win 8.1.

But I have another rendering problem, because "Match Case" has a larger font size than "Find All" and is also misaligned similar to the example of Thorsten.
Comment 2 Alex Thurgood 2015-11-08 10:52:53 UTC
Confirming also on

Version: 5.1.0.0.alpha1+
Build ID: b59bf9f6397641750ad3db50312a1133d7e8fc3f
Locale : fr-FR (fr.UTF-8)
Comment 3 Thorsten Wagner 2016-05-15 22:14:26 UTC
Text "Search key not found" is no longer displayed.
Comment 4 mahfiaz 2016-09-25 05:56:14 UTC
Created attachment 127616 [details]
Misaligned text

Still a problem in 5.2.1.2

Also please note the empty placeholder on tooltip.
Comment 5 Yousuf Philips (jay) (retired) 2016-10-20 04:21:43 UTC
This affects writer as well so changing component. Before 4.3, search errors used to show a message box.
Comment 6 Aron Budea 2017-01-17 05:49:40 UTC
Adjusting earliest version. I guess bibisect could be used here to get a code pointer.
Comment 7 Terrence Enger 2017-01-24 17:51:57 UTC
Created attachment 130660 [details]
bibisect output, using Calc

Working in the bibisect-43max repository, I see that the misaligned
text starts as soon as the message moves from a dialog box to the Find
toolbar.  This happens 4 commits earlier for Writer than for Calc:

            commit    s-h       date
            --------  --------  -------------------
    msgbox  8dc3e465  d6f13b6a  2014-02-05 18:09:11
    Writer  e31ca1ea  f25cdaa7  2014-02-05 18:09:15
    Calc    db294f9f  d50e08b4  2014-02-05 18:10:04

The two commits implicated are:

    commit f25cdaa78d5e7d200fbaf31cce9895bab7c5ee63
    Author: Matúš Kukan <matus.kukan@collabora.com>
    Date:   Tue Feb 4 15:46:41 2014 +0100

        fdo#74132: Do not interrupt search in Writer.
    
        Instead of "Do you want to continue at the beginning?" dialog,
        just inform that we were at the end of the document in new label.
    
        Also replace 'Search key not found' dialog with label.
    
        Change-Id: I6a140cbad93406b73996f87a6d05fcc5d245fdbf

    commit d50e08b4e18ad6fa8b4078df6e23ffbaf47e708c
    Author: Matúš Kukan <matus.kukan@collabora.com>
    Date:   Wed Feb 5 13:47:45 2014 +0100

        fdo#74132: Do not interrupt search in Calc.
    
        Extending f25cdaa78d5e7d200fbaf31cce9895bab7c5ee63
        "fdo#74132: Do not interrupt search in Writer." for Calc.
    
        Change-Id: I3a7e5070300993d2811a79f17cb1b2edb0355c44


With SAL_USE_VCLPLUGIN=gtk3, in Writer, the Find toolbar grossly
misplaces the "not-found" message, putting it at the upper left of the
toolbar, overlapping other controls.  In the daily Linux dbgutil
repository version 2017-01-21, the situation is improved:  the message
is merely misligned as reported in this report.

I wonder if this could be an easyHack, in view of the cosmetic nature
of the problem.

I am removing keyword bibisectRequest and adding keywords bisected,
bibisected, needsDevEval.
Comment 8 Terrence Enger 2017-01-24 17:54:01 UTC
Created attachment 130661 [details]
bibisect output, using Calc
Comment 9 Xisco Faulí 2017-01-25 13:44:00 UTC
it seems like a duplicate of bug 81925

*** This bug has been marked as a duplicate of bug 81925 ***