Bug 101229 - Dragging Merged Cell Breaks Merge
Summary: Dragging Merged Cell Breaks Merge
Status: RESOLVED DUPLICATE of bug 86143
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: high minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-30 18:05 UTC by Joel Madero
Modified: 2017-02-25 15:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2016-07-30 18:05:59 UTC
Version: 5.3.0.0.alpha0+
Build ID: fc305bb6d656736bedc2f89789e18d8c9a3bbf2c
CPU Threads: 2; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

(Also tested with 5.1.4.2 where it works as expected)

Repro Steps:
1. Open calc;
2. Merge A1 and B1
3. Copy merged A1:B1 cell
4. Paste into A2

Observed: Text within the merged cell is pasted but the merge itself does not carry through. This makes it so there is no shortcut or easy way to merge lots of cells repetitively

Minor: Can slow down but will not prevent high quality work;
High: Regression + pretty standard behavior. If a user wanted to merge A#:B# from A1:B1 to A1000:B1000 (i.e., 1000 merges) it would be pretty time consuming and annoying to have to do this manually instead of copy/paste.

Also: Dragging has same bad behavior now
Comment 1 Joel Madero 2016-07-30 18:21:29 UTC
I can't repro consistently so going to close and test some more.
Comment 2 Joel Madero 2016-07-30 18:23:03 UTC
Sorry here are better instructions:
1. Open calc;
2. Merge A1:B1
3. Type "test" in merged cell
4. Drag down

Observed: Merge breaks/does not carry through
Comment 3 m.a.riosv 2016-07-30 22:27:54 UTC
Hi @Joel.
Reproducible Win10x64
Version: 5.3.0.0.alpha0+
Build ID: 9dc3356f1499a2b90078be86ca7470eb2e96aba8
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-07-21_23:52:45
Locale: es-ES (es_ES); Calc: CL

But even worse I'm not able to drag only one row, at least five and only the text is copied.
I think not a minor.

Copy fine with the keyboard but the same problem for drag with mouse, with:
Version: 5.1.5.2 (x64) Build ID: 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 
Locale: es-ES (es_ES); Calc: CL

Drag issue is inherited from OOo.
Comment 4 Joel Madero 2016-07-31 07:16:39 UTC
> 
> Drag issue is inherited from OOo.
What's the regression then? Just want to make sure that we're on the same page :)
Comment 5 m.a.riosv 2016-07-31 14:57:20 UTC
I didn't set as regression, but there is a regression for copy.
Works for me with:
Version: 5.2.0.3 (x64)
Build ID: 7dbd85f5a18cfeaf6801c594fc43a5edadc2df0c
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL;
Comment 6 Luke 2016-08-01 16:24:50 UTC
I'm confused about the regression tag. I can reproduce this on 5.3 with a drag, but not with a copy. What are the steps to reproduce with a copy? What version is this working and not working on?
Comment 7 m.a.riosv 2016-08-01 20:55:32 UTC
You are right @Luke, I have had a confusion because after paste, if you don't move the selection looks as if only the first cell of the merged range was pasted.

So not a regression for copy with keyboard but confirmed an inherited issue for drag.

- Not possible to drag a merged range on less than five*(number of merged cells less one) rows
- Merge it's not copied.

If there a values on the hidden cells of the merged range:
- Only the first cell of the merged range is pasted.
with keyboard or dragging.
Comment 8 Joel Madero 2016-08-03 05:18:03 UTC
Confirmed on at least 5.1.4.2
Comment 9 m.a.riosv 2017-02-25 15:36:37 UTC

*** This bug has been marked as a duplicate of bug 86143 ***