Bug 43958 - EDITING: Dashed border (CTRL+c) does not cover whole merged cell
Summary: EDITING: Dashed border (CTRL+c) does not cover whole merged cell
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium normal
Assignee: Attila Szűcs
URL:
Whiteboard: target:7.1.0
Keywords:
: 41842 73390 86143 87381 127256 (view as bug list)
Depends on:
Blocks: Calc-Merge-Split
  Show dependency treegraph
 
Reported: 2011-12-19 12:40 UTC by OfficeUser
Modified: 2020-09-30 09:44 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot (12.14 KB, image/png)
2011-12-19 12:40 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2011-12-19 12:40:48 UTC
Created attachment 54578 [details]
screen shot

Please look at the attached screen shot.

If a CTRL+c is pressed on a merged cell, only the upper left partial cell is covered by a dashed border.
Comment 1 Rainer Bielefeld Retired 2012-03-17 04:34:33 UTC
[Reproducible] with "LibreOffice 3.5.1.2 German UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit) 
[Reproducible] with "LibreOffice 3.4.1 RC1 – WIN7  Home Premium  (64bit) English UI [OOO340m1 (Build:201)]", I believe that always has been as observed now.

"Crawling Ants" only around top left cell, but copy function works correct for all contents, for example centered string  outside dotted line rectangle.

Seems reporter uses Linux, so OS All correct.

@Kohei:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 2 Michael Stahl (CIB) 2012-05-22 06:20:00 UTC
bug 43958 looks related
Comment 3 Michael Stahl (CIB) 2012-05-22 06:20:43 UTC
sorry i meant bug 42164
Comment 4 Michael Stahl (CIB) 2012-05-23 14:51:25 UTC
can reproduce it in LO 3.5.4;
looks like OOo doesn't have these "crawling ants" anyway.
Comment 5 tommy27 2014-06-15 14:05:45 UTC
still see this with LibO 4.2.4.2 and 4.4.0.0.alpha0+
Build ID: 488f31200094d7237d45545ab227014831a1f8e6
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-15_05:02:39
Comment 6 QA Administrators 2015-07-18 17:42:33 UTC Comment hidden (obsolete)
Comment 7 tommy27 2015-07-19 08:11:17 UTC
already present in LibO 3.3.3

still present in LibO 5.1.0.0.alpha1+ (x64)
Build ID: 5a61d7f049a81d6e747d9d097f364ae45f58697b
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-16_01:06:26
Comment 8 QA Administrators 2016-09-20 10:17:47 UTC Comment hidden (obsolete)
Comment 9 OfficeUser 2016-09-24 19:47:39 UTC
I still see the bug with build 5.2.1.2. (Tested OS: Linux)
Comment 10 QA Administrators 2018-06-04 02:34:08 UTC Comment hidden (obsolete)
Comment 11 OfficeUser 2018-06-15 17:19:20 UTC
Still reproducible with: 

Version: 6.0.3.2
Build-ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU-Threads: 8; BS: Linux 4.4; UI-Render: Standard; VCL: gtk2; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
Comment 12 QA Administrators 2019-06-16 02:58:12 UTC Comment hidden (obsolete)
Comment 13 NISZ LibreOffice Team 2020-09-16 12:28:34 UTC
*** Bug 127256 has been marked as a duplicate of this bug. ***
Comment 14 László Németh 2020-09-30 08:32:55 UTC
*** Bug 41842 has been marked as a duplicate of this bug. ***
Comment 15 László Németh 2020-09-30 08:33:14 UTC
*** Bug 73390 has been marked as a duplicate of this bug. ***
Comment 16 László Németh 2020-09-30 08:33:29 UTC
*** Bug 87381 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2020-09-30 08:33:42 UTC
Attila Szűcs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/605b4ba57b2daa447af9d43d3759079e15df8148

tdf#43958 sc: fix fill by selecting merged cell

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 László Németh 2020-09-30 08:33:52 UTC
*** Bug 86143 has been marked as a duplicate of this bug. ***