Bug 101236 - Frame style not keeping text vertically centered
Summary: Frame style not keeping text vertically centered
Status: RESOLVED DUPLICATE of bug 111891
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-07-31 16:50 UTC by David
Modified: 2017-10-05 19:55 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
center text in frame (7.70 KB, application/vnd.oasis.opendocument.text)
2016-07-31 16:50 UTC, David
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2016-07-31 16:50:38 UTC
Created attachment 126499 [details]
center text in frame

I don't know when this bug started.  I think it's been like this for a while, but I didn't notice it until now.  If a frame style is set to center the text inside it, the setting is not restored when saving & closing the document and then re-opening it.

To test, create a new document with a frame.  Change the frame style to center the text.  Do NOT just select the frame and open the properties and change it from there.  It is only the frame style that does not keep this setting, not when done on a per frame basis.

See attachment for a sample document.  This document had the text setting in the frame style set to centered when it was saved, but the setting was not saved with the rest of the document.
Comment 1 Thomas Hackert 2016-08-01 12:40:15 UTC
Hello David, *,
thanks for reporting this bug :) Alas, I cannot confirm it with
OS: Debian Testing AMD64
LO: Version: 5.1.4.2
Build-ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8)

nor

LO Version: 5.1.5.1
Build-ID: 1:5.1.5~rc1-1
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: GL; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

nor

LO: Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; 
Locale: de-DE (de_DE.UTF-8)

... :( 5.1.5.1 is Debian's own version, the other two are parallel installed ones, following the instructions fromhttps://wiki.documentfoundation.org/Installing_in_parallel/Linux.

What I did:
Part 1:
1. downloaded your attachment
2. Opened it in LO
3. Clicked on the frame and on the Center button in the toolbar "Frame"
4. <Esc> and then click inside the frame
5. Clicked on the "Center horizontally" button in the toolbar "Formatting"
6. Saved the document, closed and reopened it
(and this for all three mentioned versions above)

Part 2:
1. Opened it in LO
2. set orientation to "Align left" (for both the frame as well as the text)
3. Opened it again
4. marked the frame
5. rightclicked on it and selected "Object..."
6. changed "Horizontal" from "Left" to "Center" under "Position"
7. closed the dialog
8. <Esc> and clicking in the frame to click on the text
9. clicked on "Center horizontally" button in the toolbar "Formatting"
10. Saved the document, closed it and reopened it
(as above for all three mentioned versions)

Part 3:
1. Created a new document in Writer
2. "Insert - Frame" (in Debian's versions, in LO's "Insert - Frame - Frame"
3. Either letting the default values or changing the height and width values to 7cm and 3cm and hitting <Enter>
4. Rightclick on the Frame and selected "Object..."
5. Confirmed, that its default value is "Center"
6. Hit <Enter>
7. <Esc> and clicked in Frame to insert the text "Test"
8. Clicked on "Center horizontally" button in the toolbar "Formatting"
9. Saved the document, closed and reopened it
(and again, for all three mentioned versions, but still no repro, sorry ... :( )

Would you be so kind to
a. to rename your user profile (https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile) and test it again, please?
b. to disable or enable any option related to OpenCL (Tools - Options - LibreOffice - OpenCL) or OpenGL (Tools - Options - LibreOffice - View) and test it again, please?

Maybe we could find out, if it is related to one of these options and/or corrupt user profile or an extension or ... ;)
TIA
Thomas.
Comment 2 David 2016-08-01 13:41:45 UTC
@thackert
If I read your procedure properly, you did exactly what I said NOT to do.  The frame *style* must be what is modified and not the frame directly.  Go to the sidebar, select the frame style & formatting button, and change the frame style from there.
Comment 3 David 2016-08-01 13:48:03 UTC
Yes, it is possible to select each frame and manually set it from it's own properties, but if you have a large document using many of the same style of frames, then it is much better to use the styles for what they are there for and not set things manually.
Comment 4 Thomas Hackert 2016-08-01 15:48:31 UTC
Hello David, *,
(In reply to David from comment #2)
> @thackert
> If I read your procedure properly, you did exactly what I said NOT to do. 
> The frame *style* must be what is modified and not the frame directly.  Go
> to the sidebar, select the frame style & formatting button, and change the
> frame style from there.

well, I seem to have misinterpreted your text, sorry ... :( After you mentioned the sidebar, I have tried to play around a little bit with rightclick on "Frame" -> "Modify" and changing "Vertical alignment" below "Content Alignment" on the tab "Options". There I can confirm your bug, so changing the status to "New".
Sorry for the inconvenience and have a nice afternoon
Thomas.
Comment 5 QA Administrators 2017-09-01 11:16:20 UTC Comment hidden (obsolete)
Comment 6 David 2017-09-09 06:05:58 UTC
Version 4.0.0 does not have the setting in the Styles & Formatting dialog for centering text within frames. By version 4.4.7 it was added.  I did not try the versions in between to determine when it was added.  But in versions 4.4.7 and 5.0.0 the option was available and when a document was opened they both restored it properly with the text centered, just as it had been saved.  Then sometime between version 5.0.0 and version 5.1.0 it lost the ability to recognize that the document had been saved with the text centered in the properties under the Styles and formatting frame settings.  It still has not been corrected as of version 5.4.0 and can only keep the text centered if the setting has been manually enabled directly in the properties for each individual frame, not from the Styles & Formatting properties.
Comment 7 David 2017-09-09 16:56:08 UTC
Did some more testing.  Version 5.1.0.0.alpha1 functions correctly.  Version 5.1.0.0.beta1-buildfix1 fails to load the sample document with the text vertically centered in the frame.
Comment 8 David 2017-09-14 10:22:56 UTC
Might something introduced in one of these commits have caused the regression of LO not restoring the setting when loading the document?

https://cgit.freedesktop.org/libreoffice/core/commit/?id=fbd1c167851a04c60d91daa830cf93e5b2ad7b4d
https://cgit.freedesktop.org/libreoffice/core/commit/?id=664197d95becd516c3dac25a50439078ba61e051
Comment 9 David 2017-10-05 17:32:51 UTC
Fixed by bug 111891.
Comment 10 David 2017-10-05 19:55:57 UTC

*** This bug has been marked as a duplicate of bug 111891 ***