Bug 111891 - FORMATTING (Styles): The vertical frame alignment setting is not preserved when the document is opened
Summary: FORMATTING (Styles): The vertical frame alignment setting is not preserved wh...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:6.0.0 target:5.4.2 target:5.3.7
Keywords: bibisected, regression
: 101236 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-18 06:45 UTC by Bastián Díaz
Modified: 2017-10-05 19:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (152.21 KB, image/png)
2017-08-18 07:13 UTC, Bastián Díaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2017-08-18 06:45:27 UTC
Description:
When the frame style is modified or a new one is created by configuring the vertical alignment in "centred" or "bottom", it's displayed in the open document, but when saving and reopening the configuration is lost.

Steps to Reproduce:
1. Open Styles and Formatting sidebar and select "Frame Styles|Frame|Modify..."
2. Select "options" tab
3. Modify vertical alignment settings to "centred" or "bottom"
4. Insert new frame "Insert|Frame|Frame Interactively"
5. Write a text and save the document

Actual Results:  
When you open the previously saved document, the vertical alignment setting is lost and the default setting is displayed.

Expected Results:
The vertical alignment setting in the frame style is preserved when you save a document.


Reproducible: Always

User Profile Reset: Yes

Additional Info:
LibreOffice Flatpak version 7556cbc6811c9d992f4064ab9287069087d7f62c (fedora xfce 64 bit)



User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Bastián Díaz 2017-08-18 07:13:57 UTC
Created attachment 135638 [details]
screenshot

A test file in this case is not useful, but I share a screenshot exemplifying the problem described above.
Comment 2 Mike Kaganski 2017-08-18 10:54:36 UTC
Confirmed with Version: 5.4.0.3 (x64)
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: ru-RU (ru_RU); Calc: group

and with Version: Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: ru-RU (ru_RU)

but NOT with Version: 5.0.0.5 (x64)
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: ru-RU (ru_RU)

File format is ODT.

The problem is on load. Saving the attribute happens successfully, which is visible when opening the file with 5.0 saved with a later version.
Comment 3 Mike Kaganski 2017-08-18 14:59:10 UTC
Bibisecting with bibisect-win32-5.1 shows that a file with non-top vertical alignment set for a frame style crashes starting with this commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=664197d95b
> author	Justin Luth <justin_luth@sil.org>	2015-09-10 08:41:11 (GMT)
> committer	Justin Luth <justin_luth@sil.org>	2015-10-19 04:35:55 (GMT)
> commit	664197d95becd516c3dac25a50439078ba61e051
> tree	85199c219b30c973a1c151b360c490fcfd16bce3
> parent	51df957e1a40d2f3511345c1600c05dd35f34b6b
> tdf#36117 .docx preserve page vertical alignment after RT

and after that, such files start opening with wrong (top) vertical alignment in these styles with this commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=36a3885eb2
> author	Caolán McNamara <caolanm@redhat.com>	2015-11-01 21:11:29 (GMT)
> committer	Caolán McNamara <caolanm@redhat.com>	2015-11-01 21:13:13 (GMT)
> commit	36a3885eb2ec26acbce587497db68606feddfc42
> tree	ea475fe4c6fca75d157886f7def7d7b73270e8fd
> parent	c2a76550a287adf8bdbe93c02395fb80cb11c950
> crashtesting: failure on tdf89191-1.odt
> crash since
> 
> commit 664197d95becd516c3dac25a50439078ba61e051

Testing between these commits (712 intermediate commits) is impossible, but it seems highly probable that one of these two commits is the real cause.
Comment 4 Justin L 2017-08-24 20:02:17 UTC
Yup - my problem from bug 36117 commit 664197d95becd516c3dac25a50439078ba61e051

proposed fix: https://gerrit.libreoffice.org/41538
Comment 5 Commit Notification 2017-09-04 17:41:41 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=10dc371d31f003ac3ed9b89ca1db95d36603603f

tdf#111891 unostyle: use default handler for non-page style

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Justin L 2017-09-04 18:40:21 UTC
requested backport to 5.3
Comment 7 Commit Notification 2017-09-07 14:46:51 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=461aa995d75f031209711feda9d785d915c42dd2&h=libreoffice-5-4

tdf#111891 unostyle: use default handler for non-page style

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2017-09-08 10:18:27 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db7a015c86248bd2a3d090240f9360f84b3bec8c&h=libreoffice-5-3

tdf#111891 unostyle: use default handler for non-page style

It will be available in 5.3.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 David 2017-10-05 17:31:34 UTC
Duplicate of bug 101236.
Comment 10 David 2017-10-05 19:55:57 UTC
*** Bug 101236 has been marked as a duplicate of this bug. ***