Bug 89191 - EDITING: Formula frame can't be resized
Summary: EDITING: Formula frame can't be resized
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 94194 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-07 03:37 UTC by Robert Gonzalez MX
Modified: 2015-09-13 19:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshoots and formula examples (87.07 KB, application/vnd.oasis.opendocument.text)
2015-02-07 03:38 UTC, Robert Gonzalez MX
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Gonzalez MX 2015-02-07 03:37:40 UTC
Hi.

I noticed that when inserting a formula on a writer document in LO 4.4.0.3 on Win 8.0, the frame is blocked for resizing, this behavior doesn’t happen in LO 4.3.5.2 on Win 8.0.

Steps to reproduce:

Create a new Writer file

insert a formula with Insert Object Formula
when finished try to resize the frame
it is blocked.

This behavior was not present in writer 4.3.5.2.

if you access the frame properties with right click or in the menu bar of the object, the size options are grayed and inaccessible. Even if you change the anchor position to paragraph or page.
This will be correct if in the options tab of the object properties was activated the protect size option.

I see bug 88145 resolved invalid with some of the same problems.

Testing win LO 4.3.5.2 in parallel installation works as expected.
Comment 1 Robert Gonzalez MX 2015-02-07 03:38:50 UTC
Created attachment 113194 [details]
screenshoots and formula examples
Comment 2 Jean-Baptiste Faure 2015-02-07 18:20:26 UTC
Yes, the behavior in 4.3.5 was finally regarded as faulty when concerning Math objects. Math objects should not been considered as graphics but as text. As text you have to change their font properties to modify their size.

Please have a look at bug 75408 and bug 85860.

Closing as NotABug.

Best regards. JBF
Comment 3 Jean-Baptiste Faure 2015-09-13 19:35:41 UTC
*** Bug 94194 has been marked as a duplicate of this bug. ***