Download it now!
Bug 75408 - Formula in writer is shrinked instead of keeping same size when changing border space in writer style
Summary: Formula in writer is shrinked instead of keeping same size when changing bord...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.5.0 target:4.4.0.0.beta2 tar...
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-02-23 18:10 UTC by Pierre C
Modified: 2019-01-05 21:22 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
exemple with LO 4.1.6+ and LO 4.2.1.1 (12.66 KB, application/vnd.oasis.opendocument.text)
2014-02-25 14:46 UTC, Pierre C
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre C 2014-02-23 18:10:36 UTC
1 Create a new formula in writer for example 1+1=1
2 chose modify frame style named formula in stylist (F11)
3 choose tab border, add a border and change border spacing from 0 to 0,5cm
4 OK

--> The fromula frame as the same size and the forumula is shrinked so you can't see it (LO 4.2.1.1)

expected behavior :
The formula frame is increased buy 0,5cm in each direction, and the formula keep the same size (LO 4.1.5)

So it's a regression
Comment 1 Pierre C 2014-02-25 14:46:34 UTC
Created attachment 94716 [details]
exemple with LO 4.1.6+ and LO 4.2.1.1

on attached file there are 2 formulas.

first one created with LO 4.2.1.1

Second one created with LO 4.1.6+

Both are created by the same way. As you can see the result isn't the same

You can also try to double clic on the first formula (the wrong one)

With LO 4.2.1.1 nothing happens

With LO 4.1.6+ the formula chnage to the correct size
Comment 2 vulcain 2014-02-26 13:57:48 UTC
I reproduce this bug with LibreOffice 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b on Ubuntu 12.04 x86_64

Don't reproduce with LibreOffice  3.5.7.2 Version ID : 350m1(Build:2)
Comment 3 Bernard SIAUD 2014-02-26 19:53:17 UTC
I have the same problem with my version : Build ID: 4.2.1.1-1.mga5
Comment 4 Joel Madero 2014-02-27 21:13:02 UTC
In the future please do not put your own bugs on MAB - we need independent QA staff to do this. In this case I'll leave it but in reality it doesn't belong there quite yet: 

Will you bibisect the bug? In order for it to be on MAB QA has to have done everything required (in this case a regression requires a bibisect)
Comment 5 Pierre C 2014-02-27 21:17:23 UTC
I did not put this bug in the MAB 4.2 list. I just ask if it can be in the list.
I don't know how to bibisect a bug but surely it's now time to learn it
Comment 6 Joel Madero 2014-02-27 21:18:18 UTC
ah - my mistake - I saw the comment on MAB list. In the future if you think your bug belongs on MAB - email the QA list and get input :) 

For bibisect - are you running linux?
Comment 7 Andras Timar 2014-02-28 07:49:51 UTC
This is caused by 1b717e5 that enables resizing the formula objects in Writer.

commit 1b717e5686f34c3ce798310a6216f7ea98fb2cd9
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Mon Oct 7 16:10:22 2013 +0100

    Resolves: rhbz#1012353 fdo#48846 allow starmath objects to be resized


However, you have the same bug when you insert for example a Chart, and modify the OLE frame style. So 1b717e5 just made visible, that was always there.
Comment 8 Pierre C 2014-02-28 17:55:54 UTC
@ Andras Timar

does it mean that the bug is solved ?

the bug is still present in the latest LO 4.2.2.1
Comment 9 Pierre C 2014-02-28 18:18:27 UTC
Not sure that it is this bug
https://bugs.freedesktop.org/show_bug.cgi?id=48846

this bug is solved since 2013-10-07. 
the bug is present in LO4.2.1.1 ; 4.2.2.1 ; master 28/02/2014

the bug is not present in LO 4.1.6+

I can resize the formula, but it is not an automatic resizing
Comment 10 Andras Timar 2014-02-28 19:42:22 UTC
(In reply to comment #8)
> @ Andras Timar
> 
> does it mean that the bug is solved ?

No. I've just shown the first bad commit. I also gave a second example, charts (OLE frame style) which is automatically resized, too. So even if we reverted 
1b717e5, the fix for bug 48846, this bug would not be fully solved. For formulas, the behaviour would be the same as in 4.1, but for other types of resizeable objects the problem would remain.
Comment 11 Pierre C 2014-02-28 19:57:32 UTC
@ Joel Madero 

no, I'm not a Linux user, so I can't bibisect

if of any help : the bug is present since LO 4.2.0 beta1
Comment 12 Caolán McNamara 2014-02-28 20:18:08 UTC
And it's the same for graphics, the border space is placed "inside" the frame in LibreOffice and the contained image shrunk to fit the remaining space. So now formulas are acting the same as everything else (AFAICS).

I always thought that "shrink the contents inside the original size" was a bit odd. But it's the way all graphics and every other object is handled.

Perhaps we should adjust the UI a bit to have a little radiobutton on the borders page to "add border distance to current size" vs "subtract border distance from current size (default)" Definitely a better form of words needed than that though.
Comment 13 Pierre C 2014-02-28 20:37:00 UTC
@Caolán McNamara

Hum... I'm not sure to understand. Do you mean that this is not a bug but an enhancement ?

So what the formula command 'size' is for ? (if changing the border size change the formula size)

(I mean that if I enter the formula : 
size 12 {1+1 = 1}
and then adding a 5 mm border => the formula size won't be 12)

I have no way to get the correct size of my formula.

the only way I found is to copy the x and y size of the formula before adding the border. And then adding the border size to the formula size. And finally using the mouse to resize the formula. Each try, I must go to the property's object  to check its size. I can't change directly the formula size, it's greyed
Comment 14 Pierre C 2014-03-25 21:55:08 UTC
IF I create a simple formula in LO 4.1. For example :

size 12 { 0 + 0 = 0} then adding a 2.2 cm border. I can't change the object's size. And this is the expected behaviour. If the formula size is fixed and the border is also fixed the the object size if fixed too. And I can't change it.

IF I do the same thing with LO 4.2, The object size can be changed. And this is not the expected behaviour. If I change the object size, I change de formula size (keeping the border size) and there is no way to get back to the correct formula size. So that the formula command 'size' is not respected
Comment 15 Jean-Baptiste Faure 2014-03-26 22:05:26 UTC
I agree with Pierre, Math object are not graphic objects, Math formula are texts with font size and shouldn't considered as graphic objects.

Best regards. JBF
Comment 16 Pierre C 2014-04-17 17:05:40 UTC
This bug is still in LO 4.2.4.1 and master branch...

That seems normal, because this is not a bug, but a new feature. Am I right ?

So, Thanks to this new feature, so that I can't set the font size of my formulas AND use a border (Indeed i can, but I have to reopen my file with AOo and double click on all my formulas... isn't it silly ?)

But I guess one thing... Will you add this enhancement to paragraph ?

If I wrote a paragraph, I can add a border, and set the spacing to any value.

And as it was told, the text should be shrink to keep the size of the paragraph So that the behaviour will be the same as images, chart... and formulas.

I look forward to see this enhancement in LO... Because, MPOV is that, this enhancement will not have a long life, and maybe, someone will understand that this behaviour is not a normal behaviour for formulas too...

I have a dream...
Comment 17 Jean-Baptiste Faure 2014-04-17 19:23:11 UTC
CCing UX-advise mailinig list: opinion ?

I agree with Pierre, formula should be treated in the same way as text, not as graphics, because the appearance of the formula is defined by font sizes, not line width and resolution.

Best regards. JBF
Comment 18 Joel Madero 2014-04-17 19:29:36 UTC
I wonder if treating formulas like images is what is causing the issue listed in bug 36815 comment 50 - to me it seems likely
Comment 19 Commit Notification 2014-11-26 15:46:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=51221bbf0c7cca0a329393dac2059818006ab338

Resolves: fdo#75408 go back to the old way of doing things

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2014-11-26 15:47:55 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2babe1baf46dcad936703d12cbd847393f5e467b&h=libreoffice-4-4

Resolves: fdo#75408 go back to the old way of doing things

It will be available in 4.4.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Caolán McNamara 2014-11-26 15:49:27 UTC
alright, lets go back to the old way of doing things until we get something like 85860 implemented
Comment 22 Commit Notification 2014-11-28 07:58:23 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f9fbda1030df4ef94fe07c07e55da7adac41ea4&h=libreoffice-4-3

Resolves: fdo#75408 go back to the old way of doing things

It will be available in 4.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Pierre C 2014-11-29 20:07:17 UTC
I've downloaded 4.3.6+ (29/11/2014) a formula with border works fine thanks for the job. Soon, I won't have to open my docs with AOo to get the proper formula's size.
It would be great to have it on 4.3.5.2
Comment 24 Robinson Tryon (qubit) 2015-12-17 07:38:31 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]