Bug 101349 - Default set of table styles
Summary: Default set of table styles
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Eike Rathke
URL:
Whiteboard: target:6.0.0 target:6.1.0 target:6.0.0.1
Keywords:
: 106308 (view as bug list)
Depends on: 107606
Blocks: Writer-Table-Styles
  Show dependency treegraph
 
Reported: 2016-08-06 07:04 UTC by Yousuf Philips (jay)
Modified: 2017-12-02 15:00 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
ms word 2010 table styles (55.66 KB, application/wps-office.docx)
2016-08-06 07:04 UTC, Yousuf Philips (jay)
Details
current LibreOffice AutoformatStyles (25.09 KB, text/odt)
2016-08-06 11:17 UTC, Cor Nouws
Details
ms word 2010 ribbon UI table styles (19.23 KB, image/png)
2016-08-15 20:14 UTC, Yousuf Philips (jay)
Details
WPS table styles (29.84 KB, image/png)
2016-08-15 20:20 UTC, Yousuf Philips (jay)
Details
1st collection of table styles (18.59 KB, application/vnd.oasis.opendocument.text)
2016-08-16 20:05 UTC, Yousuf Philips (jay)
Details
Various table styles (19.00 KB, application/vnd.oasis.opendocument.text)
2016-08-23 13:10 UTC, Heiko Tietze
Details
A pure gray table with banded rows (17.47 KB, application/vnd.oasis.opendocument.text)
2016-08-23 23:11 UTC, Regina Henschel
Details
Typical academic table style (2 variants) (15.09 KB, application/vnd.oasis.opendocument.text)
2017-03-02 18:43 UTC, Gerry
Details
element variants of ms word 2010 table styles (57.09 KB, image/png)
2017-05-04 10:27 UTC, Yousuf Philips (jay)
Details
Table style update (38.65 KB, application/vnd.oasis.opendocument.text)
2017-05-11 07:13 UTC, andreas_k
Details
Overview how the Andreas_Styles will look like (541.37 KB, application/pdf)
2017-05-11 07:15 UTC, andreas_k
Details
Table styles in nightly build (56.21 KB, image/png)
2017-11-02 14:53 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2016-08-06 07:04:36 UTC
Created attachment 126625 [details]
ms word 2010 table styles

Jakub (udap) has enabled table styles in the styles and formatting sidebar, but presently it only has table styles from Table > Autoformat Styles, which arent very pleasing, so we need to come up with a new set of defaults to supplement the 17 that we already have.

I've attached a document with all the 45 table styles available in MS Word 2010 for people to look through and comment on the ones they like. For those interested in designing their own table styles, please create them with a minimum of 5x5 table size and submit them as attachments here. Would be useful to show examples of usage in these designed table styles.
Comment 1 Heiko Tietze 2016-08-06 08:05:36 UTC
Ideally we attach XML files, but so far the styles are stored binary.
Comment 2 Cor Nouws 2016-08-06 11:17:39 UTC
Created attachment 126628 [details]
current LibreOffice AutoformatStyles
Comment 3 Yousuf Philips (jay) 2016-08-15 20:14:01 UTC
Created attachment 126849 [details]
ms word 2010 ribbon UI table styles

So to clarify, attachment 126625 [details] contains only the base variants (mainly grayscale) of the default themed ribbon UI table styles. The attached screenshot includes all the default themed ribbon UI styles.
Comment 4 Yousuf Philips (jay) 2016-08-15 20:20:40 UTC
Created attachment 126850 [details]
WPS table styles

Here are the default table styles in WPS/Kingsoft office.
Comment 5 Yousuf Philips (jay) 2016-08-16 20:05:24 UTC
Created attachment 126858 [details]
1st collection of table styles

So here is a first attempt at a collection of grayscale table styles, so please give your input on it, primarily the ones you like the most. Colored versions of the chosen grayscale styles will then need to be created, hopefully by those who have a good palette sense, as i don't. :D
Comment 6 Cor Nouws 2016-08-23 10:53:40 UTC
(In reply to Yousuf (Jay) Philips from comment #5)

> please give your input on it, primarily the ones you like the most. 

Well, for what it's worth, my preference: Simple list 4, 8, 9, 7
Comment 7 Heiko Tietze 2016-08-23 13:10:32 UTC
Created attachment 126985 [details]
Various table styles

Adding another draft. 

In general, we should have a very simple style that fits 80%. Furthermore we need a full-features style to illustrate what is possible. And something for financial tables. Finally _a few_ design ideas would be good (the 100+ options in Word makes no sense since users can easily change all attributes themselves).

I suggest to also ask the community like we do regarding templates, for instance.
Comment 8 Jean-Francois Nifenecker 2016-08-23 13:31:09 UTC
I fully agree with Heiko. Hundreds of examples are of no use. A few efficient templates showing what can be done using LibreOffice are a better way, IMO.

A call to the community to provide some examples/templates is the way to go as well.
Comment 9 Yousuf Philips (jay) 2016-08-23 20:59:30 UTC
(In reply to Heiko Tietze from comment #7)
> In general, we should have a very simple style that fits 80%. Furthermore we
> need a full-features style to illustrate what is possible. And something for
> financial tables.

Definitely.

> Finally _a few_ design ideas would be good (the 100+
> options in Word makes no sense since users can easily change all attributes
> themselves).

MSO has 43 autoformat table styles, where only 1 of them are shown by default, and 14 new table styles and 6 document theme-colored variants of those new table styles (total is 99 :D). It makes perfect sense to provide colored variants of table styles as

1) most users arent creative enough to colorize table styles (i include myself in that category)
2) modifying table styles isnt an easy task that novice users (benjamin) would be able to do or advanced users (eve) would want to do
3) the point of presets is to simplify the amount of changes the user has to make

We definitely dont need 7 variants of each table style design, but having 3 or 4 of each would be beneficial (1 black/white and 2 or 3 colorized).

> I suggest to also ask the community like we do regarding templates, for
> instance.

Yes asking the creative minds in the community to assist with styles and colorization would be useful.
Comment 10 Regina Henschel 2016-08-23 23:11:09 UTC
Created attachment 126995 [details]
A pure gray table with banded rows

I have created it with a Version: 5.3.0.0.alpha0+
Build ID: 44216ddbc620a1c05e98dda1f63ed6df0eae5275
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: de-DE (de_DE); Calc: group

The example shows some features like banded rows and separate styles for the corner cells.

To apply the table template to your own table, open the attached document and then find the table template in the Table section of the Style&Formatting pane in the sidebar.

I think it is misleading to name it "table style", because it is not a style for a table, but a "table template" is <quote>a set of references to table cell styles</quote>.

I think, that the current implementation produces invalid ODF, so it is too early to make final templates. Unfortunately there was no interest on dev to discuss that.
Comment 11 Yousuf Philips (jay) 2016-08-24 07:36:36 UTC
(In reply to Regina Henschel from comment #10)
> The example shows some features like banded rows and separate styles for the
> corner cells.

Looks quite nice but unfortunately because the style wasnt created on a 4x4 table, some of the features werent imported into the auto generated table style.

> I think it is misleading to name it "table style", because it is not a style
> for a table, but a "table template" is <quote>a set of references to table
> cell styles</quote>.

Dont think it is misleading to call it table styles, as that is what ODF calls it and what other office suites call it.

> I think, that the current implementation produces invalid ODF, so it is too
> early to make final templates. Unfortunately there was no interest on dev to
> discuss that.

We can create the design our intended set of table styles/templates and we can await for the code implementation to catch up to properly produce it. If you find issues with it producing invalid ODF, please report bugs for it so jakub can look into it.
Comment 12 Regina Henschel 2016-08-24 13:08:15 UTC
(In reply to Yousuf (Jay) Philips from comment #11)

> Looks quite nice but unfortunately because the style wasnt created on a 4x4
> table, some of the features werent imported into the auto generated table
> style.

? What "feature" are you missing? If you mark the whole table and use Table > AutoFormat Styles and then button Add, you get all the cell styles. The size 4x4 is only a minimum, you can use larger prototypes as well.
Comment 13 Regina Henschel 2016-08-24 14:13:36 UTC
(In reply to Yousuf (Jay) Philips from comment #11)

> Dont think it is misleading to call it table styles, as that is what ODF
> calls it and what other office suites call it.

The <table:table> element (9.1.2) has an attribute table:template-name and an attribute table:style-name. The style, which is referred by table:style-name is of type table and therefore has only those attributes listed in <style:table-properties> (17.15) and those do not contain anything from the table template. For to be a style a table template would need a style:name attribute, but it has a table:name attribute. And it would need to be child of a <style:style> element. But that is not the case. Therefore my conclusion is, that the <table:table-template> element is no style.
Comment 14 Yousuf Philips (jay) 2016-08-25 22:43:06 UTC
(In reply to Regina Henschel from comment #12)
> ? What "feature" are you missing? If you mark the whole table and use Table
> > AutoFormat Styles and then button Add, you get all the cell styles. The
> size 4x4 is only a minimum, you can use larger prototypes as well.

Seems the build i was using from the 16th didnt update the table style correctly (Styles & Formatting sidebar, table styles tab, update style).

(In reply to Regina Henschel from comment #13)
> The <table:table> element (9.1.2) has an attribute table:template-name and
> an attribute table:style-name. The style, which is referred by
> table:style-name is of type table and therefore has only those attributes
> listed in <style:table-properties> (17.15) and those do not contain anything
> from the table template. For to be a style a table template would need a
> style:name attribute, but it has a table:name attribute. And it would need
> to be child of a <style:style> element. But that is not the case. Therefore
> my conclusion is, that the <table:table-template> element is no style.

Though we dont presently support table styles in the <style:style> tag, we will in the future. Ultimately we dont have to call things by their ODF definition name if we decide that the name used isnt suitable.
Comment 15 Regina Henschel 2016-08-25 23:01:54 UTC
(In reply to Yousuf (Jay) Philips from comment #14)
> Though we dont presently support table styles in the <style:style> tag, we
> will in the future.

Please can you tell me more about such plans, perhaps in a direct mail to me in case it is to long for this issue? The current implementation on master has some problems, but in principle it follows the ODF 1.2 specification.

 Ultimately we dont have to call things by their ODF
> definition name if we decide that the name used isnt suitable.

How this feature is presented to the user is indeed a different problem.
Comment 16 Gerry 2017-03-02 18:43:40 UTC
Created attachment 131584 [details]
Typical academic table style (2 variants)

I attached a typical academic table style (e.g. as they are used in many academic journals), in two variants. It would be great to have such academic table styles.

Academic styles are usually quite basic. There is no shaded area and only horizontal lines. 

Variant 1 shows that the first row has a horizontal top border and horizontal bottom border. The last row has only a horizontal bottom border.

Variant 2 is almost the same like variant 1, but the last row represents a summary row and therefore additionally has a horizontal top border. 


It would be great if you could add such academic table styles to the default set of table styles
Comment 17 Heiko Tietze 2017-03-04 20:27:49 UTC
*** Bug 106308 has been marked as a duplicate of this bug. ***
Comment 18 Yousuf Philips (jay) 2017-04-24 14:26:27 UTC
(In reply to Gerry from comment #16)
> Academic styles are usually quite basic. There is no shaded area and only
> horizontal lines. 

Looks similar to the 'Simple List 8' style i was proposing, so we'll definitely have something close to it.
Comment 19 andreas_k 2017-05-02 08:28:54 UTC
I'd like to separate the table styles into two areas

1. Printout documents
---------------------
if you have a look at printed tables the best styled tables you will find in LaTeX and I found two documents why LaTeX produce nice tables [1] [2]:
- never use vertical lines
- avoid "boxing up" cells, usually 3 horizontal lines are enough (above, below and after heading)
- avoid double lines
- enough space between rows
- if in doubt, align left

2. screen documents
-------------------
This type of documents are styled for the screen OR for high-quality press documents. Therefor I'd like to look to webdesign and annual reports.
Here are some rules for webdesigners [3]:
- Tables love space. Set the width of tables carefully, according to the content. If you don’t know the perfect width, simply set the width of the table to 100%. Tables look nicer when they have “overwidth”, and when it comes to tables too much width is definitely better than too little width.
- Cells need some padding. Sure, each table cell relates to each other. But it doesn’t mean that we have to pull them too close, right? Define some space between the cells, crammed up table cells are so much harder to read
- Treat tables the way you treat content. Tables are read similarly to the way we read text — except it’s harder and it takes more time to read a table. So be careful with the amount of contrast you are giving to your table. Use soft colors — it’s easier for the eyes. Don’t treat your table like it’s a graphical decoration. Make sure that the style you apply to it makes the content more readable, not the other way around.

I will make some design examples for printout and screen documents and hope you like them.

[1] https://www.inf.ethz.ch/personal/markusp/teaching/guides/guide-tables.pdf
[2] https://www.tug.org/pracjourn/2007-1/mori/mori.pdf
[3] https://www.smashingmagazine.com/2008/08/top-10-css-table-designs/
Comment 20 Heiko Tietze 2017-05-02 11:30:45 UTC
(In reply to andreas_k from comment #19)
> I'd like to separate the table styles into two areas

While the paragraph styles provides an hierarchical organization we do not have it for other types. And actually going with only two top-level categories (print and screen) makes not much sense to me. 
On the other hand I fully agree with a couple of _plain_ styles. But in the end it's up to the user to choose the right one and to layout the document. Table styles are not capable to align depending on the content (numbers, text, currency...), you would have to provide different variants, which is awkward IMHO. Table style can define padding but not the column/table width and row height. Check out https://design.blog.documentfoundation.org/2015/12/13/style-your-tables/

And finally I would wait for the outcome of the survey. We want to keep the community involved rather than design by committee. That doesn't mean that the likely high-rated "Scientific" style cannot be refined or supplemented later. But if the users down-vote "3D", for instance, we shouldn't invest much in this variant.
Comment 21 andreas_k 2017-05-02 11:42:21 UTC
I don't want to separate the table style layout widget.

It's more about there should be some styles for print output and for screen output, and I also understood that we should waite for the survey result. In addition there are some examples that will fit the print and screen output very well.
Comment 22 Yousuf Philips (jay) 2017-05-04 10:27:24 UTC
Created attachment 133062 [details]
element variants of ms word 2010 table styles
Comment 23 andreas_k 2017-05-11 07:13:58 UTC
Created attachment 133228 [details]
Table style update

I made a table style for
- List Style in black and colored
- Box Style in black and colored
- Grid Style in black
- Bill Layout
- Statistic layout
- Data analytic layout
- Newspaper Layout

The first 3 Styles will work for a config dialog like in Impress. I also show how the table will look like at different (not all) settings.

and some additional stuff like how to find the best border width, ...
Comment 24 andreas_k 2017-05-11 07:15:11 UTC
Created attachment 133229 [details]
Overview how the Andreas_Styles will look like
Comment 25 Heiko Tietze 2017-05-18 07:57:40 UTC
(In reply to andreas_k from comment #24)
> Created attachment 133229 [details]
> Overview how the Andreas_Styles will look like

1.3 Bill layout: Right align all columns perhaps?
1.3 Data analytic layout: the alternating grays are too different to my taste
2.1 and 2.2 have contrast issues, e.g. either darker yellow or black font color

There are numerous resources like http://www.colorsontheweb.com/Color-Theory/Color-Contrast and contrast checkers http://webaim.org/resources/contrastchecker/

2.1 Green lines? Don't see a purpose for that despite from how attractive it is
2.2 IMHO we should deliver not more than four different colors
Comment 26 Commit Notification 2017-10-30 17:20:16 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f8a754e49cac05c356abddb3d22d03874f1bec7d

tdf#101349 Default table styles

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Thomas Lendo 2017-11-02 08:28:15 UTC
Is something wrong with the patch?

In AutoFormat dialog I can see "Default Style", "Academic" and 9 invisible, nameless table styles with no colors and borders.

In Styles sidebar tab I can see only "Default Style", "Academic" and 1 nameless table style that does nothing.

Version: 6.0.0.0.alpha1+ (x64)
Build ID: 13c5dd1d98a480cb01ca8f24242c80e326e4ade8
CPU threads: 8; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-10-31_01:03:30
Comment 28 Heiko Tietze 2017-11-02 14:52:43 UTC
(In reply to Thomas Lendo from comment #27)
> Is something wrong with the patch?

Works like a charm, at least on Linux.

Version: 6.0.0.0.alpha1+
Build ID: 1f8c3e3b78e0abb96d06a51eca354ae7ade5deb2
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-11-01_22:57:04
Locale: en-US (en_US.UTF-8); Calc: group
Comment 29 Heiko Tietze 2017-11-02 14:53:40 UTC Comment hidden (no-value)
Comment 30 Commit Notification 2017-11-03 11:59:40 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22a95ea367cc005a382de23e51cba850b6dd5e6f

Revert "tdf#101349 Default table styles"

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 Commit Notification 2017-11-06 23:08:38 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a5af0fd9f27af42cf2e8571f659cdad6e606215b

tdf#101349 Default table styles

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 Martin Srebotnjak 2017-11-14 16:00:36 UTC
Hi, are these style names localizable, as they should be?
Namely, I cannot find them in today generated pot files of master...
Comment 33 Yousuf Philips (jay) 2017-11-14 18:29:51 UTC
(In reply to Martin Srebotnjak from comment #32)
> Hi, are these style names localizable, as they should be?
> Namely, I cannot find them in today generated pot files of master...

So we likely need to add the new table styles here[1] and also place them here[2].

[1] https://opengrok.libreoffice.org/xref/core/sw/inc/strings.hrc#214
[2] https://opengrok.libreoffice.org/xref/core/sw/source/core/doc/DocumentStylePoolManager.cxx#519

Jim: do we need to replace these strings as well?

https://opengrok.libreoffice.org/xref/core/include/svx/strings.hrc#643
https://opengrok.libreoffice.org/xref/core/sw/source/core/doc/SwStyleNameMapper.cxx#305
Comment 34 Heiko Tietze 2017-11-14 20:46:56 UTC
(In reply to Yousuf Philips (jay) from comment #33)
> So we likely need to add the new table styles here[1] and also place them
> here[2].

Patch submitted as the task was assigned to me https://gerrit.libreoffice.org/#/c/44739/
Comment 35 Jim Raykowski 2017-11-20 06:42:41 UTC
 
> Jim: do we need to replace these strings as well?
> 
> https://opengrok.libreoffice.org/xref/core/include/svx/strings.hrc#643
> https://opengrok.libreoffice.org/xref/core/sw/source/core/doc/
> SwStyleNameMapper.cxx#305

After following what uses the TableStyleProgNameTable in SwStyleNameMapper.cxx#305 I think the strings should be replaced.
RID_SVXSTR_TBLAFMT_ defines in svx/strings.hrc are needed by autoform.cxx

The following may be important
https://opengrok.libreoffice.org/xref/core/sw/inc/poolfmt.hxx#204
https://opengrok.libreoffice.org/xref/core/sw/source/core/doc/tblafmt.cxx#984
https://opengrok.libreoffice.org/xref/core/sc/source/core/tool/autoform.cxx#748
Comment 36 Jim Raykowski 2017-11-20 21:54:48 UTC
Maybe the old styles can be kept for legacy support but only offer the new styles in the autoformat dialog.
Comment 37 Yousuf Philips (jay) 2017-11-21 12:52:21 UTC
(In reply to Jim Raykowski from comment #36)
> Maybe the old styles can be kept for legacy support but only offer the new
> styles in the autoformat dialog.

So how would they be kept and only show the new ones in the autoformat dialog and sidebar?
Comment 38 Heiko Tietze 2017-11-21 19:36:33 UTC
Obviously, the localization of table styles is out of my capabilities. Abandoning the not working patch https://gerrit.libreoffice.org/#/c/44739/
Comment 39 Eike Rathke 2017-11-22 12:57:16 UTC
Bear in mind that an already existing autotbl.fmt (i.e. after an upgrade) in the user config holds
a) a certain number of old predefined table styles
b) following these, added user defined table styles

The new preset autotbl.fmt will only be copied to the user config and used if there does not exist one already, i.e. in a new installation.

So the new autotbl.fmt should be versioned differently (there are some version fields) and the code adapted such that depending on which version is read different labels are displayed.

As is, it is not possible to replace the old predefined styles with the new styles, unless the user replaces the file (and thus loses user-defined styles).

Some more sophisticated code could read the presets file and compare versions and if newer replace the predefined styles in the user config file. It would still need to be able to handle both versions though, as a new version presets file must not be necessarily available.
Comment 40 Eike Rathke 2017-11-29 12:04:34 UTC
Seems nobody jumped in, so I'll try to take a stab at this.
Comment 41 Eike Rathke 2017-11-29 15:50:07 UTC
Adding (not replacing) new translations seems to be easier than I
thought, we can use subsequent resource IDs as the ID is also stored in
the file for presets, user defined styles (which in this case the new
presets are because they were created as such) have 0xFFFF stored. These
"just" need replacement in the file then with a hex-editor.

But there are other problems with the new autotbl.fmt file:
* currency number formats are stored with a fixed [$€-407] currency, so
  applying such format results always in € displays and with the
  original symbol placement, not the current locale's currency and
  placement
  * instead, the format code must use the locale's currency symbol
    without the [$...-xxxx] designator so it can be replaced with the
    proper target locale's default currency format
    * additionally complicated is that it must be the currency symbol
      flagged as compatible in locale data if the locale uses more than
      one currency, for example in Germany it is DM instead of € symbol
      * "#.##0,00 €;[ROT]-#.##0,00 €" is not ok,
        "#.##0,00 DM;[ROT]-#.##0,00 DM" is ok and will be converted, for
        example to en-US "[$$-409]#,##0.00;[RED]-[$$-409]#,##0.00"
        * you'll also see when applying such table style again in your
          same locale, the format will be
          "#.##0,00 [$€-407];[ROT]-#.##0,00 [$€-407]" in de-DE
    * opening the number formatter dialog on a cell that has a legacy
      compatible currency symbol format applied displays "Automatically"
      as currency listbox entry (which otherwise is not selectable)
* most number formats not currency are @ Text formats, effectively
  preventing any numeric input in such Calc cells
  * those should be the General (Standard) format instead if not
    intentionally set to Text for the leftmost column or the topmost row
  * my guess is that such table styles were created in Writer tables
    without numeric cell content
  * it is easier and less error prone to create table styles in Calc
Comment 42 Commit Notification 2017-12-01 10:22:01 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d12aa833aec8e9a5c453104a23bff70cec54a45

tdf#101349 Rework of table styles for use in Calc

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 43 Commit Notification 2017-12-01 10:22:17 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b56cd8050137ed4555a5aca50d4949d941e1f132

Prepare for translated new AutoFormat Table Styles, tdf#101349

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 44 Commit Notification 2017-12-01 12:43:02 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=86df47658a277521f51a1e22e92dcc632124745c

tdf#101349 patch new resource IDs into autotbl.fmt

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 45 Commit Notification 2017-12-01 13:27:55 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5370989dc654bd99337e1dad534c6a38f42c9027&h=libreoffice-6-0

tdf#101349 Rework of table styles for use in Calc

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 46 Commit Notification 2017-12-01 13:28:05 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b22d3e8b34c14a01d97057478d18d4209356cb3&h=libreoffice-6-0

tdf#101349 patch new resource IDs into autotbl.fmt

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 47 Commit Notification 2017-12-01 17:31:53 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a2d5b912e103c680339162ccfd15783ba6bfa232&h=libreoffice-6-0

Prepare for translated new AutoFormat Table Styles, tdf#101349

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 48 Commit Notification 2017-12-01 20:11:44 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dcd14963c3f3de9599dbb12d738a26feb5f56df5

Ditch the hard coded red font attribute, tdf#101349 follow-up

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 49 Commit Notification 2017-12-02 15:00:41 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7dc7c347e2deedf41eddfd1c821981533e45192f&h=libreoffice-6-0

Ditch the hard coded red font attribute, tdf#101349 follow-up

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.