Download it now!
Bug 101462 - Number format: [DBNumX] not recognized
Summary: Number format: [DBNumX] not recognized
Status: RESOLVED DUPLICATE of bug 79399
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: medium normal
Assignee: Laurent BP
URL:
Whiteboard: target:5.3.0 target:5.2.2
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-08-12 09:02 UTC by Laurent BP
Modified: 2016-08-18 18:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2016-08-12 09:02:37 UTC
Description: Number format allows to use native number characters with [NatNumN] (N from 1 to 11) format code. It corresponds to [DBNumX] (X not always equals to N, see help) Excel format code. The corresponding code has been lost.

Steps to reproduce:
1. Format > Cells > Numbers
2. Enter user defined code: 
[DBNum1]YYYY
 (or AAAA or JJJJ or VVVV according to your locale)

Actual behavior:
The format code is not recognized and preview is empty

Expected behavior:
Format code containing [DBNumX] should be recognized.

Works fine with LibO 4.0.1.2
First reproduce with 4.0.3.3

Suspected commit:
https://cgit.freedesktop.org/libreoffice/core/commit?id=00609ef4d2ef46700a6411ac0f93114005153a4a
Comment 1 Buovjaga 2016-08-12 19:30:39 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.4
Build ID: 5.2.0-1
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 2 Commit Notification 2016-08-15 10:34:14 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b1ce5db192750210b1546417494664f91759719d

tdf#101462 tdf#79399 lcl_matchKeywordAndGetNumber returns integer

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Eike Rathke 2016-08-15 10:57:52 UTC
This is simply a duplicate of bug 79399, isn't it?
Comment 4 Laurent BP 2016-08-15 13:43:20 UTC

*** This bug has been marked as a duplicate of bug 79399 ***
Comment 5 Commit Notification 2016-08-16 10:25:34 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3deb5fed775290540611cde158051a647bb5e317&h=libreoffice-5-2

tdf#101462 tdf#79399 lcl_matchKeywordAndGetNumber returns integer

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2016-08-18 18:12:02 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=502574cb4f1c081b55445fd4b47de6693ef293e2

tdf#79399 tdf#101462 Add qa unit test

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.