Download it now!
Bug 79399 - Calc does not import [DBNum2] cell format correctly
Summary: Calc does not import [DBNum2] cell format correctly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: medium normal
Assignee: Laurent BP
URL:
Whiteboard: target:5.3.0 target:5.2.2
Keywords: regression
: 101462 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-29 08:27 UTC by Kevin Suo
Modified: 2016-08-18 18:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
XLSX file in which cell A1 is formatted as "[DBNum2]" (9.94 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-29 08:27 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-05-29 08:27:34 UTC
Created attachment 100088 [details]
XLSX file in which cell A1 is formatted as "[DBNum2]"

Description:
The attached xlsx file has cell A1 formatted as "[DBNum2]" number format. When open with libreoffice calc, this number format is not shown correctly.

Steps:
1. Open the attached xlsx file with calc.

Current Behaviour:
Cell A1 is showing "120".

Expected:
Cell A1 should show "壹佰贰拾"(which means ONE HUNDRED AND TWENTY).

This bug may be a duplicate of Bug 79398, but I am filing with different bug report.

Also, you may notice that when open the file, grid lines may be massed up, which is reported in bug 79395.
Comment 1 yanjingtao 2014-05-29 08:55:48 UTC
Reproducible with 

OS:Fedora 20 x86_64
Version: 4.2.4.2
Build ID: 4.2.4.2-8.fc20

OS:Fedora 20 x86_64
Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f

OS:Windows XP SP3
Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
Comment 2 Kevin Suo 2014-05-29 09:29:21 UTC
Please note:
In order for A1 to show as "壹佰贰拾", your OS should have zh_CN locale installed, because [NatNumX] and [DBNumX] are locale related.
Comment 3 QA Administrators 2015-06-08 14:42:23 UTC Comment hidden (obsolete)
Comment 4 Kevin Suo 2015-06-24 01:56:47 UTC
(In reply to QA Administrators from comment #3)
Bug still exists in
Version: 5.0.0.1
Build ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
Locale: zh-CN (zh_CN)
Comment 5 Laurent BP 2016-08-12 10:47:03 UTC
(In reply to Kevin Suo from comment #0)
> This bug may be a duplicate of Bug 79398, but I am filing with different bug
> report.
No, both bugs are different: this bug concerns import of DBNumX code which is a regression version 4.0.3

Bug 79398 concerns export of DBNumX code XL formats, which seems to never have been working
Comment 6 Commit Notification 2016-08-15 10:34:19 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b1ce5db192750210b1546417494664f91759719d

tdf#101462 tdf#79399 lcl_matchKeywordAndGetNumber returns integer

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Laurent BP 2016-08-15 13:43:20 UTC
*** Bug 101462 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2016-08-16 10:25:41 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3deb5fed775290540611cde158051a647bb5e317&h=libreoffice-5-2

tdf#101462 tdf#79399 lcl_matchKeywordAndGetNumber returns integer

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-08-18 18:11:12 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=502574cb4f1c081b55445fd4b47de6693ef293e2

tdf#79399 tdf#101462 Add qa unit test

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.