Bug Hunting Session
Bug 101566 - [I18N] Untranslated button names on the Track changes toolbar
Summary: [I18N] Untranslated button names on the Track changes toolbar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.3 target:5.1.6
Keywords:
: 96732 (view as bug list)
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2016-08-16 22:54 UTC by Gabor Kelemen
Modified: 2017-10-23 20:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem in 5.3 master (87.94 KB, image/png)
2016-08-16 22:54 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2016-08-16 22:54:21 UTC
Created attachment 126863 [details]
Screenshot of the problem in 5.3 master

Enable the Track Changes toolbar in Writer.
Right click on the toolbar, select Visible Buttons. The list of the buttons appears in English. 
These strings are not translatable, see for example: https://translations.documentfoundation.org/hu/libo_ui/translate/#search=Regular%20Comment&sfields=source

These are coming from sw/uiconfig/swriter/toolbar/changes.xml
and were introduced here: 
https://cgit.freedesktop.org/libreoffice/core/commit/sw/uiconfig/swriter/toolbar/changes.xml?id=bba15935842071289f6fbf9edef409b605254508

I find it interesting that there are no other toolbars using non-default names with the toolbar:text attribute:

gabor@dome:~/src/core$ find . -path "*toolbar*xml" -print0 | xargs -0 grep "toolbar\:text"
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:ShowTrackedChanges" toolbar:text="Show" toolbar:helpid="10624"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:TrackChanges" toolbar:text="Record" toolbar:helpid="10725"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:PreviousTrackedChange" toolbar:text="Previous"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:NextTrackedChange" toolbar:text="Next"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:AcceptTrackedChange" toolbar:text="Accept" toolbar:helpid="10625"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:RejectTrackedChange" toolbar:text="Reject" toolbar:helpid="10626"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:AcceptTrackedChanges" toolbar:text="List" toolbar:helpid="10622"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:InsertAnnotation" toolbar:text="Regular Comment" toolbar:helpid="10625"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:CommentChangeTracking" toolbar:text="Change Comment" toolbar:helpid="10625"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:ProtectTraceChangeMode" toolbar:text="Protect" toolbar:helpid="10625"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:CompareDocuments" toolbar:text="Compare"/>
./sw/uiconfig/swriter/toolbar/changes.xml: <toolbar:toolbaritem xlink:href=".uno:MergeDocuments" toolbar:text="Merge" toolbar:visible="false"/>
gabor@dome:~/src/core$ 

Maybe it would provide for a consistent UX if we would just drop these button nicknames altogether.
Comment 1 Thomas Hackert 2016-08-29 16:00:10 UTC
Hello Gabor, *,
I can confirm your bug with
OS: Debian Testing AMD64
LO: back to Version: 4.4.1.2
Build-ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Gebietsschema: de_DE
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux, and my oldest installed 4.4.x series)
. With
LO: Version: 4.3.7.2
Build-ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba
(also parallel installed) I do not see this issue ... ;)

So setting status to new, but will change the version to 4.4.1.2. If you think, I am wrong here, feel free to change it back ... ;)
HTH
Thomas.
Comment 2 Gabor Kelemen 2016-09-11 18:49:34 UTC
Seems like this was just fixed here: https://gerrit.libreoffice.org/#/c/28814/ - thanks!
Comment 3 Commit Notification 2016-09-12 20:46:27 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b7707bb8bcf0965d2d81f9c82672cb11829737f&h=libreoffice-5-2

tdf#101566 Remove untranslatable labels from changes toolbar

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-09-13 17:33:32 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2e81f0770706758191ad871395fb36cfa5355cd4&h=libreoffice-5-1

tdf#101566 Remove untranslatable labels from changes toolbar

It will be available in 5.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Maxim Monastirsky 2017-10-23 20:18:14 UTC
*** Bug 96732 has been marked as a duplicate of this bug. ***