Bug 101616 - European Portuguese Thesaurus Update
Summary: European Portuguese Thesaurus Update
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.3
Keywords:
: 101615 (view as bug list)
Depends on:
Blocks: Thesaurus
  Show dependency treegraph
 
Reported: 2016-08-19 17:43 UTC by Tiago Santos
Modified: 2017-02-04 11:16 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
European Portuguese Thesaurus Update (946.84 KB, application/zip)
2016-08-19 17:47 UTC, Tiago Santos
Details
Updated Portuguese Thesaurus (1.32 MB, application/zip)
2016-08-21 14:46 UTC, Tiago Santos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tiago Santos 2016-08-19 17:43:26 UTC
In attachment I submit a proposal for new European Portuguese thesaurus based on a merge of the existing OpenThesaurus base and project PAPEL (http://www.linguateca.pt/PAPEL/). It was also submitted today to the team responsible for former dictionary maintenance from Universidade do Minho, for inclusion in their extension.
This thesaurus nearly quadruples the amount of words recognized by the former thesaurus, with the level of quality, at least, equivalent to the one provided by OpenThesaurus.
Comment 1 Tiago Santos 2016-08-19 17:47:23 UTC
Created attachment 126911 [details]
European Portuguese Thesaurus Update
Comment 2 Tiago Santos 2016-08-19 17:51:01 UTC
*** Bug 101615 has been marked as a duplicate of this bug. ***
Comment 3 Marco A.G.Pinto 2016-08-19 18:46:41 UTC
Tiago sent me the thesaurus a few hours ago for me to check and it seems a very good work.

:-)

Minho University in Portugal has already been contacted hoping that in future releases of the pt_PT speller OXT will also include this thesaurus.
Comment 4 Tiago Santos 2016-08-20 18:18:07 UTC
Many thanks for reviewing Marco. 

I will keep you in the loop with the another improved version with an extra 6000 words recognized (maybe this weekend though I can not guaranty that).
Comment 5 Tiago Santos 2016-08-21 14:46:33 UTC
Created attachment 126933 [details]
Updated Portuguese Thesaurus

In attachment, I submit an updated proposal for a new European Portuguese thesaurus based on the merge of the existing OpenThesaurus base, project PAPEL (http://www.linguateca.pt/PAPEL/) and project ONTO.PT (http://ontopt.dei.uc.pt/). It will also be submitted today to the team responsible for former dictionary maintenance from Universidade do Minho, for inclusion in their extension.
This thesaurus adds ONTO.PT definition to the former proposed thesaurus. These definitions contain some correspondence between Brazilian Portuguese and European Portuguese words, so, considering that at the moment there is no valid thesaurus for Brazilian Portuguese, it might also be suited for inclusion as a Brazilian thesaurus. 
The custom dictionary included in this zip file should only be considered for that language and after linguistic review.
Comment 6 Marco A.G.Pinto 2016-09-22 08:44:17 UTC
Tiago Santos sent the thesaurus to Minho University in Portugal and they are suppose to include it on the next OXT update if all goes well.

Minho University is the maintainer of the pt_PT spellers.
Comment 7 Xisco Faulí 2016-09-23 08:25:38 UTC
Setting this to NEW. Please close this bug when the thesaurus is included.
Comment 8 Tiago Santos 2016-10-03 14:16:55 UTC
Second version validated and integrated in Dicionários Natura.

http://natura.di.uminho.pt/download/sources/Dictionaries/openoffice/Pos-AO/
http://natura.di.uminho.pt/download/sources/Dictionaries/openoffice/Pre-AO/
https://pt.libreoffice.org/transferir/dicionarios/

I notice that the local git copy does not contain dictionaries projects. With whom should I discuss to submit this to the repos?
Comment 9 jani 2016-10-03 14:21:36 UTC Comment hidden (obsolete)
Comment 10 jani 2016-10-03 14:42:26 UTC Comment hidden (obsolete)
Comment 11 Tiago Santos 2016-10-03 14:47:37 UTC
@Jan

> but you only need that, if you want to build with languages, otherwise just
> submit from the local repos.

I am not sure I understood this. I am building only the language modules and I would like to update this and the updated dictionarie (on behalf of Alberto Simões).
I have also started working on other European Portuguese improvements, so, all I have to do is to get the local copy of the dictionaries branch? I tried to figure out who is the European Portuguese maintainer but I was not able to find one.
It would be great to include him on this discussion.
Comment 12 Tiago Santos 2016-10-03 14:48:36 UTC
@Olivier,

I have included you because I noticed that you have worked with Brazilian dictionaries. 

At the moment, Brazilian Language is one of the best supported languages in LO, but at the moment it lacks a pre-bundled thesaurus. 
Brazilian DicSin does not come bundled with LO, possibly due to size and quality considerations. 

I would like to discuss with you the possibility of making it available for all Portuguese as a functional bundled thesaurus, considering that the Universidade do Minho chosen version contains relations between Brazilian and European Portuguese words.
On Linux the creation of symlink files is trivial and I am willing to do it. On Windows that is also a simple task but I need to know this feature is wanted and which protocol works with git.

Best regards
Comment 13 Tiago Santos 2016-10-06 19:33:53 UTC
Second version (Updated Portuguese Thesaurus.zip) pushed to master pushed to master.
https://gerrit.libreoffice.org/#/c/29510/

Many thanks Andras. 

Closing as Fixed.