Bug 101731 - Rename gradient 'border' label to something more meaningful
Summary: Rename gradient 'border' label to something more meaningful
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Ali
URL:
Whiteboard: reviewed:2022 target:7.5.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicUI
: 143282 (view as bug list)
Depends on:
Blocks: Area-Fill-Tab
  Show dependency treegraph
 
Reported: 2016-08-25 21:11 UTC by Yousuf Philips (jay) (retired)
Modified: 2022-07-30 09:14 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (82.44 KB, image/png)
2016-08-25 21:11 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-08-25 21:11:09 UTC
Created attachment 127028 [details]
screenshot

So the gradient tab of the area dialog has a field labelled 'border' which according to the help is to 'Enter the amount by which you want to adjust the area of the endpoint color on the gradient. The endpoint color is the color that is selected in the To box'. ODF has this feature in the draw:border attribute, which is why it must be labelled like this, but users wont be able to understand it, so i'd like to get input on what we can use instead.

From what i can visually see, this value sets where along the gradient fill path the start/from color will begin transitioning to the end/to color. So maybe 'Transition point' would be good.
Comment 1 Heiko Tietze 2017-11-07 10:21:07 UTC
"Transition point" sounds good to me (not making it clearer to the user, though). Any objection from the l10n team, Sophie, or documentation, Olivier? 

If not I guess you can patch yourself :-).
Comment 2 sophie 2017-11-07 10:37:20 UTC
Just checked Indesign (https://helpx.adobe.com/indesign/using/gradients.html) who call it 'midpoint', maybe it's more easy to understand than 'transition'? I'm not sure but both are ok for me anyway :) - thanks for your work Jay! Sophie
Comment 3 Heiko Tietze 2017-11-07 10:44:36 UTC
Or just "Offset" like GIMP.
Comment 4 Olivier Hallot 2017-11-07 12:09:16 UTC
(In reply to Yousuf Philips (jay) from comment #0)
> Created attachment 127028 [details]
> screenshot
(...)
> From what i can visually see, this value sets where along the gradient fill
> path the start/from color will begin transitioning to the end/to color. So
> maybe 'Transition point' would be good.

Measured by color picker in a figure with a gradient applied, the border is the line where the transition starts. Before the border line, the color is constant.

So maybe 
"Transition start line", 
"transition begin line" 
"start of (color) transition"
Comment 5 QA Administrators 2019-06-01 02:48:47 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2021-06-01 04:30:07 UTC Comment hidden (obsolete)
Comment 7 Regina Henschel 2021-07-09 21:40:22 UTC
There is still no new wording.
Comment 8 Regina Henschel 2021-07-09 21:44:45 UTC
*** Bug 143282 has been marked as a duplicate of this bug. ***
Comment 9 Heiko Tietze 2021-07-15 14:11:33 UTC Comment hidden (obsolete)
Comment 10 Heiko Tietze 2021-07-15 14:16:08 UTC
We discussed the topic in the design meeting.

"Border" could become "Distance to edge". But we don't see much issue for Start/End value (or rather no advantage of changing this label). Rather some tooltips would help users.

Border/distance: "Defines the distance to the edge of the area where the gradient of the transparency starts. The border area itself will take the transparency from the edges of the gradient."
Start/end value: "Percent of transparency at which the gradient starts/ends"

This is an easyhack.

"Border" in gradient tab of the area style at cui/uiconfig/ui/gradientpage.ui and for the transparency tab it should be cui/uiconfig/ui/transparencytabpage.ui
Comment 11 Regina Henschel 2021-07-15 20:55:01 UTC
(In reply to Heiko Tietze from comment #10)
> We discussed the topic in the design meeting.
> 
> "Border" could become "Distance to edge".

Not specific enough, "Border" always refers to "Start".

 But we don't see much issue for
> Start/End value (or rather no advantage of changing this label). Rather some
> tooltips would help users.

Only 'Start' is relevant.

> 
> Border/distance: "Defines the distance to the edge of the area where the
> gradient of the transparency starts. The border area itself will take the
> transparency from the edges of the gradient."

... from the start of the gradient.

For color gradient it would be "take the color from the start of the gradient"
Comment 12 Heiko Tietze 2021-07-16 09:36:46 UTC
(In reply to Regina Henschel from comment #11)
> Not specific enough, "Border" always refers to "Start".

Since border can be a frame occupying some space the term distance is sound more clear.
 
> Only 'Start' is relevant.

Don't get this.

> For color gradient it would be "take the color from the start of the
> gradient"

Yes, we must be careful with the transparency vs area UIs.
Comment 13 Mike Kaganski 2021-07-19 07:14:13 UTC
(In reply to Regina Henschel from comment #11)
> Only 'Start' is relevant.

*If* I understand it correctly, you imply that border always gets the transparency value of "start". No, that is wrong; the value of border's transparency is one of the outermost part of the gradient - and that depends on the gradient kind.
Comment 14 Regina Henschel 2021-07-19 12:48:25 UTC
(In reply to Mike Kaganski from comment #13)
> (In reply to Regina Henschel from comment #11)
> > Only 'Start' is relevant.
> 
> *If* I understand it correctly, you imply that border always gets the
> transparency value of "start". No, that is wrong; the value of border's
> transparency is one of the outermost part of the gradient - and that depends
> on the gradient kind.

You are right. I forgot that "axial" is the other way round and uses the end color/transparency.

But the problem remains, that "distance to edge" does not say in case of "linear" which edge is used.
Comment 15 Mike Kaganski 2021-07-19 14:19:48 UTC
(In reply to Regina Henschel from comment #14)
> But the problem remains, that "distance to edge" does not say in case of
> "linear" which edge is used.

In theory, yes. But OTOH "Linear" gradient may be considered to only have two edges - at orthogonal directions to the axis (line) of the *linear* gradient.

OTOH, I would love to have terminology/wording improved; just I'm bad in creating UI strings :)
Comment 16 Mike Kaganski 2021-07-19 14:22:57 UTC
FTR: as I mentioned on the call, my vision of improving the situation would be not creating a better wording (easier to implement, but harder to come with a short and correct and clear wording), but creation of:

1. Tooltips appearing on hover - allow to include more information;
2. Dynamically changing preview with some indication of affected area appearing on hover/activation of a relevant control (be it a shadow, or some arrow(s)...)
Comment 17 Regina Henschel 2021-07-19 15:07:54 UTC
(In reply to Mike Kaganski from comment #16)
> FTR: as I mentioned on the call, my vision of improving the situation would
> be not creating a better wording (easier to implement, but harder to come
> with a short and correct and clear wording), but creation of:
> 
> 1. Tooltips appearing on hover - allow to include more information;

Can the tooltip depend on the chosen gradient type?

> 2. Dynamically changing preview with some indication of affected area
> appearing on hover/activation of a relevant control (be it a shadow, or some
> arrow(s)...)

A more informative preview would be good. In the transparency page is lot of space for additional parts, but the color gradient page is glutted.
Comment 18 Mike Kaganski 2021-07-19 15:21:52 UTC
(In reply to Regina Henschel from comment #17)
> Can the tooltip depend on the chosen gradient type?

Yes. https://opengrok.libreoffice.org/xref/core/sw/source/ui/fmtui/tmpdlg.cxx?r=2633d5f9#82 shows setting both normal tooltip (set_tooltip_text), and extended tooltip (set_accessible_description) at runtime.
Comment 19 Tulio Macedo 2021-12-04 23:28:38 UTC
Considering the past comments,  I'd like to add the following, "Border" in this case means the point from the initial color when the final color is applied, this is valid in linear and other types. So, some suggestions from Olivier, back in 2017, still applies, just without "line" word, I believe. "Transition start" or "Transition begin" would be great ideas to start.
Comment 20 Ali 2022-06-30 11:01:49 UTC
I think midpoint is the best replace
I assign task to my self and I'm going to change it
Comment 21 Commit Notification 2022-07-23 14:30:40 UTC
Ali_Abdollahian committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5e7663b792ee1d56838d7a5082e5c29867f839f2

tdf#101731 Rename gradient border label to midpoint

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.