Download it now!
Bug 101928 - Jump after saving and use of ctrl+alt
Summary: Jump after saving and use of ctrl+alt
Status: RESOLVED DUPLICATE of bug 95797
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-06 10:31 UTC by F. Gerken
Modified: 2016-09-29 20:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description F. Gerken 2016-09-06 10:31:51 UTC
Dear LibreOffice Team,
these two aspects should be altered for a better use. If I scroll around in my partially very long documents and it saves automatically it always jumps back to the point I was writing the last time. That is very annoying because I have to scroll back to the point I was reading. I really can't find any purpose of this feature, it only wastes time and nerves.

The second could probably be a bug but I'm not sure: I can't fill in glyphs like [,],| or ~ which use CTRL+ALT to be filled in. There simply happens nothing when I try it. Even @ and € don't work. If I press CTRL+ALT+E for a € there opens a menu bar. But these short cuts are essential!

That's it. Many thanks for updating this great software, I never use Microsoft Office again although I'm using a windows computer. :)
Kind regards, Florian Gerken
Comment 1 Heiko Tietze 2016-09-07 08:21:47 UTC
First of all it's not helpful to report two issues in one tickets since it cannot be closed when one is fixed. 

Save: Haven't tested actually but I believe you will get to where the cursor is placed. So why don't you try to use the keyboard to navigate through the document?

Shortcuts: You can modify the default association at Tools > Customize. Not sure what you mean with glyphs and why it requires complicated shortcuts.
Comment 2 F. Gerken 2016-09-07 09:41:24 UTC
Thank you for your answer! I'm sorry, next time I'll use one ticket each.

Yes, it jumps back to the cursor. And navigating by keyboard is much slower than scrolling through. It is just not practical to jump back to the cursor after saving, if I can't disable this it should be removed in future versions. In my opinion. I don't see any advantages in it.

shortcuts: I mean the standard shortcuts for signs like € and [] and so on. In every browser and every other writer you can just press CTRL+ALT+E to get a €. That is no complicated shortcut but the fastest way to get a € rather than browsing the complete list of signs.
Tools>Costumize seems not to work for simple signs, only for features.
Comment 3 Buovjaga 2016-09-29 19:20:19 UTC
Update to 5.2, the jumping issue is fixed.

*** This bug has been marked as a duplicate of bug 95797 ***
Comment 4 V Stuart Foote 2016-09-29 19:52:13 UTC
The other facet would probably be a duplicate of bug 41981

But recently we've added capability to enter any Unicode glyph directly into a document by entering its codepoint, e.g. U+20ac and then toggle to its glyph using <alt>+X giving you your euro symbol €

Additionally shortcuts can be from either an IME or a so called "deadkeys" mapping. We have bug 71176 open for doing something similar to that. 

But probably more useful will be eventual work on the Special Character dialog to add a row of favorites and recently used glyphs to a graphical picker.
Comment 5 F. Gerken 2016-09-29 20:38:15 UTC
Well thank you so far. I didn't mean bug 41981 but if that one would be fixed I could solve the problem myself by just re-adding the shortcuts. 
On the German keyboard layout it is a standard feature to insert the €-symbol by pressing CTRL+ALT+E, the @-symbol by pressing CTRL+ALT+Q, ~ by pressing CTRL+ALT++ and so on, and it works in every application or program where you can type in things, like in browsers and even cheap computer games. LibreOffice is the first program I know where it doesn't work and it also doesn't help if I change the keyboard layout to another language. 
Hope I could help finding the problem. LibreOffice is still my favourite office application anyway.