Bug 102139 - Notebookbar changes to Home tab on a number of actions
Summary: Notebookbar changes to Home tab on a number of actions
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0
Keywords:
: 106299 (view as bug list)
Depends on:
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2016-09-12 23:47 UTC by Aron Budea
Modified: 2017-03-03 14:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-09-12 23:47:58 UTC
1. Switch to Notebookbar view (View -> Toolbar Layout -> Notebookbar).
2. In View tab click Print Preview.
3. Click Close Preview.

Note how Notebookbar's open tab switched to Home.

Version: 5.3.0.0.alpha0+
Build ID: 04695b95491b7e866298bf4231fb9cca25a35a93
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: hu-HU (hu_HU); Calc: CL
Comment 1 Aron Budea 2016-09-12 23:59:24 UTC
Hm, it switches back to Home in a number of other cases.

Like:
1. Write something, then turn on bullets.
2. Switch to a different tab.
3. Press Enter twice.

Open tab will switch back to Home.

Also:
1. Switch to a different tab.
2. Press Shift-F12. (turn bullets on/off)

Open tab will switch back to Home.
Comment 2 Commit Notification 2017-01-16 14:08:23 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b33715c00ea3a20e219d80845e72a2b37ba6c8cc

tdf#102139 : prevent the notebookbar from switching to empty tab

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2017-01-18 10:58:35 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cce54bf33808dc7422ded08a7d4d38fb0194a047

tdf#102139 : avoid switching to the empty tab after exiting the OLE Object

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 QA Administrators 2017-03-01 10:55:50 UTC
Hello Szymon,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 5 bureautiquelibre 2017-03-03 14:42:45 UTC
*** Bug 106299 has been marked as a duplicate of this bug. ***