Bug Hunting Session
Bug 102165 - scaled parenthesis overlap other elements in formular
Summary: scaled parenthesis overlap other elements in formular
Status: RESOLVED DUPLICATE of bug 103279
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-13 16:00 UTC by joern.kalz
Modified: 2016-10-18 20:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (34.71 KB, image/png)
2016-09-13 16:00 UTC, joern.kalz
Details
screenshot (68.33 KB, image/png)
2016-09-20 07:09 UTC, joern.kalz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description joern.kalz 2016-09-13 16:00:03 UTC
Created attachment 127300 [details]
screenshot

Scaled parenthesis in math formular overlap other content:

Example:

left ( 
	matrix { 
		a # b # c ##
		a # b # c ##
		a # b # c ##
		a # b # c 
	} 
right )

see also attached screenshot.

OS: Windows 10
Localization: German

By the way: Thank you very much for LibreOffice - it's a great product.
Comment 1 Jean-Baptiste Faure 2016-09-17 20:36:48 UTC
Not reproducible for me with version 5.2.3.0+ built at home under Ubuntu 16.04 x86-64.

Please could you try with the current 5.2 version ?
Set status to NEEDINFO, please set it back to UNCONFIRMED once requested informations are provided.

Best regards. JBF
Comment 2 joern.kalz 2016-09-20 07:09:46 UTC
Created attachment 127448 [details]
screenshot
Comment 3 joern.kalz 2016-09-20 07:18:20 UTC
(In reply to Jean-Baptiste Faure from comment #1)
> Not reproducible for me with version 5.2.3.0+ built at home under Ubuntu
> 16.04 x86-64.
> 
> Please could you try with the current 5.2 version ?
> Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
> informations are provided.
> 
> Best regards. JBF

Thanks for your quick reply.

The problem is the same with version 5.2.1.2 (see new screenshot).

This problem could be connected to OS (I use Windows 10) or Localization (I use German).

Before 5.1 and 5.2 I used 4.x. In 4.x this bug with scaled parenthesis in formulas did not yet exist. 
I am not sure, whether this is relevant, but in 4.x there was another, possibly connected problem with scaling in formulas: some symbols like the sum symbol did not scale at all. This bug about the not scaling sum symbol in 4.x is solved now.
Comment 4 Buovjaga 2016-10-09 10:27:28 UTC
I see from your screenie that you have OpenGL enabled. Try turning it off: Tools - Options - LibreOffice - View - Use OpenGL for all rendering

Set to NEEDINFO.
Change back to UNCONFIRMED after you have tried it.
Comment 5 joern.kalz 2016-10-18 12:27:03 UTC
Turning OpenGL off solves the problem. Thank you!
Comment 6 Buovjaga 2016-10-18 12:41:17 UTC
Thanks. This seems like bug 99231, which has a screenshot of parenthesis overlapping with other elements.

*** This bug has been marked as a duplicate of bug 99231 ***
Comment 7 V Stuart Foote 2016-10-18 14:05:33 UTC
Exactly the issue of Mike K's bug 103297 with notes on needed changes for nodes to compose multi element brackets/parenthesis/braces as from bug 32262

The scaling of a single character causes the overlap.

bug 92231 is about OpenGL composition of other characters into formula nodes

*** This bug has been marked as a duplicate of bug 103297 ***
Comment 8 V Stuart Foote 2016-10-18 20:27:00 UTC
of course that dupe should be to bug 103279 not 297, and ref to bug 99231 not 92231--sorry for the noise and my dyslexia.

*** This bug has been marked as a duplicate of bug 103279 ***