Bug 103297 - Macros fail when ODT document in Read-Only mode
Summary: Macros fail when ODT document in Read-Only mode
Status: RESOLVED DUPLICATE of bug 45313
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-17 17:49 UTC by vic.orgos+bugslibreoffice
Modified: 2017-02-24 13:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Macro fails in Read-Only mode for ODT on W7x64 with v5.0.5.2 (201.96 KB, image/png)
2016-10-17 17:53 UTC, vic.orgos+bugslibreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vic.orgos+bugslibreoffice 2016-10-17 17:49:25 UTC
Description:
I have a macro does a google search for the word under the cursor that I trigger with a keyboard shortcut. When the document is in Edit Mode it works without fail but when the document is ODT format I DISABLE Edit Mode then it fails with dialog box that says,

Libreoffice Error:
com.sun.star.uno.RuntimeExceptionScriptProtocolHandler::createScriptProvider(), 

Interestingly, if I open a .doc document and likewise DISABLE Edit Mode, I have no problem running the macro.

the macro can be as simple as:

print "hello"

BUT if I run the macro from the Tools->Macros->Organize Macros->LibreOffice Basic then it runs ok.

On ArchLinux running 5.1.5.2 it is the same BUT I can't even run the macro from Tools->Macros...


Steps to Reproduce:
1. Open .doc document
2. Disable Edit Mode, Edit Menu->Edit Mode
3. Launch macro using keyboard shortcut

Actual Results:  
Error dialog appears.

Expected Results:
Macro to execute.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 vic.orgos+bugslibreoffice 2016-10-17 17:51:10 UTC
In step 1. above I meant a .odt not a .doc document. Sorry.
Comment 2 vic.orgos+bugslibreoffice 2016-10-17 17:53:09 UTC
Created attachment 128050 [details]
Macro fails in Read-Only mode for ODT on W7x64 with v5.0.5.2
Comment 3 V Stuart Foote 2016-10-18 14:05:33 UTC
*** Bug 102165 has been marked as a duplicate of this bug. ***
Comment 4 Buovjaga 2016-11-01 19:25:25 UTC
I can't reproduce the failure.

I created a macro with print "hello" in an ODT document.
Assigned a keyboard shortcut to it.
Disabled edit mode.
Hello pops up just fine.

Please test with 5.2.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.2.2.0+
Build ID: 5.2.2-1
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha1+
Build ID: 6dc8f25ecf676a2e4d1a1018b729fef4096df8e7
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on October 28th 2016
Comment 5 vic.orgos+bugslibreoffice 2016-11-03 09:29:44 UTC
Tested on fresh Windows 7 32bit VM with fresh install of LO v5.2.2.2 and ODT document is in WEB Layout mode and the problem does occur consistently but does NOT happen in Print Layout mode.

Rechecked in v5.0.5.2 (Windows 7 x64 ) and it occurs in both layouts.

Rechecked in v5.1.5.2 (ArchLinux 32bit) and it occurs in both layouts.
Comment 6 Buovjaga 2016-11-03 10:18:16 UTC
(In reply to vic.orgos+bugslibreoffice from comment #5)
> Tested on fresh Windows 7 32bit VM with fresh install of LO v5.2.2.2 and ODT
> document is in WEB Layout mode and the problem does occur consistently but
> does NOT happen in Print Layout mode.

No problem for me, even if I set it to Web layout before disabling edit.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha1+
Build ID: 4b4abb73fcd7f2802e73102b3e7c30face8d309c
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: old; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-10-31_02:54:50
Locale: fi-FI (fi_FI); Calc: group

Win 7 Pro 64-bit, Version: 5.2.2.2 (x64)
Build ID: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI); Calc: CL
Comment 7 vic.orgos+bugslibreoffice 2016-11-04 19:06:53 UTC
Fresh VM running Windows 10 Pro 32bit -  LO Version: 5.2.2.2
Build ID: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
CPU Threads: 2; OS Version: Windows 6.2; UI Render: default; 
Locale: en-US (en_US); Calc: group

Regardless of Layout view, as soon as I toggle Edit Mode the error occurs and it persists even if I get out of Read-Only mode. 

I also tried installing JRE just in case, usually I don't have it installed, and there was no difference.
Comment 8 Luis 2017-02-24 13:55:50 UTC

*** This bug has been marked as a duplicate of bug 45313 ***