Download it now!
Bug 45313 - com.sun.star.uno.RuntimeException when starting any macro after using ".uno:EditDoc" once
Summary: com.sun.star.uno.RuntimeException when starting any macro after using ".uno:E...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 59670 89470 103297 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-27 07:55 UTC by BugZilla.20.gogo555
Modified: 2017-02-24 22:16 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
stack trace, m_pImpl == 0 in OStorage::getPropertyValue() (3.04 KB, text/plain)
2015-12-18 08:37 UTC, Oliver Specht (CIB)
Details
Test document of the bug. (11.01 KB, application/vnd.oasis.opendocument.text)
2017-02-23 09:17 UTC, Luis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BugZilla.20.gogo555 2012-01-27 07:55:54 UTC
When setting a document (any type) to "read only"-status by using:

* dispatcher.executeDispatch(document, ".uno:EditDoc", "", 0, Array())
  or
* the Icon in the menu-bar "standard"

starting any Macro will throw following Exception:

com.sun.star.uno.RuntimeException/home/fstrba/cvs/ooo-build/build/libreoffice-3.3.2.2/package/source/xstore/xstorage.cxx: :4877

... in a message box. The error can not be cought by "on error goto" since it happens before the macro starts. Macros were started by 
* menu (extras/macros/run macro) by 
* button in the document
* Icon in a menu-bar with linked macro

Macros always run when started with F5 from the BASIC-IDE!


LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2
Comment 1 BugZilla.20.gogo555 2012-01-27 07:58:45 UTC
Ubuntu 10.04 & 10.10
WinXP SP2
Comment 2 Joel Madero 2014-07-13 01:33:31 UTC Comment hidden (obsolete)
Comment 3 Clément Lassieur 2014-12-02 16:16:53 UTC
Hi,

Confirmed on:

/daily/master/Linux-rpm_deb-x86_64@46-TDF/2014-11-28_00.50.11
/daily/master/Win-x86@51-TDF/2014-11-28_08.54.54
Comment 4 Oliver Specht (CIB) 2015-12-18 08:37:54 UTC
Created attachment 121380 [details]
stack trace, m_pImpl == 0 in OStorage::getPropertyValue()
Comment 5 Oliver Specht (CIB) 2015-12-18 10:11:27 UTC
*** Bug 89470 has been marked as a duplicate of this bug. ***
Comment 6 QA Administrators 2017-01-03 19:49:29 UTC Comment hidden (obsolete)
Comment 7 Luis 2017-02-23 09:17:09 UTC
Created attachment 131425 [details]
Test document of the bug.
Comment 8 Luis 2017-02-23 09:17:32 UTC
Tested on LibreOffice 5.1.6.2 (Windows 7).
This bug is present.
I wanted a functionality in a LibreOffice based application not possible due to this bug.
I have created and attached a test document.
Download the document and press the button "Change mode" that executes this macro:

sub changemode
dim oDocument as object
dim oDispatcher as object
	oDocument = ThisComponent.CurrentController.Frame
	oDispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
	oDispatcher.executeDispatch(oDocument, ".uno:EditDoc", "", 0, Array())
end sub

After this the bug is manifested by pressing the button "Test".
Comment 9 Luis 2017-02-24 13:55:50 UTC
*** Bug 103297 has been marked as a duplicate of this bug. ***
Comment 10 Luis 2017-02-24 13:57:12 UTC
*** Bug 59670 has been marked as a duplicate of this bug. ***
Comment 11 Luis 2017-02-24 14:08:31 UTC
Tested on development version 5.4.0.0 of date 2017-02-23.
The bug IS NOT present.
I will locate in which version is corrected.
Comment 12 Buovjaga 2017-02-24 14:11:05 UTC
(In reply to Luis from comment #11)
> Tested on development version 5.4.0.0 of date 2017-02-23.
> The bug IS NOT present.
> I will locate in which version is corrected.

Thanks, Luis. If the bug is not in 5.3, I think nothing further needs to be done.

Closing as WFM.
Comment 13 Stephan Bergmann 2017-02-24 14:15:09 UTC
(With the random builds I have lying around on my Linux box, I can reproduce with attachment 131425 [details] in a 5.1 and a 5.2 build, but not with a recent master towards 5.4, so this may have been fixed meanwhile.)
Comment 14 Luis 2017-02-24 14:25:26 UTC
Bug present in 5.2.4.2
Comment 15 Luis 2017-02-24 21:38:44 UTC
Tested in 5.2.5.1 (Windows 8) -> Bug present.
Tested in 5.3.0.3 (Windows 8) -> Bug NOT present
Comment 16 Luis 2017-02-24 22:16:59 UTC
Improperly I set status to resolved-fixed by mistake.
Changed status to resolved-worksforme.