Download it now!
Bug 89470 - Connecting a macro to Print document event gives RuntimeException when printing a read-only file
Summary: Connecting a macro to Print document event gives RuntimeException when printi...
Status: RESOLVED DUPLICATE of bug 45313
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-19 13:44 UTC by Buovjaga
Modified: 2015-12-18 10:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2015-02-19 13:44:39 UTC
Cloned from bug 74536, comment 8.

Repro steps:

1. Go to Tools - Customize - Events. Select "Print document" and assign an empty macro (standard - module1 - main)
2. Still in the Customize dialog, select Libreoffice in the "Save in" dropdown
3. Create and save a new text document
4. Change document editing status to read-only status using Edit - Edit mode (Ctrl-Shift-M)
5. Print document

Printing fails with error message: com.sun.star.uno.RuntimeExceptionScriptProtocolHandler::createScriptProvider(),

Tested on:
Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: b13534de022972131b46f93f5ada90af155eec9e
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-02-19_00:21:37
Locale: fi_FI

Confirmed by raal on Linux and the original reporter on Win 7.
Comment 1 Oliver Specht (CIB) 2015-12-18 10:11:27 UTC
Same problem as in issue 45313

*** This bug has been marked as a duplicate of bug 45313 ***