Bug Hunting Session
Bug 102273 - Cell data validity imported from xlsx fails
Summary: Cell data validity imported from xlsx fails
Status: RESOLVED DUPLICATE of bug 96698
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks:
 
Reported: 2016-09-19 08:55 UTC by Morten Leikvoll
Modified: 2017-06-15 09:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet demonstrating the bug. (58.16 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-09-19 08:55 UTC, Morten Leikvoll
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Morten Leikvoll 2016-09-19 08:55:12 UTC
Created attachment 127424 [details]
Spreadsheet demonstrating the bug.

The data validity fails after importing the attached xlsx spreadsheet.

I am unable to look at the original formatting details, as I do not have access to MS Excel, but after import, the criteria tab show Allow:All values. Other fields in this tab is greyed out, but the grey fields contain Data:valid range, Minimum:OR(K26="Y",K25="N"), Maximum:0, suggesting the original format may be incompatible with Libreoffice Calc, and needs converting.

The Error Alert tab, have the "show error messages when invalid values are entered" checked, and Action=Stop, Title=Invalid Entry!, Error message:Press enter Y or N (Yes/No).

This obviously was written to check if you enter y or n, but it fails with the above error message, no matter what you try to type in the cell. Since criteria apparently was converted to allow all, but still fails, this looks like a bug. But of course, the preference would be proper conversion or support for the original condition.

FYI:The attached xlsx spreadsheet can also be found in bug#102272 since it contains two bugs.
Comment 1 Buovjaga 2016-10-16 10:46:18 UTC
Went to K25 to check the validity in both Excel and Calc and I confirm that Excel has "Own condition" and the formula is editable.

Win 8.1 32-bit
MSO 2013
LibO Version: 5.3.0.0.alpha0+
Build ID: 970a66f8c919ea0524f216f40d21b3e2a8c88ccc
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-10-16_00:03:17
Locale: fi-FI (fi_FI); Calc: group
Comment 2 Justin L 2017-05-25 15:52:55 UTC

*** This bug has been marked as a duplicate of bug 96698 ***
Comment 3 Justin L 2017-06-15 09:31:03 UTC
(In reply to Morten Leikvoll from comment #0)
> Since criteria apparently was converted to allow all, but still fails,
>this looks like a bug.
Actually, the criteria IS imported as custom (even though custom isn't properly supported).  It is just that the UI doesn't have custom as an option - so it shows as "All Values" even though that is not how it is implemented.  (It WILL be implemented as "All Values" if you now hit OK instead of Cancel).