Bug Hunting Session
Bug 102302 - 'Title Slide' and 'Centered Text' slide layouts ignores content colors
Summary: 'Title Slide' and 'Centered Text' slide layouts ignores content colors
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Master-Slide-View
  Show dependency treegraph
 
Reported: 2016-09-20 01:00 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-09-22 00:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Master with red title and green content (10.76 KB, application/vnd.oasis.opendocument.presentation)
2016-09-20 06:35 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-09-20 01:00:49 UTC
Steps:
1) Start impress
2) Switch to master slide mode
3) Set text color and bullet color of title and content textboxes to red
4) Close master slide mode
5) Notice that non-title textbox isnt red
6) Change slide layout to 'Title, Content' and notice it is now red
7) Switch to 'Centered Text' slide layout and notice that it isnt red

Not sure if this how it was meant to be, but this seems strange to me.

Version: 5.3.0.0.alpha0+
Build ID: 3287bc2f91438085b7604773d5e0346fc3c3f452
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-09-18_06:17:20
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Heiko Tietze 2016-09-20 06:35:42 UTC
Created attachment 127447 [details]
Master with red title and green content

/confirmed

Version: 5.3.0.0.alpha0+
Build ID: ba269f7294e2416659011cbb498a2c6b5f9d5199
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-12_02:36:16
Locale: de-DE (de_DE); Calc: group
Comment 2 Heiko Tietze 2016-09-20 06:36:15 UTC
(Removing UX keyword since it's an ordinary bug)
Comment 3 Cor Nouws 2016-09-20 08:22:20 UTC
hmm... I don't understand the problem.
attachment 127447 [details] behaves as I would expect: red text in title text box and green in other text boxes from page layouts .. ?
Comment 4 Heiko Tietze 2016-09-20 08:29:59 UTC
(In reply to Cor Nouws from comment #3)
> attachment 127447 [details] behaves as I would expect...

If you switch the slide layout to centered text the font color is black.
Comment 5 Cor Nouws 2016-09-20 09:28:04 UTC
(In reply to Heiko Tietze from comment #4)
> (In reply to Cor Nouws from comment #3)
> > attachment 127447 [details] behaves as I would expect...
> 
> If you switch the slide layout to centered text the font color is black.

Ah :) then select the frame, right click and choose Edit style, and notice the dialog says "Subtitle". So it's just another style that is used there. OK?
Comment 6 Heiko Tietze 2016-09-20 09:43:23 UTC
Looks like the concept of master slide interferes with the styles concept. I'm fine with NAB, but how about killing the styles from Impress?
Comment 7 Regina Henschel 2016-09-20 20:30:42 UTC
Having the placeholder presentation objects on the master slide in addition to the style&formatting dialog is first time confusing. But that is not a reason to drop the styles. Do not kill styles from Impress.
Comment 8 Yousuf Philips (jay) (retired) 2016-09-21 02:45:47 UTC
Well i guess my issue boils down to a user being able to modify all the various placeholder textboxes and their styles interactively in master slide mode except for subtitle, where they would have to use the styles sidebar in order to modify it.

We have the 'object area for autolayouts' placeholder textbox which occupies the same space used by the subtitle textbox in Title Slide layout, but the textbox doesnt have a first line with text like 'Click to edit the subtitle text format', so a user could get easy access to modifying it.

Not having an easily accessible interactive means of modifying the subtitle in master slide mode is bad UX and something the average user wont discover as the only means to modify it is in a dialog.

So i guess we can reopen this bug to address this issue, or we can start up a new bug about it.
Comment 9 Cor Nouws 2016-09-21 06:34:28 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> Well i guess my issue boils down to a user being able to modify all the
> various placeholder textboxes and their styles interactively in master slide
> mode except for subtitle, where they would have to use the styles sidebar in
> order to modify it.

Indeed, thats the issue here.

> So i guess we can reopen this bug to address this issue, or we can start up
> a new bug about it.

done with bug 102318
Comment 10 Heiko Tietze 2016-09-21 06:56:35 UTC
(In reply to Yousuf Philips (jay) from comment #8)
* Master provides access to subtitles next to the auto-layouts

Alternative solutions, except of killing styles:
* Master is not used to deal with styles, i.e. no font color
* Master is/can be defined per slide layout (Slide design is actually a dialog to access templates per Load...); Microsoft Powerpoint works like this
* Styles dialog gets an overhaul and it becomes clear what style can be changed

* Workaround: Sidebar shows Styles and Formatting > Presentation Styles in master edit mode with a WYSIWYG preview; the subtitle is part of this list

Presentation styles cannot be applied to the selection, meaning I cannot switch a subtitle into a title. That's confusing since Graphic Styles, which are applied to text boxes and have the same look and feel as auto-layouts, work as expected. When we rename this style to Master Style it would be more clear (or we drop one of the styles *g*).
Comment 11 Yousuf Philips (jay) (retired) 2016-09-22 00:42:20 UTC
(In reply to Heiko Tietze from comment #10)
> * Master provides access to subtitles next to the auto-layouts

Tried to think of a plausible way this could be done, but couldnt come up with one, so look forward to seeing your mockup.

> Alternative solutions, except of killing styles:
> * Master is not used to deal with styles, i.e. no font color

The good thing about master slide mode is that users are modifying the underlying styles like they normally modify direct formatting.

> * Master is/can be defined per slide layout (Slide design is actually a
> dialog to access templates per Load...); Microsoft Powerpoint works like this

Doubt it would be easy to change to powerpoint's concept of master slides and their child layouts, but it would be nice to assign a default layout to a master slide. We currently have 3 main layout types - Title+Subtitle, Title+Content, Subtitle

> * Styles dialog gets an overhaul and it becomes clear what style can be
> changed

Would have to hear more about the idea to get what you mean.

> * Workaround: Sidebar shows Styles and Formatting > Presentation Styles in
> master edit mode with a WYSIWYG preview; the subtitle is part of this list

Should likely be renamed Master Slide Element Styles for better clarity as i always assumed it was a global style for the entire presentation, as thats how paragraph and cell styles are, but actually they are per master slide styles.

> Presentation styles cannot be applied to the selection, meaning I cannot
> switch a subtitle into a title. That's confusing since Graphic Styles, which
> are applied to text boxes and have the same look and feel as auto-layouts,
> work as expected.

I was confused on this as well previously.