Bug 102527 - LibreOffice start center has flickering scrollbar and glitchy highlight boxes
Summary: LibreOffice start center has flickering scrollbar and glitchy highlight boxes
Status: RESOLVED DUPLICATE of bug 93120
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks: Scrollbars Flickering-UI
  Show dependency treegraph
 
Reported: 2016-09-26 17:05 UTC by froilens
Modified: 2020-04-01 20:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
flickering ui (2.86 MB, video/mp4)
2016-09-26 17:05 UTC, froilens
Details

Note You need to log in before you can comment on or make changes to this bug.
Description froilens 2016-09-26 17:05:22 UTC
Created attachment 127648 [details]
flickering ui

When I scroll in the start center the scrollbar and the document list start to flicker. Moreover the highlight boxes that appear around the document thumbnails may look glitchy if you hover your mouse over said thumbnails.
Comment 1 tommy27 2016-10-05 08:05:04 UTC
please give details about your Linux version, GUI and graphic card.
Comment 2 froilens 2016-10-06 17:34:16 UTC
@tommy27 I use Ubuntu 16.04 with Unity 7 and I have Intel integrated graphics.
Comment 3 Thomas Hackert 2016-10-09 09:12:38 UTC
Hello Matteo, *,
(In reply to Matteo Paolini from comment #2)
> @tommy27 I use Ubuntu 16.04 with Unity 7 and I have Intel integrated
> graphics.

which one? I have tried to confirm your bug with
OS: Debian Testing AMD64
LO: Version: 5.2.2.2.0+
Build-ID: 1:5.2.2~rc2-2
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(Debian's own version)

and

LO: Version: 5.2.2.2
Build-ID: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)
Graphics adapter:
<quote>
lspci |grep -i graphics
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
</quote>

I can confirm however your bug with Debian's version (when using the down arrow of the scrollbar) but not with ours ... :( Which one are you using: the Ubuntu version or the one provided by LO?
Have a nice day
Thomas.
Comment 4 froilens 2016-10-09 14:17:42 UTC
@Tommy My processor is a Pentium P6100 and on both the terminal and Intel's official site it just says "Intel HD graphics". I'm using LO from the PPA.
Comment 5 Buovjaga 2016-10-09 18:44:04 UTC
(In reply to thackert from comment #3)
> Which one are you using:
> the Ubuntu version or the one provided by LO?

Matteo: please reply to this.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 6 froilens 2016-10-09 21:56:26 UTC
@Bouvjaga I use the one provided by LO.
Comment 7 Buovjaga 2016-10-10 06:29:25 UTC
I'll actually set to NEW as Thomas was able to repro.
Comment 8 Yousuf Philips (jay) (retired) 2016-10-17 04:03:44 UTC
I've seen the flickering scrollbars for years and it has been around since the start center document view was implemented. It happens in all vcl backends except gtk3 and this also affects the template manager which uses the same widgets/controls (sfxlo-RecentDocsView, sfxlo-TemplateDefaultView, sfxlo-TemplateSearchView, sfxlo-TemplateLocalView).

Flickering documents by scrolling up and down with the mouse wheel has also been there since the beginning, but it got worse with the 5.0 release, as likely it can refresh it faster but doesnt provide a smooth scrolling motion because it jumps so much per movement.

The flickering when you mouseover documents is because of the refresh of the highlight when the mouse moves over the tooltip.

I've seen the glitchy highlights boxes for a long time as well, but believe it has been fixed, as i havent seen it in a while.
Comment 9 Buovjaga 2018-02-01 10:13:47 UTC

*** This bug has been marked as a duplicate of bug 93120 ***
Comment 10 Commit Notification 2020-04-01 20:13:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/afad46c4e891359aad7a829e704e627e1039fc33

crashtesting: assert on loading fdo102527-1.html

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.