Bug 93120 - Flickering of Thumbnails in Start Center while Moving the Mouse Pointer (without GPU hardware acceleration)
Summary: Flickering of Thumbnails in Start Center while Moving the Mouse Pointer (with...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords:
: 102527 (view as bug list)
Depends on:
Blocks: Start-Center Flickering-UI
  Show dependency treegraph
 
Reported: 2015-08-04 14:19 UTC by Harald Koester
Modified: 2018-10-26 09:14 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
zip of a CamStudio AVI movie showing 1px residual (2.21 MB, application/zip)
2015-09-05 23:58 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2015-08-04 14:19:13 UTC
In order to reproduce the bug:
[1] Start LibreOffice. Some recent documents should be displayed as thumbnails. If not open some files and close them again.
[2] Move the mouse pointer slowly from the menu bar down to the first thumbnail. Stop moving when the thumbnail is selected. The path and file name is displayed as tip. 
[3] Go on moving down. Every time when the mouse pointer reaches the tip the thumbnail flickers once and the tip is displayed a bit more down. Expected: No flicker. 
[4] If you perform steps 2 and 3 faster the thumbnail flickers serveral times, which is quite irritating.

Comments:
(a) The flickering exists already since version 4.2.0, but it was not very obvious. With the change of the background colour (version 5.0.0.5) to dark grey the flickering becomes more distinct.
(b) I'm not sure if the position of the tip should change during moving the mouse pointer above a thumbnail. I think a fixed position (e.g. below the thumbnail, similar to tips of icons of the symbol bars) would be better.

OS: Win7, 32 Bit, LO: 5.0.0.5
Comment 1 raal 2015-08-05 02:56:50 UTC
Reproducible with Version: 5.1.0.0.alpha1+ (x64)
Build ID: e92a8b92072284fd7c37d7bb3e1e8fe72a185f35
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-22_21:46:26, win7
Comment 2 V Stuart Foote 2015-08-06 03:11:38 UTC
Yes, there is a noticeable flash during redraw. Believe it is an ongoing buffering issue, more noticeable at 5.0 release with change in StartCenter color scheme. None the less this is clearly a duplicate/continuation of bug 71807

*** This bug has been marked as a duplicate of bug 71807 ***
Comment 3 Harald Koester 2015-09-03 18:57:27 UTC
I'm sorry but I think there is a mistake. From my point of view there is no relationship between this bug and bug 71807 [Drawings (in Writer) embedded in document corrupted on saving. Rest of document is fine.]. May be another bug is meant. Hence set Status back to NEW.
Comment 4 V Stuart Foote 2015-09-03 19:04:51 UTC
Sorry that of course should have been dupe of bug 71087

*** This bug has been marked as a duplicate of bug 71087 ***
Comment 5 V Stuart Foote 2015-09-03 19:18:51 UTC
No, confirming and setting this back to new.

The issue is a canvas refresh, but it looks to come from movement of the Tooltip containing full file path. As cursor is moved, the Tooltip repositions and causes the entire thumbnail view canvas to be redrawn.

If you check on Tools -> Options ->  General: Extended Tooltips, which without local help installed shows a generic tooltip for the thumbnail views that does not reposition as the mouse moves.  There is no "flash" as the mouse traverses the frame.
Comment 6 V Stuart Foote 2015-09-03 19:21:16 UTC
@Kendy,

Can the drawing of the tooltip on mouse movement be adjusted to not also refresh the active thumbnail?
Comment 7 V Stuart Foote 2015-09-03 19:32:04 UTC
Have another aspect to the canvas redraw while the mouse cursor moves and the tool tip pop-up follows it.

As cursor is moved, and tooltips with file name and path are redrawn to follow along, the old border from the tooltip is not being erased.

Results in a ~1px white line for each tooltip as it relocates that was the old top edge and right edge of the tooltip. That ~1px line remains until the whole canvas is redrawn with a scroll bar movement or selection of a document or activation of a module.
Comment 8 Harald Koester 2015-09-03 21:54:37 UTC
(In reply to V Stuart Foote from comment #5)
> If you check on Tools -> Options ->  General: Extended Tooltips, which
> without local help installed shows a generic tooltip for the thumbnail views
> that does not reposition as the mouse moves.  There is no "flash" as the
> mouse traverses the frame.

This is different on my system (German UI, German local help installed(!), extended tool tips checked): The german generic tool tip is displayed. If you 'touch' this tool tip with the mouse pointer the position of the tool tip changes and the canvas also flickers in this case.

Furthermore with extended tool tips checked and local help installed, the flickering also occurs if you display the templates within the start center and 'touch' the displayed tool tip.
Comment 9 V Stuart Foote 2015-09-03 22:39:12 UTC
(In reply to Harald Koester from comment #8)
> > without local help installed shows a generic tooltip...
> 
> This is different on my system (German UI, German local help installed(!),
> extended tool tips checked): The german generic tool tip is displayed. If
> you 'touch' this tool tip with the mouse pointer the position of the tool
> tip changes and the canvas also flickers in this case.
> 

Yes I see that also, but I have to work to get the generic tooltip to appear at a location over a thumbnail.

Point was, that if the local help is not installed, by checking extended tips it is more obvious the issue is screen flash related to the canvas redraw of repositioned tooltips moving in response to the mouse movements.  The generic tip that shows with extended tips selected is for the whole StartCenter and does not get bumped around--as much--by mouse cursor movements.
Comment 10 V Stuart Foote 2015-09-05 23:58:58 UTC
Created attachment 118450 [details]
zip of a CamStudio AVI movie showing 1px residual

Screen capture video of 1px top and right edge of file path and name tool-tip leaving a trail as is pushed down across its thumbnail view on the StartCenter.
Comment 11 V Stuart Foote 2015-09-06 00:01:22 UTC
On Windows 10 Pro 64-bit en-US with
Version: 5.1.0.0.alpha1+
Build ID: d417059dae303685de7aa0f4b1c192ffcf5304d5-GL
TinderBox: Win-x86@39, Branch:master, Time: 2015-09-05_09:23:01
Locale: en-US (en_US)

When Tools -> Options -> View: "Use OpenGL for all rendering" is turned off, the tool-tip does not leave a trail.
Comment 12 Richard Prins 2015-09-21 08:51:26 UTC
This also happens in the template manager (file->templates->manage in writer)
Comment 13 V Stuart Foote 2015-12-07 22:33:20 UTC
With OpenGL active tooltips or file path "tip" are "off by one" when cleared as the tip is moved with mouse pointer movement. Leaving trails across the StartCenter until the screen is refreshed or resized.  The flickering on redraw is momentary--but the trails are persist.

When OpenGL rendering is disabled--the tooltips or file path "tip" is correctly disposed as the next is drawn. The "flicker" also is gone.

On Windows 8.1 Pro 64-bit

Version: 5.2.0.0.alpha0+
Build ID: ebe80ac6713b67b1801ede3d1e9038cb2c93cb11
Threads 8; Ver: Windows 6.2; Render: GL; 

Also, on Fedora 23 32-bit with
Version: 5.0.3.2
Build ID: 5.0.3.2-4.fc23-GL
Locale: en-US (en_US.UTF-8)
Comment 14 Michael Meeks 2015-12-10 11:48:42 UTC
I have a fix for this =) for 5.1 / master - it removes all flicker. Will push shortly.
Comment 15 V Stuart Foote 2015-12-12 21:09:04 UTC
Michael, *

On Windows 10 Pro 64-bit with

Version: 5.2.0.0.alpha0+
Build ID: 917d59a84124d1022bd1912874e7a53c674784f1
CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-12_12:17:04
Locale: en-US (en_US)

The tool-tips display of file name is still leaving a trail of redraw edges as it is pushed by mouse down the backing pane of the thumbnail view of Start Center.  

Also, don't see too much reduction in the "flicker" as each thumbnail is redrawn as the tool-tip repositions.

It only occurs when OpenGL is active, but may be a different facet than the double buffering you've been working on?
Comment 16 Michael Meeks 2015-12-12 22:17:42 UTC
Hah - so my patch removes GL related flicker; but for this case, it's un-related to GL AFAICS and was here from 4.2.0 ... so ;-)

The re-paint dirt is another bug that got tangled into here; but the flickering is prolly easy enough to fix - will have a look =)

Thanks !
Comment 17 V Stuart Foote 2015-12-17 01:18:31 UTC
On Fedora 23 w/LXDE (as guest on VMWare Workstation 12 on Windows 8.1) and
Version: 5.2.0.0.alpha0+
Build ID: 8a342e9f6ad701bd46ecca1c3d270ef2d9670d44
CPU Threads: 1; OS Version: Linux 4.2; UI Render: GL; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-12-16_12:23:28
Locale: en-US (en_US.UTF-8)

The flicker while redrawing each thumbnail is, at this point following Michael's patch, not as noticeable as under windows. However the tooltip filename ghost behaves the same. 

Present until the StartCenter is resized or redrawn by component launch. When OpenGL is disabled the "ghosting" of the tooltip frame vanishes.

As in movie clip comment 10.

Unfortunately for this build, no opengl_device.log being written to settings/cache directory.
Comment 18 V Stuart Foote 2016-01-04 17:29:03 UTC
On Windows 8.1 Pro with
Version: 5.2.0.0.alpha0+
Build ID: 4a8c0d313540bd78c9c381edd548b976c580ca9a
CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-01-04_02:00:52
Locale: en-US (en_US)

The off by one of the tooltip has been eliminated! Thumbnail views on backingwindow are clean. 

Any "Flicker" is gone--except for the still noticible redraw of the onmouseover background for the active thumbnail.

As mouse cursor is repositioned, the tooltip is redrawn in a new location. That triggers a clear and apply of the onmouseover background.  Might look like a "flicker", but it clearly follows the redraw of the moving tooltip.
Comment 19 Michael Meeks 2016-01-05 09:04:31 UTC
The ghosting / off-by-one error is fixed as bug#96858. Tor is tackling OpenGL related flicker under Windows in a similar way as for gtk+ too. Glad it's working nicely under Linux for you (though to use GL under Linux you need SAL_USE_VCLPLUGIN=gtk - gtk3 erroneously claims it is working, when it is not ;-)
Comment 20 Tor Lillqvist 2016-01-13 09:51:37 UTC
This flicker might be a generic problem with thingies that are displaying a tooltip. If you slowly move the mouse cursor between tool icons in the toolbar of Writer, for instance, so that the tooltip stays visible (and its contents switches as you move the cursor between icons), you will notice, now and then, that the icon you are leaving and/or entering flickers. Probably it is much more noticeable for the start centre thumbnails just because they are much larger and take a little longer to draw.
Comment 21 Tor Lillqvist 2016-01-13 10:18:17 UTC
... but in the case of toolbar icons, I see the flicker only when not using OpenGL. So maybe not the same root cause after all.
Comment 22 Harald Koester 2016-02-16 19:29:10 UTC
Checked again with version 5.1.0.3, Win 7: Bug still exists with and without using OpenGL. Also the flickering described in comment 8 still exists.
Comment 23 V Stuart Foote 2016-02-16 20:36:45 UTC
And as in comment 18, and initial description, this is now exclusively an issue of redrawing the thumbnail view or icon when mouse over focus shifts or as the tool tip is being repositioned.

It is normal, consistent and is acceptable given that that portion of the canvas is being redrawn.  It is less noticiple in OpenGL because it is accelerated, and it is not overly objectionable as it is rather hard to reproduce--slowly pushing the tool-tip to force the redraw of that thumbnail is hardly a normal action.

I'd say it is good enough and be done with it -- believe we can close WONTFIX.  Alternative of "anchoring" the tool-tip is much less appealing.
Comment 24 Michael Meeks 2016-02-17 11:10:10 UTC
Happy to leave it open if someone wants that but un-CC'ing the GL guys =) I don't see us having time to fix the minor cosmetic thing anytime soon.
Comment 25 V Stuart Foote 2016-02-17 13:23:19 UTC
@Kendy,

With OpenGL issues resolved (reworked buffering and effective black listing), would there be a lot of work in providing less graphically demanding mouse over behavior on the Start Center and Template Manager backingwindow, and for tooltip movement, for when hardware acceleration is not active or is blocked?

If not, suggest we close residual as WONTFIX.
Comment 26 QA Administrators 2017-03-06 15:26:02 UTC Comment hidden (obsolete)
Comment 27 Harald Koester 2017-03-16 15:52:09 UTC
Bug still exists in version 5.3.0 with Win7 and OpenGL disabled.
Comment 28 Buovjaga 2018-02-01 10:13:47 UTC
*** Bug 102527 has been marked as a duplicate of this bug. ***
Comment 29 Mike Kaganski 2018-03-27 08:23:19 UTC
https://gerrit.libreoffice.org/51930 fixes this on Windows.
Comment 30 Commit Notification 2018-03-27 13:39:27 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fec7dc8d4b82cc9a60d8625f313ba12d926665b5

tdf#93120: Avoid redraws when mouse enters tooltips (Win)

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 Xisco Faulí 2018-04-27 07:29:47 UTC
A polite ping to Mike Kaganski: is this bug fixed? if so, could you
please close it as RESOLVED FIXED ? Thanks
Comment 32 Mike Kaganski 2018-04-27 07:37:31 UTC
(In reply to Xisco Faulí from comment #31)

No, the last commit is for Windows only, and I'm not working on the other platforms.
Comment 33 Buovjaga 2018-04-30 17:42:49 UTC
Repro the flicker while chasing tooltip. GTK3 works fine.

Arch Linux 64-bit
Version: 6.1.0.0.alpha1+
Build ID: 632bc11ce8fab1c4046ab24810b90a7ce9ac5914
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 27th 2018
Comment 34 Harald Koester 2018-10-26 09:14:07 UTC
Verified with version 6.1.2 (64 bit) with Windows 10.