Bug 71087 - Start Center document list is flickering (Win only, with OpenGL disabled)
Summary: Start Center document list is flickering (Win only, with OpenGL disabled)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: NoRepro:4.2.0.1:OSX10.9 noRepro:4.4.0...
Keywords:
: 114993 (view as bug list)
Depends on:
Blocks: Start-Center Flickering-UI
  Show dependency treegraph
 
Reported: 2013-10-31 11:40 UTC by Urmas
Modified: 2019-02-02 17:17 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2013-10-31 11:40:58 UTC
There is flickering when navigating through the recent document list with a keyboard in the new Start center.
Comment 1 tommy27 2013-11-16 18:45:25 UTC
I see flickering too under Win7 64bit 

Version: 4.2.0.0.alpha1+
Build ID: 43cab408cdc9e3489113790d0990e50ca40f0adc
TinderBox: Win-x86@47-TDF, Branch:master, Time: 2013-11-15_23:44:51

changing status to NEW.

I add GUI expert to CC list.
Comment 2 retired 2013-12-17 11:01:54 UTC
Is this still happening for any of you with 4.2b2? I have never observed any such behavior. Maybe windows only? Or fixed already? Setting to NEEDINFO.
Comment 3 Urmas 2013-12-18 08:29:26 UTC
Of course it does.
Comment 4 retired 2013-12-18 09:25:13 UTC
Urmas which OS are you on? I've not seen nor heard of this happening on OS X so far.
Comment 5 retired 2014-01-10 12:03:11 UTC
Still wonder which OS this applies to. It has not and does not happen on OSX with 4.2.0.1.

Setting OS to WIN since it's been confirmed on that platform.
Comment 6 retired 2014-01-10 12:03:45 UTC
tommy27 does this persist with 4.2.0.1?
Comment 7 tommy27 2014-01-11 06:37:43 UTC
I have installed Version: 4.2.1.0.0+
Build ID: 88cd9632e081f5839cf9fddf60cbff0c099e2968
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-01-09_22:46:56

the problem is that I do not remember how to navigate through the recent document list with a keyboard...

it seems arrow keys do not work...
Comment 8 retired 2014-03-05 12:53:23 UTC
Use tab until you arrive at the recent document list. Then arrows should work fine.
Comment 9 Laurent BP 2014-04-03 09:22:09 UTC
Confirmed on Win 7 with LibO 4.2.3.2
Comment 10 kloud 2014-06-21 05:41:57 UTC
It's not limited to keyboard-navigation. It does apply to scrolling in the documents, too. The scroll bar also flickers.

XP, v4.3 RC1
Comment 11 tommy27 2014-07-20 09:12:06 UTC
still flickering under Win7x64 using  4.4.0.0.alpha0+
Build ID: b9dca968c6fd0ab5ca140c65b0e54d153cd34986
TinderBox: Win-x86@42, Branch:master, Time: 2014-07-18_22:51:20
Comment 12 josiasmat 2015-01-06 00:14:12 UTC
Confirmed on LibO 4.4.0.1 rc running under Windows 8.1 x64.

Also, the interface should be more responsive when navigating with the mouse.
Comment 13 V Stuart Foote 2015-01-06 00:38:34 UTC
"flickering" do you mean the momentary effect while the screen is refreshed/redrawn on scrolling, mouse over, or keyboard movement of object with focus on the Start Center?  Or as a manifestation of the digital video signal affecting the whole screen?

On Windows 7 sp1, 64-bit en-US with
Version: 4.4.0.0.beta2
Build ID: be92f32b8f21603a6b7a75dd645f7475bdee519d
Locale: en_US

and 

Version: 4.5.0.0.alpha0+
Build ID: 29c38bab7a69127c69f17c9a62b35faf68deb843
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2014-12-22_11:08:00
Locale: en_US

I do see the first, and that is completely normal screen redraw of the Start Center panel, both with and without the Tools -> Options -> View "Use hardware acceleration".  If this is the issue, please Resolve as Invalid.

The later would mean there are GPU hardware and/or driver issues with you systems.
Comment 14 josiasmat 2015-01-07 18:53:47 UTC
(In reply to V Stuart Foote from comment #13)
> "flickering" do you mean the momentary effect while the screen is
> refreshed/redrawn on scrolling, mouse over, or keyboard movement of object
> with focus on the Start Center?
> [...]
> I do see the first, and that is completely normal screen redraw of the Start
> Center panel, both with and without the Tools -> Options -> View "Use
> hardware acceleration".  If this is the issue, please Resolve as Invalid.

I think flickering, in any situation, cannot be normal. Is is a very annoying issue. And in these days when people are accostumed with using touch-screen devices which respond very quickly and without any graphical glitches, how can flickering be a "completely normal" thing? I don't agree.
Comment 15 V Stuart Foote 2015-01-31 19:20:54 UTC
There is NO flickering! 

Rather, as indicated, the entire GUI frame holding all widgets representing the recent documents list is being redrawn with each cursor movement of the focused object.

That as distinct from a mouse-over activation which is only refreshing a single thumbnail view.

@Kendy, before this is closed out of hand, is it possible to to adjust timing of the thumbnail view repaint to reduce the noticeable flash on redraw? Perhaps somehow fully buffer the frame first and then paint?
Comment 16 tommy27 2015-06-22 20:05:32 UTC
whether you call it flickering, flashing or redrawing, this issue is still present in LibO 4.4.3.2 and recent 5.1.0.0alpha
Comment 17 Jan Holesovsky 2015-06-23 16:03:27 UTC
This issue needs a substantial rewrite so that it is possible to get rid of the flickering.

The good news is that most of that has already happened, and we are bugfixing the rest (see the various commits mentioning 'rendercontext').  In the builds that have this enabled, start center is without flickering; we are now fixing Writer.
Comment 18 Urmas 2015-07-12 06:49:00 UTC
It became even worse, as the list is flickering even on scrolling now.
Comment 19 Harald Koester 2015-08-04 12:38:09 UTC
Due to the changed background colour of the Start Center (Version 5.0.0.5) to dark grey, the flickering is over again more obvious (scrollbar, keyboard). This is quite irritating and should be changed soon.
Comment 20 V Stuart Foote 2015-08-04 13:10:01 UTC
@Harold, *

(In reply to Harald Koester from comment #19)
> Due to the changed background colour of the Start Center (Version 5.0.0.5)
> to dark grey, the flickering is over again more obvious (scrollbar,
> keyboard). This is quite irritating and should be changed soon.

Please let us know your OS, GPU and its driver details. And if you are working with Tools -> Options -> View: "Use OpenGL for all rendering"

And if OpenGL is active, does "flickering" subside with it disabled? If that is the case, could be similar to bug 92708
Comment 21 Harald Koester 2015-08-04 16:16:02 UTC
OS: Win 7 Pro, 32 Bit
GPU: NVIDIA GEForce 7950 GT
Driver version according NVIDIA system control: 309.08
Driver version according OS: 9.18.13.908
"Use OpenGL for all rendering" is disabled. Option can't be enabled.
Comment 22 V Stuart Foote 2015-09-03 19:04:51 UTC
*** Bug 93120 has been marked as a duplicate of this bug. ***
Comment 23 V Stuart Foote 2015-09-03 19:09:59 UTC
For Windows users with nVidia GPUs, please update to latest supported nVidia driver set for your card.

Then test with current master:

Version: 5.1.0.0.alpha1+
Build ID: eb2e1ab4651350bffc53f618961a910bd3bbcfd9-GL
TinderBox: Win-x86@39, Branch:master, Time: 2015-09-02_23:59:59
Locale: en-US (en_US)

or

Version: 5.1.0.0.alpha1+
Build ID: 24703d7a98768cbb976b59455dd75f20c380b89c-GL
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-09-02_23:22:52
Locale: en-US (en_US)

Recent work on OpenGL may, or may not, have improved issue of the canvas "flickering" when displaying the thumbnail views of StartCenter.
Comment 24 Harald Koester 2015-09-04 10:43:40 UTC
(In reply to V Stuart Foote from comment #23)
> For Windows users with nVidia GPUs, please update to latest supported nVidia
> driver set for your card.
> 
> Then test with current master:
> 
> Version: 5.1.0.0.alpha1+
> Build ID: eb2e1ab4651350bffc53f618961a910bd3bbcfd9-GL
> TinderBox: Win-x86@39, Branch:master, Time: 2015-09-02_23:59:59
> Locale: en-US (en_US)
Tested with this version, but Locale: de-DE (de_DE)
OS and GPU according comment 21.

> Recent work on OpenGL may, or may not, have improved issue of the canvas
> "flickering" when displaying the thumbnail views of StartCenter.

With option "Use OpenGl for all rendering" checked:
(a) Scrolling with scroll bar: No more flickering, for me scrolling of thumbnails could be a bit smoother.
(b) Scrolling with mouse wheel: No more flickering, for me scrolling of thumbnails could be considerably smoother.
(c) Navigating with arrow keys: Works for me.

With option "Use OpenGl for all rendering" unchecked: Flickering of thumbnails theirselves and scroll bar in all 3 cases.

And: Changing the option will take effect only if LibreOffice is closed and opened again.
Comment 25 tommy27 2015-11-01 07:33:15 UTC
tested under Win8.1 x63
flickering is still present in LibO 5.0.3.1 even with "Use OpenGl for all rendering" checked.

no more flickering with that option checked in LibO 5.1.0.0.alpha1+ (x64)
Build ID: f173e148d8f2d0600fd50bee05e536932d529643-GL
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-10-30_22:26:03
Locale: it-IT (it_IT)

but if you uncheck that option the flickering will affect 5.1.x too

my graphic card is ATI AMD Radeon(TM) R5 Graphics
Comment 26 V Stuart Foote 2016-02-17 13:36:55 UTC
Redraw of LibreOffice Start Center / Template Manager graphical elements on non-hardware accelerated systems has been improved about as far as can be done without major rework to simplify (and remove) visual features.

What folks report as flicker, is precisely the element by element redraw of portions of the backingwindow canvas. OpenGL when available redraws smoothly, non-OpenGL rendering by GPU as controlled by OS drivers a bit less, and non-accelerated rendering by the CPU under OS graphics calls is noticeable as "flicker".

This should probably be resolved WONTFIX, but alternative might be to disable thumbnail view features on the backingwindow when hardware acceleration is disabled -- presenting a static landing similar to pre-4.2 releases.
Comment 27 QA Administrators 2017-03-06 15:57:05 UTC Comment hidden (obsolete)
Comment 28 Harald Koester 2017-03-16 20:40:34 UTC
Poblem still exists in version 5.3.0.
Comment 29 bugzilla2 2017-12-26 14:29:05 UTC
I can confirm the flicker/flashing/redraw problem in 5.4.4 and 6.0 RC1 on two different Notebooks with Windows (Win81 32Bit / Win10 64Bit).
It for sure is not a critical bug that should be addressed immediately, but it SHOULD be fixed in my opinion. And it doesn't make any difference if I use Classic Rendering or OpenGL, it flickers in all cases.
Comment 30 Buovjaga 2018-02-01 10:14:54 UTC
*** Bug 114993 has been marked as a duplicate of this bug. ***
Comment 31 QA Administrators 2019-02-02 03:44:20 UTC Comment hidden (obsolete)
Comment 32 bugzilla2 2019-02-02 10:40:43 UTC
The bug is still there in 6.2.4.

Btw. the headline is misleading, the flicker also happens with hardware acceleration enabled, at least as we talk about classic rendering.

No flicker in OpenGl mode (seems I need to give OpenGL another shot, it seems to be improved since I testet it the last time...)
Comment 33 bugzilla2 2019-02-02 10:42:22 UTC
Ahh, im stupid, meant 6.1.4 of course :/

So again:

The bug is still there in 6.1.4.2.

Btw. the headline is misleading, the flicker also happens with hardware acceleration enabled, at least as we talk about classic rendering.

No flicker in OpenGl mode (seems I need to give OpenGL another shot, it seems to be improved since I testet it the last time...)