Bug 102739 - Export to PDF with font substitution and Umlauts
Summary: Export to PDF with font substitution and Umlauts
Status: RESOLVED DUPLICATE of bug 89246
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Substitution
  Show dependency treegraph
 
Reported: 2016-09-28 09:43 UTC by Helmut Leininger
Modified: 2017-11-04 11:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Files to see the problem (292.97 KB, application/zip)
2016-09-28 09:50 UTC, Helmut Leininger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Leininger 2016-09-28 09:43:52 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build Identifier: LibreOffice 5.2.2.2

Maybe this is a duplicate of bug 89246.

The document has Arial font specified. LO has a replacement list to substitute Arial with Liberation Sans (always set). On screen it looks ok, and also when printing the Umlauts are printed. The fonts are installed on the system.

The exported PDF document opened by PDF-Xchange Viewer does not show the Umlauts although they are in the PDF file (Search finds them). Strange: Microsoft Edge displays the Umlauts in the PDF correctly.

This problem does not appear if the font substitution is disabled in LO.

An attachment contains the files to reproduce the problem.

Reproducible: Always




[Information automatically included from LibreOffice]
Locale: de
Module: TextDocument
[Information guessed from browser]
OS: Windows 10 64-bit
OS is 64bit: yes


Reset User Profile?No
Comment 1 Helmut Leininger 2016-09-28 09:50:10 UTC
Created attachment 127697 [details]
Files to see the problem

Ahnenliste_Anna_Guentner.doc  - original document
Ahnenliste_Anna_Guentner_with_replacement.pdf - export to PDF with font replacement enabled
Ahnenliste_Anna_Guentner_without_replacement.pdf - export to PDF with font replacement disabled
LibreOffice-Font-Replacement.jpg - screenshot with settings
Comment 2 Xisco Faulí 2016-10-10 14:43:43 UTC

*** This bug has been marked as a duplicate of bug 89246 ***
Comment 3 Xisco Faulí 2016-10-10 15:34:28 UTC
Hello Helmut,

Thank you for reporting the bug. This issue has previously been reported, so this bug will be resolved as a duplicate of the earlier report. You will automatically be added to the CC list of the other bug.
Comment 4 Helmut Leininger 2016-10-28 20:11:32 UTC
It may be a bug in PDF-Xchange Viewer.

It is ok when displaying it with browsers (MS Edge, Firefox) and PDF-Xchange Editor.