Download it now!
Bug 89246 - German umlaute characters (Ää Öö Üü) missing in exported PDF if text uses substituted font
Summary: German umlaute characters (Ää Öö Üü) missing in exported PDF if text uses sub...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.6.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
: 88319 99049 100309 102739 (view as bug list)
Depends on:
Blocks: Font-Substitution PDF-Export
  Show dependency treegraph
 
Reported: 2015-02-09 08:25 UTC by Watz
Modified: 2017-11-04 11:54 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Example in PDF (162.30 KB, application/pdf)
2015-02-12 10:22 UTC, Watz
Details
My Test Document The Source (35.44 KB, application/vnd.oasis.opendocument.text)
2015-02-12 10:23 UTC, Watz
Details
Generated PDF document, without any umlaut characters (119.25 KB, application/pdf)
2016-05-10 08:24 UTC, drunken monkey
Details
Source document with umlaut characters (8.72 KB, application/vnd.oasis.opendocument.text)
2016-05-10 08:25 UTC, drunken monkey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Watz 2015-02-09 08:25:01 UTC
Hello, 

Currently I have still a problem when exporting to a PDF file.
The worst part is, 
that the PDF umlauts Ää Öö Üü are completely missing, 
which is a no go.

The font I use is Helvetica in Win7 64bit.

When I choose Arial, than it works, no missing characters
but the documents I use are written in Helvetica. 

Is there any solution to that? 


P.S. I love the freeOffice idea... Thank You so much.
Comment 1 Jan 2015-02-10 15:20:19 UTC
Can you attach a (minimal) document and the generated pdf?
Which reader are you using?

Cannot reproduce on Ubuntu 14.04 using Libreoffice Version: 4.2.7.2 Build ID: 420m0(Build:2). Exporting umlauts to pdf just works fine.
Comment 2 Watz 2015-02-12 10:22:04 UTC
Created attachment 113334 [details]
Example in PDF

This is what I see, and not see after the PDF-Export.
Comment 3 Watz 2015-02-12 10:23:46 UTC
Created attachment 113336 [details]
My Test Document The Source

In the Document, everything ist ok.
Comment 4 Watz 2015-02-12 10:28:25 UTC
I' am using Acrobat 11 and PDFExchange Viewer. 
I think, what I need is a fix, workaround for the Helvetica TT font.
Comment 5 Watz 2015-02-12 10:32:19 UTC
Funny, when I open my test PDF-File in the Firefox browser, 
there is only the first Ö missing. 
Everything seems to be ok than.
But I can't still not see it in my normal pdf-viewer's.
Comment 6 QA Administrators 2015-09-04 02:55:43 UTC Comment hidden (obsolete)
Comment 7 Watz 2015-09-16 10:31:34 UTC
Even in the new version 5; 
this problem still exists for me. 

MyBe I should have used another font  ;-). 

No big deal, 
when nobody else got this functions.
Comment 8 drunken monkey 2015-10-25 17:17:15 UTC
Isn't this the same as 34212? Or what's the differnce?
Comment 9 QA Administrators 2016-05-09 20:07:40 UTC Comment hidden (obsolete)
Comment 10 drunken monkey 2016-05-10 08:24:29 UTC
Created attachment 124945 [details]
Generated PDF document, without any umlaut characters

I think all that information was already provided and it's just that no-one set the proper status?

Anyways, just tested it again in the current version (under Linux):

Version: 5.1.2.2.0+
Build ID: 5.1.2.2 Arch Linux build-1

Still the same result: the generated PDF lacks all umlaut characters when viewed in some PDF viewers. (Firefox, for example, shows them, albeit in a completely different font.)
Comment 11 drunken monkey 2016-05-10 08:25:02 UTC
Created attachment 124946 [details]
Source document with umlaut characters
Comment 12 Watz 2016-05-11 11:53:59 UTC
Even in the new version, this error is still there. 
And its easy to see and understand. 
I provided everything you need to understand. 
... an some do. 
I am so sorry.
Comment 13 charlesay 2016-05-31 13:45:04 UTC
affects me also and still
Comment 14 Aron Budea 2016-06-10 14:48:04 UTC
*** Bug 100309 has been marked as a duplicate of this bug. ***
Comment 15 Yousuf Philips (jay) (retired) 2016-10-05 05:09:26 UTC
Without helvetica installed on Linux Mint 17.3 (ubuntu 14.04 base) system, i cant reproduce this either in 3.3 or master using attachment 113336 [details].

Version: 5.3.0.0.alpha0+
Build ID: f309531cfe1d6a1b6ea1306d45ed3e121145bc5f
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-04_03:52:18
Locale: en-US (en_US.UTF-8); Calc: group
Comment 16 Dieter Praas 2016-10-06 13:25:23 UTC
Using the attachment from comment 15 I get the following result:

I can reproduce the bug using the PDF-Export in LibreOffice.

I can't reproduce the bug using the external programme PDF-Creator.

Version: 5.2.2.2 (x64)
Build-ID: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 17 drunken monkey 2016-10-06 14:13:20 UTC
For me, this problems appears to be fixed in version 5.2.2.2.0+ (Build ID: 5.2.2-1) – the latest in Arch Linux. (Or maybe it has to do with changes in Evince? Not 100% sure.)
Comment 18 Xisco Faulí 2016-10-10 14:19:24 UTC
*** Bug 99049 has been marked as a duplicate of this bug. ***
Comment 19 Xisco Faulí 2016-10-10 14:43:43 UTC
*** Bug 102739 has been marked as a duplicate of this bug. ***
Comment 20 Xisco Faulí 2016-10-10 14:50:35 UTC
*** Bug 88319 has been marked as a duplicate of this bug. ***
Comment 21 Yousuf Philips (jay) (retired) 2016-10-15 20:05:56 UTC
A user on reddit said "This occurs using the font "Liberation Sans Bold". I use Windows 7."

https://www.reddit.com/r/libreoffice/comments/55jyu1/libreoffice_writers_pdf_export/

Unfortunately i dont have windows 7, but have window 8.1 and tested attachment 113336 [details] and attachment 124946 [details] without having Helvetica, Disgusting Behaviour, or Nimbus Roman No9 L fonts on my computer and there wasnt any problems with the pdf export with 5.2.1.2.

@Stuart, @Bouvaja: Do you guys have a windows 7 machine.
Comment 22 V Stuart Foote 2016-10-15 21:01:34 UTC
(In reply to Yousuf Philips (jay) from comment #21)
On Windows 7 sp1 32-bit en-US with
Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
Locale: en-US (en_US)

Can not reproduce. I opened attachment 124946 [details] and attachment 113336 [details]

Of course I do not have Helvetica, Discusting Behavior, or Nimbus installed--so both documents render with replacement fonts, and on export to PDF with substitute fonts with their umlauts intact.

The Nimbus is exported as TimesNewRomanPSMT. The Helvetica as Liberation Sans. And the Disgusting Behavior as DejaVu Sans and Source Sans.

But, this looks to be duplicate of bug 34212 which has 
https://gerrit.libreoffice.org/#/c/29792/1 pending review

Perhaps give that a chance to post and retest.
Comment 23 Buovjaga 2016-10-24 10:23:13 UTC
(In reply to V Stuart Foote from comment #22)
> But, this looks to be duplicate of bug 34212 which has 
> https://gerrit.libreoffice.org/#/c/29792/1 pending review

Btw. regarding type 1 fonts: https://lists.freedesktop.org/archives/libreoffice/2016-October/075547.html

"Type 1 fonts are not supported. They can be supported with some effort, but Type 1 fonts have been obsolete for more than 15 years and I’d like to use this opportunity to drop support for them and cleanup some of the ugly code we have."
Comment 24 Yury 2016-10-24 11:37:45 UTC
(In reply to Buovjaga from comment #23)
> (In reply to V Stuart Foote from comment #22)
> > But, this looks to be duplicate of bug 34212 which has 
> > https://gerrit.libreoffice.org/#/c/29792/1 pending review
> 
> Btw. regarding type 1 fonts:
> https://lists.freedesktop.org/archives/libreoffice/2016-October/075547.html
> 
> "Type 1 fonts are not supported. They can be supported with some effort, but
> Type 1 fonts have been obsolete for more than 15 years and I’d like to use
> this opportunity to drop support for them and cleanup some of the ugly code
> we have."

I personally don't much care what the developers do with LO on windows platform, but linux platform advertises itself as a "platform for the people", of sorts. 

Now, I don't actually expect to have any import on that matter, but the quote's an example of rather unpleasant tone OSS developers are universally taking these days. Won't this and won't that, that thing's obsolete and that thing won't be missed by anybody. If you want something, write it yourself.

Hardly "for the people", this.

The fonts issue: I've bought a disk with type 1 fonts in 1997 -- how is it "obsolete", please?

Half of my legacy equipment works perfectly, but has no hope of running modern OSS software, and for what gains? I can not do significantly more with LO these days (excepting the new import/export formats), than I'd been doing in like 1999, when it was named StarOffice for OS/2.
Comment 25 Khaled Hosny 2016-10-24 12:34:21 UTC
> The fonts issue: I've bought a disk with type 1 fonts in 1997 -- how is it
> "obsolete", please?

They don’t support Unicode, they are limited to 256 characters/glyphs, they don’t support complex scripts. Even Adobe stopped making them for a decade and half now.

You can convert Type 1 fonts to OpenType using freely available tools, like makeotf from AFDKO (http://www.adobe.com/devnet/opentype/afdko.html) and as a bonus this bug with be “magically” fixed.
Comment 26 Yury 2016-10-24 21:28:53 UTC
(In reply to Khaled Hosny from comment #25)
> > The fonts issue: I've bought a disk with type 1 fonts in 1997 -- how is it
> > "obsolete", please?
> 
> They don’t support Unicode, they are limited to 256 characters/glyphs, they
> don’t support complex scripts. Even Adobe stopped making them for a decade
> and half now.

I feel that's a very wrong approach, somehow on par, BTW, with "snubbing" the word 2003 import/export issues.

Let's not have an argument, just one thought, though: so those fonts can't "do" those fancy things. They still have the glyphs for which they were bought, however. Or do they?

> You can convert Type 1 fonts to OpenType using freely available tools, like
> makeotf from AFDKO (http://www.adobe.com/devnet/opentype/afdko.html) and as
> a bonus this bug with be “magically” fixed.

Or open/export in FontForge. That's not the point. That sort of pruning of "obsolete"/"unneeded" features (while bloating the deliverables simultaneously, somehow) does the product no good.
In other words, alternative product (LO vs Word) can have "can't's".
Comment 27 Khaled Hosny 2016-10-24 21:46:16 UTC
> That sort of pruning of "obsolete"/"unneeded" features

Keeping support for Type 1 fonts requires active work and code no one is writing. Unless you are volunteering to do the needed work, you are simply feel entitled that others do work they don’t won’t to do to support features you want.

As you should have seen from the email, we are rewriting the text layout engine to be cross-platform and to solve tens of real bugs people have been reporting, there is no way we are going to postpone this just to keep supporting obsolete technology. You can always choose to not upgrade, or use different software or whatever.
Comment 28 Yury 2016-10-25 06:10:26 UTC Comment hidden (no-value)
Comment 29 Watz 2016-10-25 08:35:32 UTC
Yes; ok, I understand the point of the developers. 
Sorry I cannot program the stuff by myself. 
From time to time I give some money to help. 

I understand the idea with the cut, for old things. 
I also understand, that there are a lot of alternative fonts, 
that look a bit like the old PS1-fonts. 

As long, as you can find this program limitation in the manual, 
this is no issue. 

Maybe a warning, for using the wrong font. 

I just wanted to help, finding problems, for getting better ;-). 

Thanks for a great software. 
And many thanks to the team.
Comment 30 Yury 2016-10-25 09:33:38 UTC Comment hidden (off-topic)
Comment 31 Buovjaga 2016-10-25 09:51:30 UTC Comment hidden (off-topic)
Comment 32 Khaled Hosny 2016-11-11 23:43:47 UTC
The ESC decided to drop support for Type 1 fonts, so I’m closing this as invalid since 5.3 does not support Type 1 fonts by default (they are still supported by the old, non-default layout engine but this will also go away).

Please re-open if the bug is still reproducible with 5.3.
Comment 33 V Stuart Foote 2016-11-12 00:37:26 UTC
(In reply to Khaled Hosny from comment #32)
> The ESC decided to drop support for Type 1 fonts

Or more kindly... to not put the effort necessary into supporting the unsupportable format--the Harfbuzz common layout handles instances fairly well with replacement otf/ttf fonts.

-=ref-=

http://nabble.documentfoundation.org/Libreoffice-qa-minutes-of-ESC-call-tc4198434.html