Bug 102929 - Writer hangs after error message (SAXParseException: Attribute w:cstheme redefined) on invalid docx
Summary: Writer hangs after error message (SAXParseException: Attribute w:cstheme rede...
Status: RESOLVED DUPLICATE of bug 113790
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-SAXParse
  Show dependency treegraph
 
Reported: 2016-10-03 08:58 UTC by kosmas sofronidis
Modified: 2018-01-09 17:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
I cannot open this file (3.80 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-10-05 09:02 UTC, kosmas sofronidis
Details
fixed file (3.80 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-10-20 23:05 UTC, MM
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kosmas sofronidis 2016-10-03 08:58:22 UTC
cannot open a document  .docx.
Why this happens? How can I solve it?
Comment 1 Julien Nabet 2016-10-03 17:59:51 UTC
Which LO version do you use? (last stable one is 5.2.2)
Are you sure you use PowerPc ?
Do you mean you can't open any docx or just a specific one?
If a specific one, could you attach it so we can try to reproduce the problem?
Comment 2 kosmas sofronidis 2016-10-05 09:02:00 UTC
Created attachment 127818 [details]
I cannot open this file
Comment 3 kosmas sofronidis 2016-10-05 09:05:38 UTC
version 5.1.5.2
I use HP ProDesk 600 G1TWR, Windows 10 Pro, x64

I can't open a specific docx. I didn’t try for others.

OK I attach file
Comment 4 Julien Nabet 2016-10-10 19:04:35 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce the problem.
Here's a popup with this error:
File format error found at 
SAXParseException: '[word/document.xml line 2]: Attribute w:cstheme redefined
', Stream 'word/document.xml', Line 2, Column 8733(row,col).

Here are the console logs:
warn:unotools.config:3099:1:unotools/source/config/configitem.cxx:431: ignoring XHierarchicalNameAccess to /org.openoffice.Office.Compatibility// Exception: 
warn:unotools.config:3099:1:unotools/source/config/configitem.cxx:431: ignoring XHierarchicalNameAccess to /org.openoffice.Office.Compatibility// Exception: 
0x3be6250:createUnknownChildContext:b:Sources
0x3bd57e0:start unknown element:b:Sources
0x3bd57e0:end unknown element:b:Sources
warn:writerfilter:3099:1:writerfilter/source/dmapper/DomainMapper_Impl.cxx:573: no context of type 1 available
warn:writerfilter:3099:1:writerfilter/source/dmapper/DomainMapper_Impl.cxx:573: no context of type 1 available
warn:writerfilter:3099:1:writerfilter/source/dmapper/DomainMapper_Impl.cxx:573: no context of type 1 available
warn:svl:3099:1:svl/source/items/style.cxx:262: StyleSheet-Follow not found
warn:writerfilter:3099:1:writerfilter/source/dmapper/DomainMapper_Impl.cxx:573: no context of type 1 available
...
Comment 5 Julien Nabet 2016-10-10 19:33:05 UTC
Same SAXParseException in tdf#55196
Comment 6 kosmas sofronidis 2016-10-11 05:04:24 UTC
Thanks for your effort.
So, what happens next?
I can't use the file.
Please tell me in simple words
Comment 7 Julien Nabet 2016-10-11 09:11:47 UTC
Several possibilities:
1) Just wait some dev to fix this (it can take some days, some months or some years)
2) You can pay someone to fix this
3) If you know programming, you can contribute (see https://wiki.documentfoundation.org/Development)

I may be wrong but I think Microsoft provides free viewers for its modules (Winword, Powerpoint, Excel) so it may be a workaround if you just want to read the content (and perhaps export it in pdf).
Comment 8 MM 2016-10-20 23:05:18 UTC
Created attachment 128112 [details]
fixed file
Comment 9 MM 2016-10-20 23:07:05 UTC
Just removed all duplicates -> w:cstheme="minorHAnsi" in document.xml.
Comment 10 kosmas sofronidis 2016-10-21 07:10:36 UTC
Thank you for your help
Comment 11 Timur 2016-10-21 16:16:13 UTC Comment hidden (obsolete)
Comment 12 Timur 2016-10-21 16:43:21 UTC
It's wrong to trust error message in Bug 5519, I can't get it myself.

- attachment 127818 [details] cannot be open also with MS Office, it's corrupted, you just get an error message
- problem is not opening this file, but that LO Writer hangs after the error message

MSO error mesage is: no atttribute name may appear more than once in the same start tag or empty element tag

LO error message is:
File format error found at 
SAXParseException: '[word/document.xml line 2]: Attribute w:cstheme redefined
', Stream 'word/document.xml', Line 2, Column 8733(row,col).
Comment 13 MM 2017-12-23 22:53:44 UTC
The file might be corrupted, but with the newer version, on win7 x64 i've tested
Version: 6.0.0.1
Build ID: d2bec56d7865f05a1003dc88449f2b0fdd85309a
CPU threads: 3; OS: Windows 6.1; UI render: default; 

writer ignores part of the file and then opens. Could this report be closed for this reason (it doesn't hang anymore) ?
Comment 14 Mike Kaganski 2017-12-24 02:05:53 UTC
(In reply to MM from comment #13)

Yes, the cause of this bug must be fixed in bug 113790; opening what is possible to read from file was implemented in bug 104718; what about freeze - I couldn't reproduce it; I suspect that it had never froze actually, just progress bar wasn't reset - bug 104650, also fixed.

Please close as fits best.
Comment 15 Aron Budea 2018-01-09 17:06:05 UTC
Let's assume it's fixed based on bug 113790 and bug 104650. Thanks, Mike!

*** This bug has been marked as a duplicate of bug 113790 ***