Bug 55196 - FILEOPEN: particular MS-Word-Document layout infinite loop / LO hangs with 100% CPU
Summary: FILEOPEN: particular MS-Word-Document layout infinite loop / LO hangs with 10...
Status: RESOLVED DUPLICATE of bug 76219
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:doc, filter:emf, haveBacktrace
Depends on:
Blocks: EMF-WMF DOC
  Show dependency treegraph
 
Reported: 2012-09-21 12:43 UTC by Stefan
Modified: 2017-01-26 16:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Word-Document which hangs Writer when opening (216.00 KB, application/msword)
2012-09-21 12:43 UTC, Stefan
Details
some bts at random (3.45 KB, application/zip)
2012-09-22 07:34 UTC, Julien Nabet
Details
simplified document (816.50 KB, application/msword)
2015-09-15 15:35 UTC, Xisco Faulí
Details
backtrace master 5.3 from Windbg.txt (17.02 KB, text/plain)
2016-10-21 16:35 UTC, Timur
Details
Simplified document DOCX (96.89 KB, application/wps-office.docx)
2016-12-05 09:59 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan 2012-09-21 12:43:08 UTC
Created attachment 67499 [details]
Word-Document which hangs Writer when opening

Hello,

please try to open the attched word-document. Writer hangs with 100% CPU.
Comment 1 Julien Nabet 2012-09-22 07:34:06 UTC
Created attachment 67536 [details]
some bts at random

On pc Debian x86-64 with master sources updated today, I reproduced the problem.

I attached some bts at random.

I noticed these logs too:
warn:legacy.tools:11753:1:/home/julien/compile-libreoffice/libo/svx/source/svdraw/svdoole2.cxx:1297: The destination model must have a persistence! Please submit an issue!
warn:legacy.tools:11753:1:/home/julien/compile-libreoffice/libo/svx/source/svdraw/svdoole2.cxx:1298: The source and the destination models should have different persistences! Problems are possible!
Comment 2 Julien Nabet 2012-09-22 07:34:59 UTC
Michael: one for you?
Comment 3 QA Administrators 2015-04-19 03:19:48 UTC Comment hidden (obsolete)
Comment 4 braeunig 2015-04-29 14:06:19 UTC
Problem still exists in LibreOffice 4.4.2.2, tested with Windows 7 x64.
Comment 5 Julien Nabet 2015-05-02 09:48:40 UTC
On pc Debian x86-64 with master sources updated today, I can still reproduce this too.

Also, still the same console logs:
warn:legacy.tools:6534:1:svx/source/svdraw/svdoole2.cxx:1413: The destination model must have a persistence! Please submit an issue!
warn:legacy.tools:6534:1:svx/source/svdraw/svdoole2.cxx:1414: The source and the destination models should have different persistences! Problems are possible!
Comment 6 Xisco Faulí 2015-09-15 15:35:35 UTC
Created attachment 118750 [details]
simplified document

This issue is still present in

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: es-ES (es_ES)

on Windows 7 (64-bit)

When I open it with Word 2010, an alert prompts saying: "the dimensions after cropping are too small or too large"
Comment 7 Robinson Tryon (qubit) 2015-12-10 02:02:46 UTC Comment hidden (obsolete)
Comment 8 David W. Smith 2016-09-20 08:21:35 UTC Comment hidden (off-topic)
Comment 9 Timur 2016-10-21 16:16:13 UTC
*** Bug 102929 has been marked as a duplicate of this bug. ***
Comment 10 Timur 2016-10-21 16:35:32 UTC
Created attachment 128131 [details]
backtrace master 5.3 from Windbg.txt

Attached is backtrace with master 5.3 from Windbg. Backtrace with Xisco's simplified doc is different.
I don't have that SAXParseException error message.
Comment 11 Michael Stahl (CIB) 2016-10-24 15:11:57 UTC
from the backtrace in comment #10 it's obvious this is some kind of layout loop.
Comment 12 Michael Stahl (CIB) 2016-10-24 15:15:24 UTC
comment #8 is a completely different bug, marking as off-topic
Comment 13 Telesto 2016-12-05 09:59:02 UTC
Created attachment 129312 [details]
Simplified document DOCX

The problem seems to be caused by embedded emf/wmf files.
Comment 14 Telesto 2016-12-05 10:02:26 UTC
Bug is also present in:
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 15 Xisco Faulí 2017-01-26 16:16:34 UTC
It opens if 347bb1634b10eba577742fe8a7edb4b2dd69265d is reverted. Closing as
RESOLVED DUPLICATED of bug 76219

*** This bug has been marked as a duplicate of bug 76219 ***