Bug 65881 - FILEOPEN: Writer freezes when trying to open a DOC with frame in header
Summary: FILEOPEN: Writer freezes when trying to open a DOC with frame in header
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, haveBacktrace
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2013-06-18 08:29 UTC by cyrille.derory
Modified: 2021-06-10 11:15 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
DOC file working with word but blocking LibreOffice Writer (91.50 KB, application/msword)
2013-06-18 08:29 UTC, cyrille.derory
Details
3 bts at random (2.04 KB, application/bzip2)
2013-06-18 20:50 UTC, Julien Nabet
Details
procdump+debug (14.22 KB, text/plain)
2016-02-26 09:45 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cyrille.derory 2013-06-18 08:29:57 UTC
Created attachment 80988 [details]
DOC file working with word but blocking LibreOffice Writer

When opening this DOC file (see attachement) LibreOffice 4.1.0.0 beta 2 is blocking.
Same with previous stable versions 4.0.1 to 4.0.3, 3.6.x, 3.5.x.
I've tested LibreOffice on windows and Linux 32 bits.
Comment 1 Emir Sarı 2013-06-18 08:46:18 UTC
Reproducible with 4.2.0 master, on OS X 10.7.5. 

OpenOffice also hangs while opening the file.
Comment 2 Julien Nabet 2013-06-18 20:36:59 UTC
Comment on attachment 80988 [details]
DOC file working with word but blocking LibreOffice Writer

Mimetype fixed
Comment 3 Julien Nabet 2013-06-18 20:50:00 UTC
Created attachment 81039 [details]
3 bts at random

On pc Debian x86-64 with master sources updated today, I reproduced the problem.

I attached 3 bts at random.
Comment 4 Julien Nabet 2013-06-18 20:53:08 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2015-03-16 23:05:45 UTC Comment hidden (obsolete)
Comment 6 Jean-Baptiste Faure 2015-03-28 16:25:07 UTC
Still reproducible with the master built at home:
Version: 4.5.0.0.alpha0+
Build ID: c79bdd062f657d1be98aa815d9b882d144f35e04
Ubuntu_14.10_x86-64
Locale: fr_FR

Best regards. JBF
Comment 7 Timur 2016-02-26 09:45:18 UTC
Created attachment 123005 [details]
procdump+debug
Comment 8 Julien Nabet 2016-02-26 09:52:07 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2017-01-26 17:02:35 UTC
It opens if 347bb1634b10eba577742fe8a7edb4b2dd69265d is reverted. Closing as
RESOLVED DUPLICATED of bug 76219

*** This bug has been marked as a duplicate of bug 76219 ***
Comment 10 Timur 2020-10-08 08:37:23 UTC
This is a tricky DOC. Still freezes LO 7.1+. But we already have bug 61967 and bug 76219. 

It's 1 page DOC in MSO but becomes 3 page in MSO if resaved as DOCX. That indicates a problem and really it opens as pages counting in LO. So not valid example. 

If DOCX is edited in MSO, to delete content or fit to 1 page again, it opens more or less correctly in LO. So, DOCX from this bug has no value. 
What's interesting is that header is fine (so text side on left side).
Comment 11 Timur 2021-06-09 14:07:18 UTC
repro 7.2+.
Comment 12 Xisco Faulí 2021-06-10 10:41:24 UTC
(In reply to Timur from comment #10)
> This is a tricky DOC. Still freezes LO 7.1+. But we already have bug 61967
> and bug 76219. 
> 
> It's 1 page DOC in MSO but becomes 3 page in MSO if resaved as DOCX. That
> indicates a problem and really it opens as pages counting in LO. So not
> valid example. 
> 
> If DOCX is edited in MSO, to delete content or fit to 1 page again, it opens
> more or less correctly in LO. So, DOCX from this bug has no value. 
> What's interesting is that header is fine (so text side on left side).

Tricky doc, inherit from OOo, no duplicates, high/major importance doesn't make sense
Comment 13 Timur 2021-06-10 11:15:04 UTC
Many bugs where LO crashes/stops responding are Major and I find it correct. 
If Inherited from OO it can be Medium, though, while regression should be High.