Bug 42603 - Writer goes on infinite loop until exhausting system memory or killed when opening/importing the attached document.
Summary: Writer goes on infinite loop until exhausting system memory or killed when op...
Status: RESOLVED DUPLICATE of bug 76219
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Layout-Loops, Writer-Loops
  Show dependency treegraph
 
Reported: 2011-11-04 13:36 UTC by Erik
Modified: 2017-01-26 16:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
1 page. Microsoft Word 97-2003 Document. 215,040 bytes (210.00 KB, application/msword)
2011-11-04 13:36 UTC, Erik
Details
backtrace (34.33 KB, text/x-log)
2013-02-17 16:53 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik 2011-11-04 13:36:32 UTC
Created attachment 53155 [details]
1 page. Microsoft Word 97-2003 Document. 215,040 bytes

Both LibreOffice Writer 3.4.3 and 3.4.4 OOO340m1 (Build:402) on Windows and Linux can't open the attached "badfile.doc". Writer starts taking 100% of one cpu and starts growing in memory allocation.

After a few hours it keeps trying to open it and reserving more and more memory.

This single page document opens with no issues with MS Word Viewer on Windows.
Comment 1 tester8 2012-01-05 15:16:58 UTC
Reproduced with

LOdev 3.5.0beta2 
4ca392c-760cc4d-f39cf3d-1b2857e-60db978
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI
Comment 2 cristi falcas 2012-02-09 04:23:33 UTC
The same in Windows 3.5 beta3
Comment 3 Jorendc 2013-02-17 16:53:01 UTC
Created attachment 74992 [details]
backtrace

Opening this file using LibreOffice Version 4.1.0.0.alpha0+ (Build ID: c16e9f4ed97f65357e9986f46ad88ee9f223799) with Linux Mint 14 x64 result in CPU 100%. I added a backtrace; after 2 minutes I killed soffice.bin.
Comment 4 Julien Nabet 2014-04-27 14:57:49 UTC
On pc Debian x86-64 with master sources updated today, I can still reproduce the problem. I noticed these console logs:
warn:legacy.tools:30503:1:svx/source/svdraw/svdoole2.cxx:1387: The destination model must have a persistence! Please submit an issue!
warn:legacy.tools:30503:1:svx/source/svdraw/svdoole2.cxx:1388: The source and the destination models should have different persistences! Problems are possible!
warn:legacy.osl:30503:1:sw/source/core/attr/format.cxx:561: Do no longer use SvxBrushItem, instead use [XATTR_FILL_FIRST .. XATTR_FILL_LAST] FillAttributes (simple fallback is in place and used)
warn:legacy.osl:30503:1:sw/source/core/attr/format.cxx:455: Do no longer use SvxBrushItem, instead use [XATTR_FILL_FIRST .. XATTR_FILL_LAST] FillAttributes (simple fallback is in place and used)
warn:legacy.osl:30503:1:sw/source/core/attr/format.cxx:561: Do no longer use SvxBrushItem, instead use [XATTR_FILL_FIRST .. XATTR_FILL_LAST] FillAttributes (simple fallback is in place and used)
warn:legacy.osl:30503:1:sw/source/core/attr/format.cxx:561: Do no longer use SvxBrushItem, instead use [XATTR_FILL_FIRST .. XATTR_FILL_LAST] FillAttributes (simple fallback is in place and used)
Comment 5 Joel Madero 2015-05-12 18:10:27 UTC
This is inherited from OOo - updating version to reflect this.

Bug still present in:
Version: 5.0.0.0.alpha1+
Build ID: 7d890d0482abb8e051144d8177917c21844638c3
Locale: en-US (en_US.UTF-8)
Comment 6 Xisco Faulí 2017-01-26 16:01:41 UTC
It opens if 347bb1634b10eba577742fe8a7edb4b2dd69265d is reverted. Closing as
RESOLVED DUPLICATED of bug 76219

*** This bug has been marked as a duplicate of bug 76219 ***