Download it now!
Bug 61967 - FILEOPEN: Freeze when trying to open DOC with complex header&footer
Summary: FILEOPEN: Freeze when trying to open DOC with complex header&footer
Status: RESOLVED DUPLICATE of bug 76219
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA Confirmed:4.1.3.2:OSX10.9 Confirm...
Keywords: filter:doc, haveBacktrace, perf, preBibisect, regression
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2013-03-07 15:07 UTC by Mike Silbermann
Modified: 2018-12-27 17:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
12 page full original document (306.00 KB, application/msword)
2013-03-07 15:07 UTC, Mike Silbermann
Details
procdump+debug (40.42 KB, text/plain)
2015-08-17 12:04 UTC, Timur
Details
1 page test case (139.00 KB, application/vnd.ms-word)
2015-08-17 12:42 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Silbermann 2013-03-07 15:07:43 UTC
Created attachment 76121 [details]
12 page full original document

Problem description: 

Steps to reproduce:
1. double click on file
2. Program hangs
3. ....

Current behavior:

Expected behavior:

              
Operating System: Windows 8
Version: 4.0.1.2 release
Comment 1 Jacques Guilleron 2013-03-07 15:25:01 UTC
Confirmed with both 
LO 4.0.2.0+ (Build ID: (01f8d0a1dffce854a66c0f957e81e6df6d361a8)
and LO 4.0.1.1. 
OS: Windows 7 Home premium

Regards.

Jacques Guilleron
Comment 2 retired 2013-12-16 10:10:13 UTC
Crashes on OS X as well. Adding OS ALL and whiteboard status.
Comment 3 QA Administrators 2015-04-19 03:22:15 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-06-18 13:31:33 UTC
Still hanging.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 437210d58f32177ef1829d704f7f4d2f1bbfbfdd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-18_07:21:56
Locale: fi-FI (fi_FI)
Comment 5 Timur 2015-06-18 18:02:31 UTC
(In reply to Mike Silbermann from comment #0)
> Created attachment 76121 [details]
> This dokument hangs in "LO 3.3".... "OO 3.3" works correct
So regression.
Comment 6 Timur 2015-08-17 12:04:13 UTC
Created attachment 117967 [details]
procdump+debug

I hope that's correct backtrace:

STACK_COMMAND:  ~0s; .ecxr ; kb
SYMBOL_NAME:  swlo!com_sun_star_comp_Writer_LayoutDump_get_implementation+1569
IMAGE_NAME:  swlo.dll
BUCKET_ID:  APPLICATION_FAULT_STATUS_BREAKPOINT_swlo!com_sun_star_comp_Writer_LayoutDump_get_implementation+1569
ANALYSIS_SOURCE:  UM
FAILURE_ID_HASH_STRING:  um:status_breakpoint_80000003_swlo.dll!com_sun_star_comp_writer_layoutdump_get_implementation

SYMBOL_NAME:  swlo!CharFormat::GetItemSet+1934
IMAGE_NAME:  swlo.dll
BUCKET_ID:  APPLICATION_FAULT_STATUS_BREAKPOINT_swlo!CharFormat::GetItemSet+1934
ANALYSIS_SOURCE:  UM
FAILURE_ID_HASH_STRING:  um:status_breakpoint_80000003_swlo.dll!charformat::getitemset
Comment 7 Timur 2015-08-17 12:42:08 UTC
Created attachment 117968 [details]
1 page test case

Opens fine when right side text box is decreased out of header. 
Somehow opens also when header image is removed or main text deleted.
Comment 8 Jean-Baptiste Faure 2016-04-10 08:02:54 UTC
Both test files do not open with LO 5.1.3.0.0+ and the master.

Best regards. JBF
Comment 9 Xisco Faulí 2016-09-20 12:22:15 UTC
Adding keyword 'preBibisect' as the oldest bibisect build already freezes.
Comment 10 Xisco Faulí 2016-09-20 12:30:17 UTC
Adding keyword 'perf'.
Comment 11 Xisco Faulí 2017-01-26 16:57:43 UTC
It opens if 347bb1634b10eba577742fe8a7edb4b2dd69265d is reverted. Closing as
RESOLVED DUPLICATED of bug 76219

*** This bug has been marked as a duplicate of bug 76219 ***