Download it now!
Bug 60501 - FILEOPEN: LibreOffice hangs with 100% CPU with specific .doc file
Summary: FILEOPEN: LibreOffice hangs with 100% CPU with specific .doc file
Status: RESOLVED DUPLICATE of bug 76219
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, perf
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2013-02-08 15:43 UTC by t.schaaf
Modified: 2017-01-26 18:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
stripped to minimum (26.00 KB, application/msword)
2013-02-08 15:43 UTC, t.schaaf
Details
3 bts at random (6.63 KB, application/bzip2)
2013-02-08 18:08 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description t.schaaf 2013-02-08 15:43:08 UTC
Created attachment 74437 [details]
stripped to minimum

We're using Alfresco Community Edition which is using LibreOffice (in earlier versions OpenOffice) to render previews of documents.

When hitting certain files the open office process goes up to 100% CPU usage and slowly eats up all the RAM until it crashes (after RAM and swap is depleted).

I checked in a destop environment under Debain, Ubuntu and Windows 7 in diffrent versions and everywhere it's the same issue. We have that issue for quite some time and i recently found a document that was causing that issue.

I stripped away every text, picture and everything i could, to have a basic "container" that is actually causing the problem.

It got down to 2 texts and a countainer.

If you remove any of these items the file works. So that's the minimum i could get out to "cause" the issue.

I saw some other reports with the same issue, maybe this minimal file can contribute to solve the problem.
Comment 1 Julien Nabet 2013-02-08 17:58:22 UTC
Comment on attachment 74437 [details]
stripped to minimum

mimetype fixed
Comment 2 Julien Nabet 2013-02-08 18:05:16 UTC
On pc Debian x86-64 with master sources updated today, I reproduce the hang.

I'm not sure I understood what you meant. Is it a doc file from Winword? If yes which version? Or is it a doc file generated by LO embedded in Alfresco? If yes which LO version?
Comment 3 Julien Nabet 2013-02-08 18:08:07 UTC
Created attachment 74446 [details]
3 bts at random

3 bts at random
Comment 4 Julien Nabet 2013-02-08 18:09:25 UTC
We need feedback to consider this as a blocker (see my comment 2).
Comment 5 t.schaaf 2013-02-08 21:04:05 UTC
The document was created in MS Office (2007 or 2010, not sure) i edited it in latest MS Office 2010 to strip everything that was not causing the issue (some texts and pictures).

The problem just occurred while the file was uploaded in Alfresco, since Alfresco uses LibreOffice to render the preview of a document.

When Alfresco was trying to do that, the CPU went to 100% and stayed that way.
Since we're using Alfresco in a company environment we had to globaly deactivate the preview of documents to not kill the server.

Anyway, i'm not sure if that's the only document that is causing the issue, cause we have several thousands of documents in Alfresco. This was just one of the files that i found that was causing that issue and was easy to reproduce under every LibreOffice version so far (same goes for OpenOffice).
Comment 6 Julien Nabet 2013-02-08 21:16:24 UTC
t.schaaf: thank you for your feedback

Cédric/Michael: hanging on a simple doc file. Some bts at random have been attached. One for you?
Comment 7 Cédric Bosdonnat 2014-01-20 08:57:18 UTC
Restricted my LibreOffice hacking area
Comment 8 caralu1974 2014-11-25 21:01:37 UTC
I`ve editing on writer (Versión: 4.3.4.1 Id. de compilación: 430m0(Build:1))a .odt file of 273 pages and lots of tables, when I edit the file LO freezes and quit responding (Using 100% of one CPU) so I must kill it every time. Next I should recover it and lost some of the job.
Comment 9 Xisco Faulí 2015-09-14 16:41:18 UTC
This issue is still present in

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 10 Robinson Tryon (qubit) 2015-12-09 18:07:55 UTC Comment hidden (obsolete)
Comment 11 Telesto 2016-12-21 19:42:40 UTC
This issue is still present in:
Version: 5.4.0.0.alpha0+
Build ID: 9cfb2f2f03b5ec086487fd483298466db0b09010
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-20_23:58:02
Locale: nl-NL (nl_NL); Calc: CL
Comment 12 Xisco Faulí 2017-01-26 18:20:25 UTC
It opens if 347bb1634b10eba577742fe8a7edb4b2dd69265d is reverted. Closing as
RESOLVED DUPLICATED of bug 76219

*** This bug has been marked as a duplicate of bug 76219 ***