Bug 57980 - FILEOPEN: particular WW8 doc loops in layout on import
Summary: FILEOPEN: particular WW8 doc loops in layout on import
Status: RESOLVED DUPLICATE of bug 76219
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL: https://bugs.freedesktop.org/attachme...
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: Layout-Loops, Writer-Loops DOC
  Show dependency treegraph
 
Reported: 2012-12-07 13:06 UTC by Michael Stahl (CIB)
Modified: 2017-01-26 15:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
crash report (91.92 KB, text/plain)
2012-12-08 02:53 UTC, clkao
Details
3 bts at random on master with symbols (2.52 KB, application/bzip2)
2012-12-15 00:29 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stahl (CIB) 2012-12-07 13:06:30 UTC
the 3rd attachment on bug 57780
causes a layout loop in Writer on import.
https://bugs.freedesktop.org/attachment.cgi?id=71123

loop happens in LO master, libreoffice-3-6, 3.5.7, 3.4.6,
as well as OOo 3.3, 3.2.1, 3.0.1, so it's a long standing problem.
Comment 1 clkao 2012-12-08 02:53:25 UTC
FTR, the source of the doc is          http://lci.ly.gov.tw/LyLCEW/communique/work/93/42/LCIDC01_934201_00002.doc

this hangs when opening manually, but crashes with unoconv invoked to convert to html.
Comment 2 clkao 2012-12-08 02:53:53 UTC
Created attachment 71170 [details]
crash report
Comment 3 clkao 2012-12-08 02:57:58 UTC
Here's another with similar crashes with massive SWTxtFrm::HideAndShowObjects: http://lci.ly.gov.tw/LyLCEW/communique/work/92/24/LCIDC01_922401_00004.doc


0   libswlo.dylib                 	0x1d4fb62e SwTxtFrm::IsHiddenNow() const + 14
1   libswlo.dylib                 	0x1d4fbc1e SwTxtFrm::HideAndShowObjects() + 30
2   libswlo.dylib                 	0x1d4fbe78 SwTxtFrm::HideAndShowObjects() + 632
3   libswlo.dylib                 	0x1d4fbe78 SwTxtFrm::HideAndShowObjects() + 632
4   libswlo.dylib                 	0x1d4fbe78 SwTxtFrm::HideAndShowObjects() + 632
5   libswlo.dylib                 	0x1d4fbe78 SwTxtFrm::HideAndShowObjects() + 632
Comment 4 clkao 2012-12-08 03:00:36 UTC
I was trying to attach the second testcase but it's more than 3M.  so please use the url to access it.
Comment 5 Julien Nabet 2012-12-15 00:29:18 UTC
Created attachment 71529 [details]
3 bts at random on master with symbols

On pc Debian x86-64 with master sources updated today, I reproduced the hang.
I attached 3 bts at random, hope it may help.
Comment 6 Julien Nabet 2012-12-15 00:30:07 UTC
Comment on attachment 71529 [details]
3 bts at random on master with symbols

Fix mimetype
Comment 7 QA Administrators 2015-01-05 17:52:22 UTC Comment hidden (obsolete)
Comment 8 clkao 2015-01-05 19:11:45 UTC
This issue persists in 4.3.5 on macosx 10.10.1
Comment 9 QA Administrators 2016-01-17 20:05:00 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2016-08-11 15:50:43 UTC
This issue is still present in

Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: es-ES (es_ES)

Change version to Inherited from OOo as it was already present in Openoffice according to comment 1.
Comment 11 Xisco Faulí 2017-01-26 15:58:21 UTC
It opens if 347bb1634b10eba577742fe8a7edb4b2dd69265d is reverted. Closing as RESOLVED DUPLICATED of bug 76219

*** This bug has been marked as a duplicate of bug 76219 ***