Bug Hunting Session
Bug 102944 - Incorrect text rendering of document with OpenGL enabled
Summary: Incorrect text rendering of document with OpenGL enabled
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords: bibisected, bisected, regression
Depends on: HarfBuzz
Blocks: Font-Rendering VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-10-04 01:18 UTC by Aron Budea
Modified: 2016-11-22 14:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with OpenGL enabled (82.53 KB, image/png)
2016-10-04 01:18 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-10-04 01:18:57 UTC
Created attachment 127795 [details]
Screenshot with OpenGL enabled

1. Have OpenGL enabled.
2. Start Writer.
3. Open this attachment from bug 101962: https://bugs.documentfoundation.org/attachment.cgi?id=127193

See attachment in next comment how terrible the second line looks. Looks fine with default rendering.
Reproduced with 5.1.3.2, 5.2.0.1, 5.3 master build / Windows 7. It looks much worse in 5.1.2.2 intermittently, then slightly better since 5.1.3.2. Confirmation in Linux needed.
Works in 5.1.0.3. => regression
Comment 1 Aron Budea 2016-10-04 01:36:27 UTC
There's no "next comment" with attachment, it was attached together with the description.
Comment 2 V Stuart Foote 2016-10-04 04:06:17 UTC
Interestingly if one edits the default paragraph style changing the font selection from Liberation Serif to different fonts, for example a Graphite font (Linux Libertine Display G) or to to some other MS fonts (Calibri, Cambria) the text renders correctly. 

But changing to other MS fonts show the layout glitches (Arial, Tahoma, Times New Roman) that Liberation Serif shows on layout.

This one is weird.

=-=
On Windows 10 Pro 64-bit (1607) en-US with
Version: 5.2.2.2 (x64)
Build ID: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US); Calc: group
Comment 3 V Stuart Foote 2016-10-04 04:07:25 UTC
Also present in recent master:
Version: 5.3.0.0.alpha0+
Build ID: 89a3f825559753d6600807342ca96c169cd58c87
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-29_23:19:33
Locale: en-US (en_US); Calc: group
Comment 4 raal 2016-10-04 21:48:42 UTC
This seems to have begun at the below commit.
Adding Cc: to Tor Lillqvist; Could you possibly take a look at this one? Thanks

author	Tor Lillqvist <tml@collabora.com>	2016-01-07 13:05:58 (GMT)
committer	Tor Lillqvist <tml@collabora.com>	2016-01-21 10:04:04 (GMT)
commit	4622689fad7ddff72cd08da9611ccfacdb0aa7bd (patch)
tree	69799d69d624d09e4809f05f13b04466f7f3be2a
parent	88b458d55dc1f56e13bbf34aa7c6758e13707fa1 (diff)
tdf#96420: Re-introduce SimpleWinLayout
	
 git bisect log
# bad: [6380ca07b05f68dedcaa379302cfe1fa478571c4] source sha:60b74fe1775e647545d2da1fcc58a4c63ec18aa5
# good: [1f670510f08cb800cbae2a1dd6ea70d3542e4721] source sha:49c2b9808df8a6b197dec666dfc0cda6321a4306
git bisect start 'origin/master' 'oldest'
# bad: [38f37b8ec1a2d199bb957cfd2581df7d1b273b74] source sha:c0da1080b61a1d51654fc34fdaeba373226065ff
git bisect bad 38f37b8ec1a2d199bb957cfd2581df7d1b273b74
# good: [6998931a34ad75eb555f882fbed223e585548721] source sha:1fbd073828ef52f5206aed4643226bae9fb85f4f
git bisect good 6998931a34ad75eb555f882fbed223e585548721
# bad: [b283fbadb387862ea0f09058430317906e1a78b5] source sha:1fc4cb57755cdfb9ab65c112435997874fb057cd
git bisect bad b283fbadb387862ea0f09058430317906e1a78b5
# bad: [46053f8f06492a2c806ebd473883548d4a1115d8] source sha:3de2c3952b9757c40615194811142fd19a9b72eb
git bisect bad 46053f8f06492a2c806ebd473883548d4a1115d8
# good: [a00d80e7a5378b9fcb8b2dd9ebfc2d96b73e9c6d] source sha:af6a39120f590a49088d58c14d46f206abe3e4c2
git bisect good a00d80e7a5378b9fcb8b2dd9ebfc2d96b73e9c6d
# good: [2e9e7cd95591bbf20af052c1c08f7e06a6738348] source sha:a5372932f787534d15d4e36ee8c297f3c6ac0888
git bisect good 2e9e7cd95591bbf20af052c1c08f7e06a6738348
# bad: [ce53878878fff0293bb08e9267f30f091b4e57f2] source sha:05b44143d2300d025d6112b8986ac6965ef844c0
git bisect bad ce53878878fff0293bb08e9267f30f091b4e57f2
# bad: [043c93f1493c99d1c0cf7625f8e4b397421d4f04] source sha:2af991dc232bbf96557dc5efe5bd2ce9b6b99f9b
git bisect bad 043c93f1493c99d1c0cf7625f8e4b397421d4f04
# bad: [a04bc4926151aca39a247feaa449974d43327f63] source sha:8608b276aee2075ce06ff33bcbac8899d427ad51
git bisect bad a04bc4926151aca39a247feaa449974d43327f63
# good: [099d8395f96cd92ef4c20bfc5d6017e153f61cc6] source sha:4d2034803646bf88b76ed8a3b897edd7209ce30a
git bisect good 099d8395f96cd92ef4c20bfc5d6017e153f61cc6
# good: [207bb1ecd01d586d8d141b06fae9968c7945ee73] source sha:2112d171224a0ae8676afa30292623461065d5b7
git bisect good 207bb1ecd01d586d8d141b06fae9968c7945ee73
# good: [e09174dcd8f1bf26f59cd6d82e91c9548c107305] source sha:88b458d55dc1f56e13bbf34aa7c6758e13707fa1
git bisect good e09174dcd8f1bf26f59cd6d82e91c9548c107305
# bad: [bf46c56d1ea254c094510b7dd92d8d3d14b7a475] source sha:4622689fad7ddff72cd08da9611ccfacdb0aa7bd
git bisect bad bf46c56d1ea254c094510b7dd92d8d3d14b7a475
# first bad commit: [bf46c56d1ea254c094510b7dd92d8d3d14b7a475] source sha:4622689fad7ddff72cd08da9611ccfacdb0aa7bd
Comment 5 Aron Budea 2016-11-22 07:16:14 UTC
Looks good with the new common layout. Closing as WFM.
Comment 6 V Stuart Foote 2016-11-22 14:08:32 UTC
It is still bad with OpenGL in 5.2 Windows builds

Version: 5.2.3.3 (x64)
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US); Calc: group

but is correct with new HarfBuzz layout with OpenGL on 5.3.0 master, and with old DirectWrite based layout the issue is still present.

Giving it a target:5.3.0 since we know the new layout engine corrects it.