Bug 99677 - Opentype ligatures and context alternatives no longer work
Summary: Opentype ligatures and context alternatives no longer work
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords: bibisected, bisected, regression
: 99812 102191 (view as bug list)
Depends on: HarfBuzz
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2016-05-04 14:06 UTC by Patrick Schönbach
Modified: 2016-12-13 08:46 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Font for test case (842.30 KB, application/x-font-otf)
2016-05-10 19:57 UTC, Patrick Schönbach
Details
Test case (8.82 KB, application/vnd.oasis.opendocument.text)
2016-05-10 19:58 UTC, Patrick Schönbach
Details
printscreen from 5.2 (40.42 KB, application/vnd.oasis.opendocument.text)
2016-05-11 16:15 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Schönbach 2016-05-04 14:06:03 UTC
Until version 5.1.1.3, the OpenType ligatures and context alternatives worked quite fine. However, in 5.1.2.2, OpenType ligatures and context alternatives do not work at all anymore.

For me, this is a major problem since I am working a lot with old German fonts that heavily rely on theses features.
Comment 1 Patrick Schönbach 2016-05-04 17:27:24 UTC
Correction: Ir stopped working in 5.1.x, it worked in 5.0.x.
Comment 2 V Stuart Foote 2016-05-04 20:37:00 UTC
What is the state of OpenGL rendering on your Please copy and paste details from the Help -> About LibreOffice dialog

If enabled, any improvement if you disable from Tools -> Options -> View "Use OpenGL for all rendering (on restart)"?

Please copy and paste details from the Help -> About LibreOffice dialog and let us know which build of Windows you are working on.
Comment 3 Patrick Schönbach 2016-05-04 21:33:57 UTC
Windows 7 SP1 x64

Version: 5.1.3.1 (x64)
Build-ID: 115e0e13d3c8ac1452186ad2394abce2dd5c2b57
CPU-Threads: 16; BS-Version: Windows 6.1; UI-Render: GL; 
Gebietsschema: de-DE (de_DE)

Turning on an off OpenGL and restarting does not change anything.
Comment 4 V Stuart Foote 2016-05-04 21:40:34 UTC
OK, thanks, one more question. Which fonts are you using that contain the ligatures?
Comment 5 Patrick Schönbach 2016-05-04 21:47:42 UTC
I am mainly using proprietary fonts emulating old-style German lettering and handwriting created by http://www.fraktur.biz/. But I guess, also other OpenType smart fonts will cause issues.
Comment 6 raal 2016-05-05 07:06:22 UTC
duplicate of bug 66916?
Comment 7 Patrick Schönbach 2016-05-05 10:30:24 UTC
(In reply to raal from comment #6)
> duplicate of bug 66916?

Not sure, as it used to work in 5.0.x, apart from a strange detail problem. But basically, it worked.
Comment 8 raal 2016-05-05 10:39:24 UTC
Cn you attach test case? If it worked in 5.0, we can bibisect it.
Comment 9 Patrick Schönbach 2016-05-05 10:44:28 UTC
The problem ia that the font I am using is proprietary, so I cannot attach it. However, maybe you can verify first, if OpenType ligatures and context alternatives work at all in 5.1.x. Somehow, ir does not look like it.
Comment 10 Buovjaga 2016-05-07 12:31:39 UTC
(In reply to Patrick Schönbach from comment #9)
> The problem ia that the font I am using is proprietary, so I cannot attach
> it. However, maybe you can verify first, if OpenType ligatures and context
> alternatives work at all in 5.1.x. Somehow, ir does not look like it.

We are very busy with testing, so would appreciate, if you checked it and created a test case with non-proprietary fonts :)
Comment 11 Patrick Schönbach 2016-05-07 12:35:06 UTC
(In reply to Buovjaga from comment #10)
> (In reply to Patrick Schönbach from comment #9)
> > The problem ia that the font I am using is proprietary, so I cannot attach
> > it. However, maybe you can verify first, if OpenType ligatures and context
> > alternatives work at all in 5.1.x. Somehow, ir does not look like it.
> 
> We are very busy with testing, so would appreciate, if you checked it and
> created a test case with non-proprietary fonts :)

Ok. Could you maybe name a suitable OpenType font I could use?
Comment 12 Buovjaga 2016-05-07 15:22:22 UTC
(In reply to Patrick Schönbach from comment #11)
> Ok. Could you maybe name a suitable OpenType font I could use?

Not off the top of my head. Needs searching.
Comment 13 Patrick Schönbach 2016-05-10 19:57:29 UTC
Created attachment 124958 [details]
Font for test case
Comment 14 Patrick Schönbach 2016-05-10 19:58:16 UTC
Created attachment 124959 [details]
Test case
Comment 15 Buovjaga 2016-05-11 16:04:25 UTC
(In reply to Patrick Schönbach from comment #14)
> Created attachment 124959 [details]
> Test case

For me, the "eer" is joined. I have to test on Windows later.

64-bit, KDE Plasma 5
Build ID: 5.1.2.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 16 Patrick Schönbach 2016-05-11 16:09:56 UTC
For me, on Windows, nothing is joined on the latest 5.1.x version on Windows.
Comment 17 raal 2016-05-11 16:15:40 UTC
Created attachment 124983 [details]
printscreen from 5.2

I can confirm with Version: 5.2.0.0.alpha1+
Build ID: e76d458422b0f0f713cc17bf47ca94c33ac570a7
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-05-03_06:32:27
Comment 18 raal 2016-05-11 17:30:47 UTC
This seems to have begun at the below commit.
Adding Cc: to Tor Lillqvist ; Could you possibly take a look at this one?
Thanks

bf46c56d1ea254c094510b7dd92d8d3d14b7a475 is the first bad commit
commit bf46c56d1ea254c094510b7dd92d8d3d14b7a475
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Jan 22 03:32:58 2016 -0800

    source sha:4622689fad7ddff72cd08da9611ccfacdb0aa7bd

author	Tor Lillqvist <tml@collabora.com>	2016-01-07 13:05:58 (GMT)
committer	Tor Lillqvist <tml@collabora.com>	2016-01-21 10:04:04 (GMT)
commit	4622689fad7ddff72cd08da9611ccfacdb0aa7bd (patch)
tree	69799d69d624d09e4809f05f13b04466f7f3be2a
parent	88b458d55dc1f56e13bbf34aa7c6758e13707fa1 (diff)
tdf#96420: Re-introduce SimpleWinLayout
Comment 19 Volga 2016-07-05 08:55:44 UTC
I can also reproduce this bug on Windows 10

Version: 5.1.4.2 (x64)
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: zh-CN (zh_CN)

After I installed FreeSerif font, input many “f”, no ligature appeared.
Comment 20 Xisco Faulí 2016-10-05 08:25:04 UTC
*** Bug 99812 has been marked as a duplicate of this bug. ***
Comment 21 Buovjaga 2016-10-07 18:25:57 UTC
*** Bug 102191 has been marked as a duplicate of this bug. ***
Comment 22 Volga 2016-11-04 03:30:42 UTC
I think this should fixed in Version: 5.3.0.0.alpha1+
Comment 23 tommy27 2016-12-13 07:54:38 UTC
@Volga
did you effectively test this in 5.3.x?
Comment 24 tommy27 2016-12-13 08:46:02 UTC
@Khaled
thanks for confirming this has been FIXED