Bug Hunting Session
Bug 103083 - EDITING: Cut and Paste (at the same position) changes bullet point formatting
Summary: EDITING: Cut and Paste (at the same position) changes bullet point formatting
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Noel Grandin
URL:
Whiteboard: target:5.3.0 target:5.2.4 target:6.1.0
Keywords:
: 100948 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-10-10 08:09 UTC by Noel Grandin
Modified: 2018-01-15 21:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
reproduction document (83.07 KB, application/vnd.oasis.opendocument.presentation)
2016-10-10 08:09 UTC, Noel Grandin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Noel Grandin 2016-10-10 08:09:44 UTC
Created attachment 127910 [details]
reproduction document

issue: open the attached deck. Mark a complete bullet point line, cut it (CTRL+X) and then insert it at the same position (CTRL+V). The bullet point formatting is changing from solid bullet to dash

expected result: no changes in bullet point formatting, especially when pasting at the same position
Comment 1 Noel Grandin 2016-10-10 08:29:01 UTC
Possibly same bug as tdf#100948
Comment 2 Noel Grandin 2016-10-10 08:33:26 UTC
Tbe structure of this document is rather weird, which means it might also be some kind of import issue:

From the UI the structure looks like:

  * This is the 1st level
    * These are the 4 bullet points we are focussing on
    * They have all the same formatting

But the XML structure has each bullet point inside it's OWN list:

      <text:list text:style-name="L3">
       <text:list-item>
        <text:p>This is the 1<text:span text:style-name="T3">st</text:span> level</text:p>
       </text:list-item>
      </text:list>
      <text:list text:style-name="L4">
       <text:list-item>
        <text:list>
         <text:list-item>
          <text:p>These are the 4 bullet points we are focussing on</text:p>
         </text:list-item>
        </text:list>
       </text:list-item>
      </text:list>
      <text:list text:style-name="L5">
       <text:list-item>
        <text:list>
         <text:list-item>
          <text:p>They have all the same formatting</text:p>
         </text:list-item>
        </text:list>
       </text:list-item>
      </text:list>
Comment 3 Noel Grandin 2016-10-10 08:36:31 UTC
This structure leads to us overwriting the stylesheet on the text node with a stylesheet with the "wrong" depth here:

#5  0x00002aaadd9e9f61 in sd::View::OnEndPasteOrDrop (this=0x25f2fe0, pInfo=0x7fffffff1778) at /home/noel/libo/sd/source/ui/view/sdview.cxx:1254
#6  0x00002aaab108fb62 in SdrObjEditView::EndPasteOrDropHdl (this=0x25f2fe0, pInfo=0x7fffffff1778) at /home/noel/libo/svx/source/svdraw/svdedxv.cxx:2097
#7  0x00002aaab108a558 in SdrObjEditView::LinkStubEndPasteOrDropHdl (instance=0x25f2fe0, data=0x7fffffff1778) at /home/noel/libo/svx/source/svdraw/svdedxv.cxx:2095
#8  0x00002aaaae755938 in Link<PasteOrDropInfos*, void>::Call (this=0x2b83388, data=0x7fffffff1778) at /home/noel/libo/include/tools/link.hxx:84
#9  0x00002aaaae752565 in Outliner::EndPasteOrDropHdl (this=0x2b83250, rInfos=...) at /home/noel/libo/editeng/source/outliner/outliner.cxx:1777
#10 0x00002aaaae750d08 in Outliner::LinkStubEndPasteOrDropHdl (instance=0x2b83250, data=...) at /home/noel/libo/editeng/source/outliner/outliner.cxx:1773
#11 0x00002aaaae55ed28 in Link<PasteOrDropInfos&, void>::Call (this=0x6241f60, data=...) at /home/noel/libo/include/tools/link.hxx:84
#12 0x00002aaaae553513 in EditEngine::HandleEndPasteOrDrop (this=0x2bb0db0, rInfos=...) at /home/noel/libo/editeng/source/editeng/editeng.cxx:927
#13 0x00002aaaae5ccf83 in ImpEditView::Paste (this=0x23c6640, rxClipboard=uno::Reference to (VclGtkClipboard *) 0x25b0260, bUseSpecial=true)
    at /home/noel/libo/editeng/source/editeng/impedit.cxx:1526
Comment 4 Commit Notification 2016-10-19 06:24:56 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7e4887679924df28da2083735e0367ecccb8180b

tdf#103083 - EDITING: Cut and Paste changes bullet point formatting

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Noel Grandin 2016-10-19 08:23:16 UTC
*** Bug 100948 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2016-10-25 07:42:08 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c6b34fd6db956a7b3e695c412131715f32a6e2a9&h=libreoffice-5-2

tdf#103083 - EDITING: Cut and Paste changes bullet point formatting

It will be available in 5.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-01-15 21:32:42 UTC
Mert Tümer committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2733ca6c0aed6468c26fd7a80b0b50e32fd608c4

tdf#103083 option to show/hide hidden files/folders on Android

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.