Bug 103093 - "Insert as Link" should be renamed to "Reference externally (non-embedded)"
Summary: "Insert as Link" should be renamed to "Reference externally (non-embedded)"
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Dialog
  Show dependency treegraph
 
Reported: 2016-10-10 15:40 UTC by Björn Michaelsen
Modified: 2017-03-23 20:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2016-10-10 15:40:37 UTC
Description:
The "insert" in "Insert as Link" suggests to the naive that the content is actually embedded, rather then merely referenced. "Reference externally" should make the concept more explicit as in natural language we refer to this concept as "reference", not as "link".

Steps to Reproduce:
1. Open Writer
2. Insert -> Image


Actual Results:  
See a checkbox "Insert as link"

Expected Results:
See a checkbox "Reference externally (non-embedded)"


Reproducible: Always

User Profile Reset: 

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Yousuf Philips (jay) (retired) 2016-10-11 01:31:42 UTC
Maybe "Reference external file (non-embedded)" and then we can have Edit > External References.

@Adolfo, @Stuart, @Heiko: What you guys think?
Comment 2 Heiko Tietze 2016-10-11 07:55:54 UTC
Guess most users are aware of what "Insert as Link" (only "[ ] Link" here) means and will rather be confused from this change because "reference" reminds to the bibliography. And there is a big warning dialog afterwards...

The question came up with the change of hyperlink to link, which now makes the other 'links' weird. Taking this as the reason of the suggested change we should try to stay as close to the current term as possible. So how about "Insert as reference"?

By the way, the image dialog contains a section for the _link_ where the filename is stored. This label needs to get changed accordingly. It's also possible to insert media as link (no idea how to access the properties for media except per toolbar). Objects (OLE: further) can be inserted as _symbol_, the properties dialog contains a _link_ tab.

We should also talk about the bigger picture:
* "Link" are all hyperlinks to external content
* "Cross-reference" is a link to an object within the document
* "Reference" should be the term used for non-embedded local objects

However, the "Hyperlink..." function starts a dialog that allows to insert an URL, a mail address, or (local) documents. And Edit > Reference contains footnote/endnote, indexes, and bibliography stuff.
Comment 3 Björn Michaelsen 2016-10-11 09:28:43 UTC
(In reply to Heiko Tietze from comment #2)
 
> However, the "Hyperlink..." function starts a dialog that allows to insert
> an URL, a mail address, or (local) documents.

A mailto link or a file link are URLs too:
https://en.wikipedia.org/wiki/File_URI_scheme
https://en.wikipedia.org/wiki/Mailto

Possibly using "Insert URL" instead of either "hyperlink" or "link" would be less ambiguous, more specific. But it is also a more technical term.
Comment 4 Yousuf Philips (jay) (retired) 2016-10-12 00:25:10 UTC
(In reply to Heiko Tietze from comment #2)
> Guess most users are aware of what "Insert as Link" (only "[ ] Link" here)
> means and will rather be confused from this change because "reference"
> reminds to the bibliography. And there is a big warning dialog afterwards...

I would presume most non-advanced/non-technical users, ex. Benjamin or my father, dont understand what it means because they always want images/etc embedded into their documents. Also users of services like Google Docs dont have this option as well, which means we have a generation of users who never saw such an option. 

So it seems it says '[ ] Link' in LO's internal file dialogs and on Windows and '[ ] Insert as Link' in the GTK dialog. :D 

> The question came up with the change of hyperlink to link, which now makes
> the other 'links' weird. Taking this as the reason of the suggested change
> we should try to stay as close to the current term as possible. So how about
> "Insert as reference"?

Reference by itself will definitely be misunderstood as we have book references in bibliography and cross-reference fields.

> However, the "Hyperlink..." function starts a dialog that allows to insert
> an URL, a mail address, or (local) documents. And Edit > Reference contains
> footnote/endnote, indexes, and bibliography stuff.

Which is why i suggested Edit > External References, but it could also be External File Reference to make it as clear as possible.

(In reply to Björn Michaelsen from comment #3)
> Possibly using "Insert URL" instead of either "hyperlink" or "link" would be
> less ambiguous, more specific. But it is also a more technical term.

Yes URL is to technical for users. :D
Comment 5 Luke 2016-10-31 20:56:49 UTC
If we're going to change hyperlink to link. We need to either qualify every link as internal link or URL link. If you don't like 'insert URL', then we should keep 'insert hyperlink'.
Comment 6 Björn Michaelsen 2016-10-31 21:34:19 UTC
(In reply to Luke from comment #5)
> If we're going to change hyperlink to link. We need to either qualify every
> link as internal link or URL link. If you don't like 'insert URL', then we
> should keep 'insert hyperlink'.

Well, other use (its only one -- so no need for using a plural here AFAICS) of the word 'link' in LibreOffice is actually misleading:

"Linked text frames" are not really describing well what this feature does (it describes more what the internal implementation looks like, which should not bother users): Instead they should be named according to their function e.g. as "Continuous flow text frame" or some such.

(In reply to Heiko Tietze from comment #2)
> Guess most users are aware of what "Insert as Link" (only "[ ] Link" here)
> means

Citation needed ;)
From my observation of users, the whole concept of having a parts of the document not stored in the is _not_ at all obvious to many users of the product. Emphasising the EXTERNAL of this action as early as possible might help here.

> will rather be confused from this change because "reference"
> reminds to the bibliography.

In "Reference externally" the first word is a verb, not a noun. A native speaker will not be very likely to confuse this with the latter. In german "Extern referenzieren" doesnt suggest a strong relation to the bibliography either.

> The question came up with the change of hyperlink to link, which now makes
> the other 'links' weird.

As said above, the other use of 'link' (its only one: the continuous flow text frames) in the product are unfortunate in themselves.
Comment 7 Luke 2016-11-02 17:27:25 UTC
I checked and the 2 major desktop publishing packages, QuarkXPress[1] and PageMaker[2], use 'link' for continuous text between textboxes and hyperlink for URLs. Trying to invent our own terminology when there already is a well-defined standard seems like we're making things more confusing for our users.


[1] https://quark.parature.com/link/portal/30026/30029/Article/1423/How-to-Link-Text-Boxes-to-Form-a-Single-Text-Chain

[2] https://www.uncp.edu/sites/default/files/Images_Docs/Departments/DoIT/Computer_Training/pagemaker_6_5plus.pdf
Comment 8 Björn Michaelsen 2016-11-03 10:54:41 UTC
(In reply to Luke from comment #7)
> [1]
> https://quark.parature.com/link/portal/30026/30029/Article/1423/How-to-Link-
> Text-Boxes-to-Form-a-Single-Text-Chain

"Form single text chain" is a wonderful wording that doesnt require the ambiguous "link". 

 
> [2]
> https://www.uncp.edu/sites/default/files/Images_Docs/Departments/DoIT/
> Computer_Training/pagemaker_6_5plus.pdf

That is 16 years old. I dont think it is a useful reference on contemporary use of "link"/"hyperlink".
Comment 9 Adolfo Jayme 2016-11-05 23:19:59 UTC
Björn, want to know an example of an outdated word? That would be “telecaster”. Nobody calls a television broadcaster by that word anymore. That is not the case of “hyperlink”, which is just a precise term for a particular kind of links, and which is widely used nowadays. (Unconvinced? First thing I’ve found in Google: https://support.office.com/en-us/article/Create-or-edit-a-hyperlink-5d8c0804-f998-4143-86b1-1199735e07bf ).

It was a mistake to just blindly replace the word with the ambiguous “link”.
Comment 10 Björn Michaelsen 2016-11-06 01:03:41 UTC
(In reply to Adolfo Jayme from comment #9)
> Björn, want to know an example of an outdated word? 

Please do not carry this offtopic. Also please refrain from rhetorical questions.

As for link/hyperlinks see:

 https://www.google.com/trends/explore?date=all&q=link%20to%20webpage,hyperlink%20to%20webpage
 https://en.wikipedia.org/wiki/Hyperlink

for contemporary _english_ usage (other locales might differ). From the latter:

> In computing, a hyperlink, or simply a link, is a reference to data that the reader can directly follow either by clicking, tapping, or hovering.
Comment 11 Adolfo Jayme 2016-11-06 04:00:39 UTC
Your best defense is a Google Trends graph with a specially tailored combination of terms so that it goes on your favor?

Come on.

My only point here is that “Link” in the context of an office suite where it’s important to distinguish the kinds of links you’re using in each area.
Comment 12 Björn Michaelsen 2016-11-06 12:03:39 UTC
(In reply to Adolfo Jayme from comment #11)
> Your best defense [...]?

Seriously: Please try to make your point without falling back on pointless rhetorical questions. They dont help the discussion at all. Data on this is hard to come by, but when you have better sources supporting your position, please share them.

> My only point here is that “Link” in the context of an office suite where
> it’s important to distinguish the kinds of links you’re using in each area.

And my point is that we use "link" in the UI only in one instance ("Linked text frames") as something which is not a hyperlink. In that case we could use "Form a Single Text Chain" and avoid possible confusion from the start.

As such any possible confusion on "link" is self-inflicted and avoidable. And avoiding confusion of the user (by using "Form a Single Text Chain" instead) is a Good Thing(tm) with no collateral damage.
Comment 13 Heiko Tietze 2016-11-06 14:41:54 UTC
(In reply to Björn Michaelsen from comment #12)
> Data on this is hard to come by...

We could do a quick poll on G+, got ~200 replies from the LibreOffice channel with the last questions. But on the other hand the question is not easy to ask in a comprehensive way. Things like "What do you prefer for resources on the Internet? () Link () Hyperlink" do not work as the complexity is not addressed. But maybe 

"What is the best name for
                   Link   Hyperlink   URL    Reference  Chain
Resource on 
the Internet       ()     ()          ()     ()         () 
Resource within 
the document       ()     ()          ()     ()         () 
Resource at local 
file system        ()     ()          ()     ()         () 
Connected text 
blocks             ()     ()          ()     ()         ()
etc.

This matrix question cannot be asked on G+ but at the blog.
Comment 14 Björn Michaelsen 2016-11-06 19:24:38 UTC
(In reply to Heiko Tietze from comment #13)
> "What is the best name for
>                    Link   Hyperlink   URL    Reference  Chain
> Resource on 
> the Internet       ()     ()          ()     ()         () 
> Resource within 
> the document       ()     ()          ()     ()         () 
> Resource at local 
> file system        ()     ()          ()     ()         () 
> Connected text 
> blocks             ()     ()          ()     ()         ()
> etc.
> 
> This matrix question cannot be asked on G+ but at the blog.

I would start the other way around to learn about user expectations when encountering these words, e.g. with questions like:
- "When you see the LibreOffice interface refer to 'link' what do you expect it to refer to?"
- "Are you aware (without googling for them first) of a difference between the meaning of 'link' and 'hyperlink' for you when you come across them in the LibreOffice interface? If yes, what is it?"
- "Are you aware (without googling for it first) of uses of the word 'link' in the LibreOffice interface that do not refer to resources (webpages, pictures, videos etc.) on the internet or on the local computer? If so, which are those?"

Of course, the audience for these questions on G+/blog is highly self-selected (thus the importance of the 'w/o googling first hint', which might still be ignored) -- and the answers are free-text, which is more work to analyse. I assume 50% of TDF blog readers are very much not aware about "connected text blocks" when not hinted at it explicitly or implicitly at them[1] before. As blog readership is self-selected, 50% TDF of blog readers being aware translates to 99% of the general user base not being aware of "linked text frames".

Anyway, so far I havent heard one good reason to use the ambiguous and technical wording with 'link' for the text frame feature. Thus using "Form a Single Text Chain" instead of any wording using 'link' seems to have no drawbacks, but only advantages. As such, unless I overlooked a drawback, THAT change should be non-controversal (and should not need any surveys) as it unclutters the problem space quite a bit already.

Another reference: https://manuals.info.apple.com/en_US/Pages09_UserGuide.pdf seems to use both 'hyperlink' and 'link' interchangeably in the UI. Sadly there does not seem to be any newer version available.

[1] https://en.wikipedia.org/wiki/Priming_(psychology)
Comment 15 Björn Michaelsen 2016-11-06 19:28:35 UTC
(In reply to Björn Michaelsen from comment #14)
> Anyway, so far I havent heard one good reason to use the ambiguous and
> technical wording with 'link' for the text frame feature. Thus using "Form a
> Single Text Chain" instead of any wording using 'link' seems to have no
> drawbacks, but only advantages. As such, unless I overlooked a drawback,
> THAT change should be non-controversal (and should not need any surveys) as
> it unclutters the problem space quite a bit already.

(Hint: If confirmed, this means this might be an EasyHack that UX might both create and promise to mentor.)
Comment 16 Luke 2016-11-06 21:50:53 UTC
Björn Michaelsen,

With all due respect, are you a native English speaker? Maybe it's just your style, but even your written comments come off as stilted. Your claim that "Hyperlink is terribly dated vocabulary" is patently false for us native speakers. 

No disrespect, but you are making things more confusing without any benefit. Any native English speaker with basic computer literacy knows exactly what ‘hyperlink’ means and does not find it confusing. The overload term 'link' can be confusing.
Comment 17 Luke 2016-11-06 22:04:55 UTC
As far as the Pagemaker link being, old. Yes, it was. Funny thing is they changed their name. But you know what didn’t change? They still call refer to URLs as 'hyperlink' in both the documentation and the program itself.  Proof here from Adobe's help site: 

https://helpx.adobe.com/indesign/using/hyperlinks.html
Comment 18 Björn Michaelsen 2016-11-06 23:22:05 UTC
(In reply to Luke from comment #16)
> Your claim that "Hyperlink is terribly dated vocabulary" is patently false for us native speakers.

Citation needed (just as is for my original assumption that 'hyperlink' is being dated).

> Any native English speaker with basic computer literacy knows exactly what
> ‘hyperlink’ means and does not find it confusing.

I still find that doubtful. I assume that asking 20 random people (which is the target audience for LibreOffice, not people on bugtrackers) on the street of a native english speaking country will only yield a minority confidently be able to answer the question "Can you tell what the difference between a hyperlink and a link in your browser is?" with "There isnt one." -- Most will assume a 'hyperlink' to be some Magic Thing that is special and different from the 'normal' link they know from their browser.

Anyway, the 'native english' thing was and is just a limitation of the scope of this discussion. There have been assumptions this would apply to all l10ns (https://bugs.documentfoundation.org/show_bug.cgi?id=101442#c29), which isnt the case. So Im not claiming any authority as a native speaker at all.

(In reply to Luke from comment #17)
> https://helpx.adobe.com/indesign/using/hyperlinks.html

Thanks, that is helpful.

FWIW, whatever the word used for (hyper)links in the end, we should use the same word everywhere (which we obviously didnt before) and not mix hyperlink and link as e.g. the pages manual did. So when we use hyperlink as a noun, we should use it everywhere (same for the use of a 'linking'/'hyperlinking' verb, even though mixing consistent 'hyperlink' as noun and 'linking' as verb is fine).
Comment 19 Luke 2016-11-07 02:49:32 UTC
I totally agree that consistency is paramount. When it comes to picking the best terms, I do not think polling is the answer either. As you pointed out, we’re not your “average users”.

I propose we survey as many office suites and desktop publishing programs we can. We should use the latest version to make sure nothing is dated. Let’s pick the term based on the accepted industry standard for current software. 

This way users coming from other applications will be comfortable. And we avoid all the polling issues of leading questions and sampling errors.
Comment 20 Björn Michaelsen 2016-11-07 08:18:28 UTC
(In reply to Luke from comment #19)
> I propose we survey as many office suites and desktop publishing programs we
> can. We should use the latest version to make sure nothing is dated. Let’s
> pick the term based on the accepted industry standard for current software. 

Another reference point: google docs simply uses "Insert Link" in the text processor UI as of now.
Comment 21 Cor Nouws 2016-11-09 12:11:49 UTC
above all, we're stuck in a mess now, and are far from having sight on a balanced and supported solution :(
Comment 22 V Stuart Foote 2017-03-23 20:08:09 UTC
Adolfo, *

It looks like you've tracked down all the link/hyperlink use instances. So, should now be consistent even if the "Reference externally" nomenclature Björn had suggested was not picked up.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b66b3050c466de0382c3571909ba0450cdd3fd1d